From BlenderWiki

Jump to: navigation, search

Introduction

Since so many hopeful developers struggle getting a good dev environment setup (across all OS's), I have made a virtual appliance setup with developer tools setup already.

There is no secret sauce here, all thats done is documented:

What you Get

Arch linux vbox dev env.png

Whats Missing

  • Web browser (can install later)
  • Popular editors VIM and Emacs (can install later)
  • Some blender dependencies are disabled to reduce size - OpenEXR for example.

Download

Download the VirtualBox appliance (840mb)
http://www.graphicall.org/ftp/ideasman42/blender_dev_env.ova

Last Updated: r55976. 12/04/2013

VirtualBox Setup

Brief instructions

  • Install VirtualBox
  • Start VirtualBox
  • File -> Import Appliance...
  • Select OVA file
  • Finalize import (will take a few minutes to extract disk image)
  • Right click on newly imported OS -> Settings -> Display -> Enable 3D Acceleration
  • Press Start, the system will boot into a lightweight desktop.

Usage

QuickStart

The purpose of this pre-built system is not to baby new devs along by hiding details of setup, rather to save them time by providing a pre-built environment where they can hit the ground running.

Once you boot into desktop you can immediately open QtCreator from the desktop and press "Build" (Build -> Build or Hammer icon on bottom left). This will take some time since its building for the first time. While blender is building you can navigate the source, you can view the "Window -> Output Panels -> Compile Output".

One the build is finished you can run or debug blender (arrow icons on lower left).

After this, incremental builds will be much faster.

Note: this system runs as root, if you need to login use root with an empty password.

Running Blender

From QtCreator:
Build -> Run

From the command line:

cd ~/blender-svn/build_linux/bin
./blender

Building Blender

From QtCreator:
Build -> Build

From the command line:

cd ~/blender-svn/build_linux
make

Configure CMake

You may want to enable/disable build-time features or change compiler options.

cd ~/blender-svn/build_linux
cmake-gui .

... after changing options you will need to rebuild

Updating Source (SVN)

This gets you the most recent sources used by developers
From QtCreator:
Tools -> Subversion -> Update Repository

From the command line:

cd ~/blender-svn/blender
svn up

Undo Changes (SVN)

You may mess up blenders source code and want to reset the source to their original state

From the command line:

cd ~/blender-svn/blender
svn revert . -R

Updating QtCreator Project File

Ideally this would be done automatic, for now you have to do manually when files are added/removed from SVN

From the command line:

cd ~/blender-svn/blender
make project_qtcreator

Updating Linux OS

Not really needed but you may want to get recent packages

From the command line:

pacman -Suy

For more info see: https://wiki.archlinux.org/index.php/Pacman

Viewing Changes

Its nice to see before/after changes you make

From QtCreator:
Tools -> Subversion -> Diff Repository

From the command line:

meld ~/blender-svn/blender

Installing Packages on Linux OS

You may want to install a browser for reading docs while developing

From the command line:

pacman -S firefox

Shutting Down the Linux OS

You can simply save the state of the system in VirtualBox, otherwise you can shutdown from the command line

From the command line:

halt

Python Scripts

For this installation python scripts are used 'in-place', this means the scripts from SVN are used by blender at runtime. This has the advantage that you can edit them and re-run blender to see the results.

To edit scripts open "Geany" - a lightweight IDE, and you can navigate the scripts directory and edit them.

Known Issues

  • Multiple blender windows won't display text properly, this is a limitation with VirtualBox OpenGL acceleration.