From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.


Ваша первая анимация за 30 плюс 30 минут часть I

Эта глава проведет вас через анимирование несложного персонажа под названием "Пряничный человечек" (gingerbread man, человечек из имбирного теста). Мы опишем полностью каждый шаг, но мы полагаем, что вы уже прочли interface главу, и что вы понимаете понятия, используемые в этой книге.

В Части I этого урока мы создадим неподвижную фигурку пряничного человечка. Затем в Части II, мы заставим его пройтись.

Разогрев

Итак, запустим Blender. На экране вы должны увидеть вид сверху (top view), установки по умолчанию. Камеру, источник света и куб. Выделите куб, он окрасится в розовый цвет. (Стандартный экран Blender'а, как только вы его запустили.).

Стандартный экран Blender'а, как только вы его запустили (уменьшенное).

Мы организуем наше рабочее пространство, поместив объекты в разные слои, где мы сможем спрятать их; мы можем также вернуть их обратно в текущую сцену, когда они нам понадобятся. Вот как работают слои:

Layer visibility controls.

Blender предоставляет вам двадцать слоев для того, чтобы организовать вашу работу. Вы можете увидеть, какие слои в данный момент видны в группе из двадцати кнопок в заголовке 3D окна (3D window header) (Управление видимости слоями (Layer visibility controls). Вы можете изменить видимость слоев LMB Template-LMB.png и переключить видимость ⇧ ShiftLMB Template-LMB.png. Последний выбранный слой становится активным слоем. Активный слой - тот слой, куда будут помещены и где будут храниться все вновь созданные объекты.

Итак, давайте очистим место.

Layer control toolbox.

Выделите камеру и источник света ⇧ ShiftRMB Template-RMB.png и нажмите M. Появится панель выбора слоев. Отметьте крайнюю правую кнопку верхнего ряда а затем кликните на OK. Это переместит камеру на слой 10.


Теперь убедитесь, что только Слой1 видим, потому что мы не хотим стереть лампу или камеру; выберите все на этом слое, используя клавишу A и сотрите клавишей X >> Стереть Выбранные Объекты. Теперь рабочее место организовано и мы можем заняться нашим моделированием.

Тело человечка

Переключитесь в фронтальный вид клавишей 1 NumPad и добавьте куб (если он отсутствует) нажатием клавини Space >> Add >> Mesh >> Cube. Куб появится и будет он в EditMode.

Наш куб в Режиме редактирования, все вертексы выбраны.

EditMode - это режим, в котором вы можете редактировать вертексы сети (mesh). По умолчанию все вертексы выбраны для каждого вновь созданного объекта (выбранные вертексы подсвечены желтым, не выбранные розовым).

Назовем нашего пряничного человечка Гасом. Первым нашим заданием станет создание тела Гаса, что мы сможем сделать, поработав над вертексами нашего куба. Взгяните на инструменты Blender'а, их-то мы и будем использовать для этих целей. Нажмите кнопку с изображением квадрата с желтыми вертексами в заголовке Окна Кнопок (Button window), либо нажмите F9 Убедитесь ,что находитесь в режиме редактирования EditMode. Для перехода в режим редактирования нажмите ⇆ Tab

Кнопки редактирования в Окне Кнопок.

Теперь найдите кнопку Subdivide в панели Mesh Tools и нажмите на нее один раз (Окно кнопок редактирования для Сетки(Mesh)). Это разделит каждую грань куба на две, добавив новые вертексы и фейсы (faces).

The Mesh Tools panel in the Edit context (F9).
Куб поделен Один раз.

Наведите курсор на 3D окно и нажмите A, чтобы снять выделение со всех элементов. Вертексы станут розовыми.


Limit sel button.PNG
Box Select
Во многих случаях у вас могут быть скрытые вертексы за другими вертексами, как в этом случае. Наш разделенный (subdivided) куб состоит из 26 вертексов, но пока вы видите только девять, потому что другие скрыты. Обычный RMB клик выбирает только один из этих (stacked) вертексов, тогда когда выбор рамкой выбирает их все.(Имеется в виду, что в ситуации, когда один вертекс накладывается на другой правым кликом вы можете выбрать только видимый вертекс, а при выборе рамкой вы вибираете все вертексы, которые спрятаны за видимым вертексом. Такие вертексы, которые проецируются в один называются стэком. прим. перев.) Но имейте в виду, что это справедливо только для каркасного метода рисования (wireframe drawtype) : в любом другом режиме - Раскрашенном (Shaded), Полнотелом (Solid) либо Текстурированном (Textured) мы можем выбрать только верхние вертексы по умолчанию, даже при выботе рамкой (box select). Чтобы выбрать вертексы, скрытые за другими отключите Limit selection button(кнопка ограничения выбора). Смотрите изображение справа.



Теперь нажмите B, курсор изменится на пару ортогональных серых линий. Нажмите и удерживайте LMB Template-LMB.png, затем потяните мышь вниз и вправо так чтоб в серую рамку попали все левосторонние вертексы. Теперь отпустите LMB Template-LMB.png.

Череда выбора рамкой группы вертексов.
Выпадающее меню удаления (X).

Нажмите X и из появившегося меню выберите Vertices чтоб стереть выбранные вертексы.

Зеркальное моделирование

Чтобы моделировать симметричные Объекты мы можем использовать модификатор Зеркало (Mirror modifier). Это позволит нам моделировать только одну сторону Газа, тогда как Blender будет создавать другую в реальном времени. Идем в Edit context (F9) и ищем панель Модификаторы.

Панель Модификаторыl.
Список модификаторов.

Пока панель пуста. Жмем кнопку с обозначением Add Modifier и открываем список, из которого выберем Mirror(Список модификаторов).

Ничего существенного кажется не произошло; это все потому, что модификаторы незаметно предлагают проконтролировать что показывать, а что нет. В нашем случае мы отметим кнопку Cage Mode(Ограниченный режим) так мы сможем видеть прозрачные фейсы в режиме редактирования.

Cage Mode button.(Кнопка Ограниченного Режима)

Выберем ось, по которой будет зеркально перпендикулярно копирована сторона нашего персонажа. Blender предлагает зеркальное отображение по осям X, Y и Z. В нашем случае это ось X.

Ось перпендикулярная зеркальной плоскости.

Кнопка Пределы Внедрения (Merge Limits button) служит для сохранения сети. Любой вертекс, расположенный ближе к оси зеркала, чем предел который мы установили, будет помещен прямо на плоскость зеркала. Предел может быть установлен от 0.000 до 1.000 единиц и его величина будет зависеть от содержания и масштаба сцены.

Для моделирования Гаса, вертексы которые будут далее 0.1 единицы от плоскости зеркала будут видны, а все что ближе - нет. Наша сеть должна окончиться обрывом посредине, если вертексов, которые должны быть на плоскости зеркала, там не будет. Чтобы предотвратить неумышленное разбрасывание блуждающих вертексов, которые могут вызвать некоторые проблемы мы поставим пределы внедрения равным 0.1.

Кнопка Предела Внедрения.

Наконец, отметим кнопку Do Clipping (Do Clipping button), наше зеркало станет границей, которую не сможет пересечь ни один вертекс. Если это произойдет, это приведет к небольшой неразберихе. Также, когда активна Do Clipping, каждый вертекс, который находится на зеркале липнет к нему.

Кнопка Do Clipping.

Как видите, модификатор Зеркало дает нам огромные возможности облегчить нашу жизнь.

Руки и Ноги

Давайте сделаем Гасу руки и ноги. Используя последовательность, которую мы только что изучили, выберем Рамкой два верних правых вертекса. Нажмите E и кликните на Область(Region) в откывшемся меню чтобы выдавить их. Это создаст новые движимые вертексы и фейсы, которые вы можете двигать мышкой. Переместите их на один или пол квадрата правее, затем щелкните LMB Template-LMB.png чтоб зафиксировать их позицию. Выдавите (Extrude) снова E еще на пол квадрата вправо. Выдавливание руки в два шага показывает эту последовательность.

Выдавливание руки в два шага.

Отмена/Повтор

В Blender есть две возможности отмены, одна для EditMode(Режим Редактирования) и другая для ObjectMode(Объектного режима).

В EditMode(Режиме редактирования) нажмите CtrlZ, чтобы отменить и продолжайте нажимать CtrlZ, чтобы откатить назад изменения настолько, насколько хватит буфера обмена; ⇧ ShiftCtrlZ Возвращает отмененные изменения. AltU открывает меню со списком возможных отмен, так вы сможете легко найти точку, к которой вы хотели бы вернуться.

Два замечания на память:

  • Отмена(Undo) в EditMode(Режиме Редактирования) работает только для объектов, которые находятся в этом режиме.
  • Информация об отмене (Undo data) не теряется, когда вы переключаетесь из EditMode(Режима Редактирования), но она теряется как только вы начинаете редактировать другой объект EditMode(Режиме Редактирования).

В ObjectMode(Объектном Режиме) применяются те же горячие клавиши CtrlZ для отмены, ⇧ ShiftCtrlZ для повтора и AltU, чтобы увидеть историю. Если вы внесли изменения в EditMode(Режиме Редактирования), которые не потеряны для этого объекта, они все будут отменены одним простым нажатием CtrlZ когда этот шаг --отмечен как Editmode(Режим Редактирования) в ObjectMode(Объектном Режиме) (AltU) история -- вернет его.

Другой путь избежать неприятности нажимать Esc в середине действия. Это отменит действия возврата к предыдущему состоянию.

Coincident vertices

Если вы выдавливаете, и во время перемещения передумали и нажали Esc или RMB Template-RMB.png для отказа, выдавленные вершины будут все еще там, в их изначальном расположении! Пока вы можете двигать, масштабировать либо поворачивать их нажимая G,S или R, вы возможно не захотите выдавливать их снова.

Проще говоря, чтобы избавиться от чего-то нужно вернуться на шаг назад до того как вы его создали клавишей CtrlZ.

Тело.

Теперь у Гаса есть левая рука которую вы смоделировали (он к нам лицом) и правая рука, которую добавил Blender. Мы сделаем левую ногу тем же способом - выдавливая нижние вершины. Попробуйте произвести нечто похожее на (Тело). Вам понадобится отжать кнопку "Do Clipping", если вы использовали ее раньше (иначе Гас будет оканчиваться скорее юбкой чем штанами). Опустите ноги на полторы клетки, затем нажмите G и поверните их как нужно. Продолжайте ,пога ноги не будут готовы.

Заметка
Мы использовали инструмент Выдавливание(Extrude) три раза, чтобы сделать ногуg. Пока мы не беспокоимся о локтях и коленях, но они нужны нам будут для суставов позже!


Мы покончили с зеркальным моделированием. В следующих шагах мы поэкспериментируем с другими техниками. Нам необходимо сделать правую часть нашей модели реальной, до тех пор, пока мы не применим изменения ('apply changes'), с модификаторами ничего не произойдет. Переведем Газа в ObjectMode(Объектный режим) (нажмем ⇆ Tab), кликнем на кнопку Apply(Применить)в модификаторе Mirror(Зеркало).

Вы увидете кнопку подтверждения:

Применение изменений удалит липкие сети, ключи, и группы вершин

Нажмите LMB или ENTER чтоб принять

Движение курсора
Чтобы поместить курсор в специфическую точку сетки, разместите ее где вам необходимо и нажмите SHIFT+S чтоб добраться до Меню Шага (Snap Menu). Значение Cursor to Grid(Курсор к Сетке) поместит курсор точно на точку сетки. Cursor to Selection(Курсор к Выбранному) поместит его точно на выбранные объекты. Другие опции не применимы к курсору.

Голова

Газу Нужна голова.

Переключитесь назад EditMode (нажмите ⇆ Tab)

  • Переместите курсор точно на один квадрат над телом Газа (Самое левое изображение Добавление головы) и добавьте новый куб (Space>ADD>Cube).
  • Нажмите G, чтобы переключиться в Grab Mode(Режим Захвата) и переместите вновь созданные вершины(вертексы) вниз, ограничивая движение MMB Template-MMB.png примерно на одну треть ячейки сетки (Самое правое изображение Добавление головы.).
Добавление головы.

ПодПоверхности(subsurf)

Модификатор Subsurf в понели Модификаторов в контексте Редактирования(F9)

Итак дальше мы должны создать дутую(rough) фигуру как лучше. Чтоб сделать ее округлее, поместите Modifier panel (F9(Editing) и добавьте Subsurf модификатор, (Модификатор Subsurf в панели Модификаторов). Будте уверенны чтоб установить оба Levels NumButtons ниже или на 2. Первый Level для того что вы увидите в области 3D окна, второй для рендера.

SubSurfaces
ПодПоверхность - это продвинутый инструмент для моделирования, он динамично улучшает представленный меш, создает более плотно наполненый вершинами меш и распологает вершины улучшенного меша так, что они гладко следуют за вершинами изначального меша. Поверхность(shape) объекта все еще контролируется расположением вершин грубой меша, но отображаемая(rendered) поверхность окончательно гладкая.


  • Переключитесь обратно из редима редактирования (⇆ Tab) и из данного Каркасного (Wireframe) режима в Твердотельный (Solid) используя Zчтоб взгянуть на Газа. Он должен выглядеть (Установка Газа в гладкое сотсояние, слева).
Установка Газа в гладкое сотсояние.
  • Чтоб заставить Газа выглядеть глаже, нажмите кнопку SetSmooth найденную в панели Link and Material в контексте Редактирования (F9). Теперь Газ выглядит достаточно гладко, но возможно он выглядит немного странно через его тело посредине проходит черная полоса. Обычно это вызвано тем что вы использовали модификатор Mirror, но такое может произойти если выдавливать(extrude) или зеркалить (flip), как это было сделано перед тем как модификатор был вклюен. (Установка Газа в гладкое сосотояние., посредине). Эти линии появляются потому что улучшение мэш ПодПоверхности (SubSurf's finer mesh) рассчитыввается используя информацию о направлении нормалей грубой мэш, когда некоторые точки могут оказаться в другом направлении, из-за этого нормали некоторых фейсов должны быь развернуты наружу, а некоторые внутрь. Чтоб сбросить состояние нормалей, переключитесь назад EditMode кнопкой (⇆ Tab), выберите все вертексы (A), и нажмите CtrlN. Кликните LMB Template-LMB.png Recalculate normals outside в появившемся окне. Теперь Газ должен быть хорош и гладок (Установка Газа в гладкое сосотояние, справа).

Нажмите MMB Template-MMB.png и потяните мышь вокруг чтоб посмотреть на Газа под разными углами. Опа, он слишком толстоват!

Чтоб исправить этоt, переключимся в боковой вид 3 NumPad. Теперь, переключитесь EditMode (если вы уже не в этом режиме), Затем переключитесь в режим Сетки (Wireframe) (Z), и выбирете все вертексы клавишей A.

Принудительное масштабирование

(Делаем Gus тоньше используя принудительное масштабирование., слева).

Делаем Gus тоньше используя принудительное масштабирование.

Давайте сделаем Gus тоньше:

  • Нажмите S и двигайте мышь горизонтально. (зажмите MMB Template-MMB.png для принудительного масштабирования по одной оси или нажмите Y для достижения того же результата.). Если вы сейчас будете двигать мышью по направлению к Gus, то он станет тоньше, но сохранит какую-то ширину.
  • Три числа отображают характеристики изменения размеров. С принудительным масштабированием по оси Y, только одно из них будет изменяться. Нажмите и удерживайте Ctrl. Теперь харатеристики масштабирования будут изменяться на значение '0.1'. Сделайте толщину Gus равной 0.2.
  • Вы можете вращать ваш угол обзора с помощью MMB Template-MMB.png. Убедитесь, что Gus стал значительно тоньше!

Давайте посмотрим, на кого он похож

Мы не можем больше ждать и хотим сделать первый рендеринг! Для этого нам необходима предварительная подготовка.

Making both layer 1 and 10 visible.
  • Кликните ⇧ ShiftLMB Template-LMB.png по верхней правой кнопочке в панели управления слоями, чтобы сделать видимыми слой 1 (с Гасом) и слой 10 (с камерой).
A Tip
Запомните, что последний выбранный слой является активным, поэтому все последующие добавления будут происходить в десятый слой.
  • Выберите камеру (RMB Template-RMB.png) и переместите ее приблизительно (x=7, y=-10, z=7). Для этого нажмите G и перетащите камеру зажав Ctrl перемещение будет происходить на 1 единицу сетки.

Ввод точных данных расположения и вращения

The Panel for numerical input of object position/rotation etc.

Если вы предпочитаете вводить цифровые значения с клавиатуры, вы можете это сделать так: нажмите N, появится панель с цифрами, теперь можно изменять значения. За координаты объекта отвечают строчки LocX,Y,Z.

Настройка камеры

Чтобы направить камеру на Гаса, выделите камеру, затем выделите Гаса с зажатой ⇧ ShiftRMB Template-RMB.png. Камера будет сиреневая, а Гас светло-розовый. Нажмите CtrlT и выберите пункт Track to Constraint, слежение с привязкой. Это заставит камеру следить за Гасом и она все время будет направлена на него. Теперь вы можете перемещать камеру куда захотите и будте уверены, что Гас всегда будет в центре камеры!

Tracking, слежение
Если вы выберите Old Track и камера уже имеет некоторое вращение (что случается очень часто), это не даст желаемого результата. В этом случае выберите следящий объект (в данном случае камеру), и нажмите ALT-R чтобы очистить вращение. После этого камера будет четко следить за Гасом.

На рисунке показан Гас при виде сверху, спереди, сбоку и из камеры. Чтобы включить вид из камеры нажмите 0 NumPad.

Camera position with respect to Gus.

Земля

Теперь нам необходима поверхность, на которой Гас будет стоять.

  • При виде сверху (7 NumPad), с выключенным режимом EditMode, добавьте плоскость (Space>>ADD>>Mesh>>Plane).
Note
Важно быть вне режима редактирования, иначе новодобавленный объект станет частью другого объекта, который в данный момент в режиме редактирования (как это было с головой Гаса, когда мы ее добавляли). Плоскость добавится в месте курсора, в середне туловища Гаса.
Set the reference center to Object center.
  • Находясь в объектном режиме ObjectMode ⇆ Tab, в виде спереди(1 NumPad) переместите (G) плоскость вниз к ногам Гаса, исользуйте Ctrl чтобы сохранить выравнивание с Гасом.
  • Переключите центр модификаций объекта (Pivot, опорную точку) от курсорного 3D Cursor, (который мы включали в начале), к средней точке Median Point нажав кнопку как на рисунке.
  • Перейдите на вид из камеры (0 NumPad) и, с выбранной плоскостью, нажмите S чтобы начать масштабирование.
  • Увеличьте плоскость так, чтобы ее края заходили за пределы видимости, обозначеной внешней пунктирной рамкой при виде из камеры.


Освещение

Теперь добавим света!

  • При виде сверху (7 NumPad), переместите существующую лампу (если у вас её нет, то добавьте Space>>ADD>>Lamp) спереди от Гаса,но с другой стороны по отношению к камере; например (x= -9, y= -10, z=7).
Inserting a Lamp.
The Lamp Buttons window button.
  • Переключитесь на кнопки освещения Lamp Buttons. Кликните по кнопке с рисунком лампочки или F5.


  • В кнопках на панели Preview, выберите тип освещения Spot сделав из лампы прожектор. Придайте желтоватый цвет (R=1, G=1, B=0.9). Включите Buf.Shadow, установите начало освещения ClipSta: = 5, качество размытости тени Samples: = 4, величину размытости тени Soft: = 8.
Spot light settings.
  • Сделайте так, чтобы прожектор следил за Гасом также, как это было сделано для камеры. Выберите лампу, ⇧ Shift, затем Гаса, нажмите CtrlT, Old Track. Возможно вам потребуется очистить вращение лампы AltR.
  • При виде сверху добавьте вторую лампу около прожектора (Space>>ADD>>Lamp). Эту лампу сделайте типа Hemi, установите яркость Еnergy на 0.6
The Hemi lamp settings
Две лампы?
Использование двух и более ламп помогает сделать освещение более мягким и реалистичным. Потому что в реальности свет никогда не приходит только из одной точки.

Рендер

Теперь мы готовы к рендерингу. Перейдите к кнопкам рендера нажав кнопку с изображением картинки, или F10.

The Rendering buttons window buttons.

В панели Format установите размер картинки 640x480. В панели Render проверьте включите кнопку теней Shadows, и сглаживание (ОверСемплинг Антиалиасинг) OSA. Это предотвратит появление резких ступенек в местах перехода цветов.

The Rendering Buttons window

Теперь вы можете нажать кнопку RENDER или F12. Результат на картинке слишком скучный. Нам необходимы материалы и некоторые детали, такие как глаза, рот, пуговицы.

Your first rendering. Congratulations!

Сохранение работы

The Save menu.

Если вы этого еще не сделали, то сейчас самый раз сохранить вашу работу через меню File>>Save, или CtrlW, или CtrlS. Blender всегда предупредит вас, если вы станете перезаписывать уже существующий файл.

Blender делает автосохранение вашей работы во временную папку. По умолчанию это происходит каждые четыре минуты, имя файла состоит из цифр. Это еще один способ вернутся к предыдущим состояниям сцены, отменить неудачные изменения, вернуть файл после "вылета" блендера.

Материалы и текстуры

Настало время придать Гасу хороший материал, наподобие имбирного печенья.

The Material Buttons window Button.
  • Выберите гаса. В заголовке окна кнопок выберите нажмите кнопочку с серым шариком (Shading), рядом включится кнопка с красным шариком (кнопки материалов) или нажмите F5.


The Material Menu button.
  • Окно кнопок будет почти пустым, потому что у Гаса пока что нет материала. Чтобы добавить материал, найдите панель Link and Pipeline и нажмите в ней прямоугольную кнопку Add New, или рядом, маленькую квадратную кнопку, со стрелками, и из меню выберите Add New.


  • В окне кнопок, появятся несколько панелей с кнопками, а вместо надписи Add New,

появится строка с названием материала (по умолчанию "Material"). Измените его на что-то осмысленное, типа GingerBread (Рыжий Хлеб, т.е. пряник).

  • Измените значения материала так, как на показано на рисунке, чтобы получить

предварительный материал (подвигайте ползунки R G B, Spec=0.05, Hard=5).

The Material Buttons window and a first gingerbread material.
  • Справа в панели Textures нажмите Add new. Мы добавили текстуру в

первый канал. Назовите ее, например "GingerTex".

The Textures menu button in the Material Buttons
The Texture Buttons window Button.
  • Перейдите к кнопкам текстуры (как на рисунке) или нажмите F6.


  • В панели Texture из списка Texture Type выберите Stucci

(штукатурка) и настройте параметры как на рисунке (The Texture Buttons window with a stucci texture).

The Texture Buttons window with a stucci texture.
  • Вернитесь к кнопкам материалов (F5) и перейдите ко вкладке Map

To. Отключите кнопку Col (цвет) и включите Nor (нормали), затем установите движок Nor на значение 0.75 (можете зажать Shift). Это придаст нашей текстуре Stucci рельефность (bump map) и сделает Гаса более похожего на хлеб.

Settings for the Stucci texture in the Material Buttons window.
  • Сейчас добавьте вторую текстуру, назовите "Grain" (зернистость), настройте ее,

включив только Ref и ползунок Var установите на 0.4. Используйте простую текстуру Noise.

Settings for an additional Noise texture in channel 2.
  • Добавьте также материал и для пола, например темно-синий.
A very simple material for the ground.

Глаза и детали

Осталось добавить пару последних штрихов, это глаза и некоторые другие детали.

  • Сначала включите только 1 слой, кликнув LMB Template-LMB.png по кнопке первого слоя. Это

скроет лампы, камеру и пол.

Layer visibility buttons on toolbar.
  • Поместите курсор по центру головы Гаса, только учтите, что вы в 3D-пространстве,

и вы должны проверить расположение курсора минимум в двух видах!

  • В ObjectMode добавьте сферу

Space>>ADD>>Mesh>>UVsphere). Вас спросят о количестве меридианов (Segments) и паралелей (Rings, кольца) из которых будет состоять сфера. Значение 32 слишком большое для нашей задачи, поставьте по 16. Появится сфера, см. рисунок.

  • Уменьшите её (S) до значения 0.1 по всем направлениям, затем

переключитесь на вид сбоку (3 NumPad) и масштабируйте ее только в горизонтальном направлении (Y) до 0.5.

Sequence for creation of the eyes.
  • Если необходимо, то увеличьте вид + NumPad, Wheel Template-MW.png, или CtrlMMB Template-MMB.png, перетащите

сферу (G) влево так, чтобы она находилась на половине головы.

  • Вернитесь на вид спереди (1 NumPad) и передвиньте сферу вправо. Поместите ее там,

где у Гаса должен быть глаз.

  • Отразите зеркально дубликат глаза, относительно курсора:
Выберите в заголовке 3D окна символ перекреситя (опорная точка, Pivot), в

EditMode (режиме редактирования) нажмите A чтоб выделить все вершины, ⇧ ShiftD для дублирования, Esc чтобы остановить перемещения мышкой, и M,X для зеркалирования.

Теперь у Гаса два глаза.

Рот

  • Выйдите из режима редактирования (⇆ Tab), и разместите курсор как можно

точнее в центр лица Гаса. (помните про ⇧ ShiftS, Cursor->Grid). Добавьте новую сферу и масштабируйте/перемещайте ее как описано раньше, но сделайте ее меньше и разместите ниже, правее курсора на пересечение линий, как на рисунке.

Creating a mouth with Spinning tools.
The Spin Tools buttons in the Edit Buttons window.
  • Теперь, в режиме редактирования (⇆ Tab), в кнопках редактирования

(F9) найдите вкладку Mesh Tools. Установите угол Degr: значение 90, шаг Steps:=3, и проверьте что направление вращения Clockwise: (по часовой стрелке) включено. Затем, когда все вершины выделены, нажмите SpinDup. Это создаст 3 дубликата выбранных вершин, по дуге в 90 градусов отностительно центра курсора. В результате у Гаса появился рот.

Теперь, имея кое-какой опыт, добавьте несколько сплющенных сфер, создав Гасу пуговицы. Сделав одну, выйдите из режима редактирования, нажмите ⇧ ShiftD to продублируйте ее несколько раз и разместите как на рисунке.

The complete Gus!

Материал для глаз

Дайте глазам шоколадно подобный материал, как на верхней части картинки Some other candy materials.. для рта назначьте белый, как сахар, материал, как на среднем рисунке, пуговицы сделайте красной, белой и зеленой.

Some other candy materials.


Material Menu.
Совместное использование материалов
Чтобы назначить текущему объекту такой

же материал, как и у другого объекта, перейдите в панель Link and Pipeline, и из раскрывающегося списка выберите нужный материал. Если материал не

используется, то между иконкой и именем материала появляется символ O


Rendering

Когда закончите с материалами, установите 10 слой снова видимым, (помните как? посмотрите на заголовок 3D окна). Появятся лампа и камера, сделайте рендер

(F12).

Результат должен быть похож на рисунок.

The complete Gus still rendering.

Сохранение

File type selection menu in the Rendering Buttons window.

Теперь вы можете сохранить вашу картинку. Нажмите F3. Введите в поле имя картинки и сохраните, нажав Enter.

Вы должны выбрать формат файла (JPEG, PNG, TIFF, BMP, TARGA. GIF не поддерживается! ) ДО нажатия F3. Во вкладке Format из раскрывающегося списка выберите нужный тип файлов.

Blender умеет сам добавлять расширение файла после имени файла.