From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Открытие файлов

Режим: Все режимы

Горячая клавиша: F1

Меню: File → Open

Описание

Blender использует формат файла .blend, чтобы хранить практически все: Объекты, Сцены, Текстуры и даже все настройки окон пользовательского интерфейса.

Внимание
Blender ожидает от вас, что вы знаете что делаете! Когда вы открываете файл, вас не спросят о сохранении изменений в текущей сцене, над которой вы работали; подтверждение в диалоге о загрузке файла, считается достаточным подтверждением тому, что вы делаете это не случайно. Убедитесь, что сохранили свои файлы.


Опции

Чтобы загрузить Blender файл с диска, нажмите F1. Окно под курсором мыши временно станет Окном выбора файлов (File Selection window), как показано на картинке Окно выбора файлов - загрузка). Полосу прокрутки слева можно перетаскивать LMB Template-LMB.png для прокрутки. Чтобы загрузить файл, выберите его нажатием LMB Template-LMB.png и нажмите ↵ Enter, или просто кликните LMB Template-LMB.png на кнопке Open File. Файл также может быть загружен кликом MMB Template-MMB.png на имени требуемого файла. После этого он загрузится, как если вы нажали enter.

Окно выбора файлов - загрузка

Верхнее текстовое поле отображает путь и текущую директорию, а нижнее содержит имя выбранного файла. (P) переходит вверх к родительской директории, а кнопка со стрелками содержит список недавно использовавшихся путей.

Совет

В операционной системе Windows, список вызываемый этой кнопкой содержит также список всех дисков (C:, D:, и т.д.).

Сохранение файлов

Режим: Все режимы

Горячая клавиша: F2

Меню: File → Save

Описание

Сохранение файлов подобно загрузке файлов. При нажатии F2, окно под курсором мыши временно становится Окном выбора файлов, как показано на Окно выбора файлов - сохранение.

Опции

Окно выбора файлов - сохранение

Кликните нижнее текстовое поле для ввода имя файла. Если оно не заканчивается на ".blend," расширение будет автоматически добавлено. Нажмите ↵ Enter или кликните кнопку Save file, чтобы сохранить файл.

Если файл с таким именем уже существует, вам придется подтвердить свое желание сохранить файл при запросе на перезапись.

Совет

Диалог сохранения файлов содержит небольшую функцию, призванную помочь вам в создании нескольких версий ваших работ: нажатие на + NumPad или - NumPad увеличивает или уменьшает номер, содержащийся в имени файла. Чтобы сохранить открытый файл, минуя диалог сохранения файлов, нажмите CtrlW вместо F2 и просто подтвердите запрос на перезапись.

Рендеринг

Режим: Все режимы

Панель: Контекст Render → Render

Горячая клавиша: F12

Меню: Render → Render Current Frame

Описание

Этот параграф дает только общее представление о том, что вам нужно для рендеринга вашей сцены. Вы найдете детальное описание всех опций в разделе Рендеринг.

Опции

Настройки рендера находятся в контексте Scene в суб-контексте Render Buttons (Опции рендеринга в суб-контексте Render Buttons), который можно открыть кликнув Manual-Part-I-RenderingButton.png или нажав F10.

Опции рендеринга в суб-контексте Render Buttons

В панели Output, верхнее поле содержит путь (path increment) (по умолчанию: "/tmp/") и, опционально, префикс имени файла, который используется при рендеринге. Путь может быть абсолютным или относительным. Абсолютным путем будет нечто вроде "C:\Documents\Blender\", а относительным будет точечная нотация ("./" или "../") означающая начало в текущей или родительской директории, относительно установочной директории Blender'a, или двойной слеш ("//") означающий директорию из которой blend файл был запущен.

Некорректные пути
Если путь является недействительным или содержит ошибки и отвергается операционной системой, ваш файл может обнаружиться в установочной директории Blender'a, корневой директории, или в другом месте.


Панель Format определяет формат рендера. Полный размер (число пикселей по вертикали и горизонтали) и формат создаваемого файла задаются здесь. Вы можете задать размер используя кнопки SizeX и SizeY. Кликнув на выпадающем списке, что находящится сразу под кнопками размера, откроется меню со всеми доступными форматами изображений и анимации, по умолчанию выбран "Jpeg" (Опции рендеринга в суб-контексте Render Buttons).

Теперь, когда все настройки сделаны, сцена может быть отрендерена нажатием кнопки RENDER на панели Render или кнопки F12. В зависимости от сложности сцены, процесс занимает обычно от нескольких секунд до нескольких минут; прогресс отображается в отдельном окне. Если сцена содержит анимацию - рендерится только текущий кадр. (Для того чтобы отрендерить всю анимацию см. Рендеринг анимации).

Если после рендеринга вы ничего не видите в окне вывода, убедитесь, что ваша сцена построена правильно. Есть ли источники света? Правильно ли расположена камера и туда ли она направлена? Все ли слои, что вы хотите отрендерить, видимы? Убедитесь, что Blender Internal выбран в выпадающем списке под кнопкой RENDER.

Сохранение на диск

Отрендеренное изображение не сохраняется на жесткий диск автоматически. Если вы довольны результатом, вы можете сохранить его, нажав F3 и воспользовавшись диалогом, как описано в параграфе Сохранение файлов. Изображение сохранится в том формате который был выбран ранее в панели Format.

Совет

Blender не добавляет расширение файла для изображений автоматически! Вы должны напечатать его самостоятельно, если это необходимо.

Настройки Пользователя и Темы

Режим: Все режимы

Описание

Blender имеет несколько опций которые не сохраняются в каждом файле, вместо этого они применяются ко всем файлам пользователя. Эти настройки подразумевают детали конфигурации пользовательского интерфейса, системные свойства вроде мыши, шрифтов и языков.

Потому, что настройки пользователя используются редко, они удобно спрятаны за главным меню. Чтобы сделать их видимыми, потяните вниз границу окна меню (обычно самая верхняя на экране). Все настройки сгруппированы с семь категорий, которые могут быть выбраны фиолетовыми кнопками, как показано на Окно настроек пользователя.

Опции

Окно настроек пользователя

Поскольку большинство кнопок говорят сами за себя или отображают полезные всплывающие подсказки, при наведении мышью, мы не станем здесь описывать их детально. Вместо этого, мы просто дадим краткий обзор категорий настроек:

View & Controls
Настройки определяющие, как интерфейс будет реагировать на ввод пользователя, как то, какой метод вращения будет использован в 3D видах. Здесь же вы можете активировать эмуляцию 3-х кнопочной мыши, если ваша имеет всего две копки. MMB Template-MMB.png может быть исполнена вводом AltLMB Template-LMB.png.
Edit Methods
Позволяет определять детали работы для некоторых команд редактирования, вроде duplicate. Вы также можете изменить число доступных шагов отмены, а также будет ли отмена работать локально или глобально. Автоматическое добавление ключевых кадров для анимации также устанавливается здесь.
Language & Fonts
Можно выбрать альтернативный TrueType шрифт для отображения интерфейса и выбрать другой язык из доступных языков интерфейса.
Themes
Начиная с версии 2.30, Blender позволяет использовать темы (Themes) для определения пользовательских цветов интерфейса. Вы можете создавать и управлять темами отсюда. Каждая тема это python скрипт. Вы можете импортировать темы, созданные другими людьми, просто скопировав .python скрипт в вашу директорию со скриптами и перезапустив Blender. Затем, открываем Scripts window и выбираем требуемый скрипт; затем жмем CtrlU чтобы сохранить как тему по умолчанию.
Auto Save
Творческий процесс очень увлекает, и художник может так сильно "зарыться" в моделирование и анимацию, что часто забывает мыться, есть и (что особенно важно) сохранять копии своей работы. Сбой компьютера, отключение питания или неудачный поворот созидательного процесса могут привести к потере или повреждению желаемого продукта. Не бойтесь с головой окунаться в творческий процесс, поскольку Blender предлагает несколько путей для автоматического сохранения копий рабочего процесса.
Эта суб-панель вам настраивать каждый из двух способов, которые предлагает Blender для отката к предыдущей версии файла. Кнопка "Save Versions" говорит Blender'у, когда вы вручную выбираете File/Save, сохранять указанное количество предыдущих версий вашего файла. В текущей рабочей директории, эти файлы будут названы .blend, .blend1, .blend2, и т.д. до числа версий заданных вами, где более старые файлы будут иметь большее число в названии. Обычно, 9 версий более чем достаточно. Клик на кнопке "Auto Save Temp Files" говорит Blender'у автоматически сохранять "горячие" резервные копии вашего рабочего процесса во временную (tmp) директорию. Нажатие этой кнопки включает еще две. Первая, кнопка "Minutes" определяет число минут между автоматическими сохранениями.
Автоматически сохраненный файл имеет имя, состоящее из случайных чисел, расширение .blend и находится в Temp директории (см. вкладку "File Paths"). Мы рекомендуем использовать эти кнопки для автоматического сохранения во временную директорию с заданным интервалом (5 - 10 минут обычно достаточно).
Затем, когда вы сделаете нечто ужасное со своей прекрасной моделью, у вас будет четыре выбора: 1) продолжать работу и постараться прикрыть (спрятать) или "строить" прямо на вашем недоразумении, 2) воспользоваться отменой нажав CtrlZ, 3) вернуться (открыть) к предыдущей версии файла сохраненного в рабочей директории, или 4) вернуться к предыдущей автоматически сохраненной версии (здесь нам вторая клавиша и пригодится). Чтобы откатиться на последнюю автоматически сохраненную версию файла, просто нажмите кнопку "Open Recent" и самая свежая копия рабочего процесса будет загружена из директории Temp.
Внимание
Нажатие на кнопку "Open Recent" немедленно загружает самое последнее сохранение и вы потеряете все изменения, что проделали с того момента.
После загрузки временной версии вы можете сохранить (File/Save) ее поверх текущего файла в вашей рабочей директории как обычный .blend файл.
Выход без Сохранения
Когда вы закрываете Blender и выходите из программы, Blender не спросит вас сохранить вашу работу, если она была изменена. Как бы то ни было, он автоматически сохранит текущий файл рабочего процесса под именем "quit.blend" в вашей Temp директории. Если вы вспомнили, что забыли сохранить файл прежде чем вышли из Blender'a, просто перейдите в Temp директорию, откройте файл "quit.blend" и сохраните его поверх вашего рабочего файла.
System & OpenGL
Вам следует обращаться к этому разделу, только если у вас имеются проблемы с выводом видео или звука, или у вас нет цифровой клавиатуры и вы хотите эмулировать ее (актуально для ноутбуков). Кроме того, здесь вы можете настроить освещение для режимов Solid и Shaded.
File Paths
Задет пути по умолчанию для большинства диалогов загрузки файлов.
  • YFexport: Blender связывается с YafRay, экспортируя XML файл. Эта позиция говорит Blender'у куда его сохранять. Рекомендуется: C:\Blender\tmp\
  • Fonts: Где искать TrueType Шрифты. Рекомендуется для XP: C:\Windows\Fonts\
  • Render: Куда складывать вывод рендера. Рекомендуется: C:\Blender\tmp\
  • Textures: Где искать изображения и картинки для текстурирования поверхностей. Рекомендуется: C:\Blender\lib\tex
  • Scripts: Расширения Blender'a. Рекомендуется: директория куда установлен Blender\.blender\scripts
  • Tex Plugins: DLL-плагины для процедурного текстурирования. Рекомендуется: C:\Blender\bin\plugin-tex
  • Sounds: wave файлы звукового сопровождения и звуковых эффектов. Рекомендуется: C:\Blender\lib\wav\
  • Seq Plugins: Для видеомонтажа у Blender'a имеется пакет спец эффектов, которые реализованы DLL'ками. Рекомендация: C:\Blender\bin\plugin-sequence\
  • Temp: Обычная сорная корзина. Рекомендация: C:\Blender\play\tmp

Настройка сцены по умолчанию

Вам не нравится раскладка окон Blender'а по умолчанию или вы хотите иметь особенные настройки рендера для каждого нового проекта, или просто хотите сохранить свою тему? Нет проблем. Вы можете использовать любую сцену, как сцену по умолчанию, с которой Blender стартует. Нажатием CtrlU вы превратите сцену над которой работаете в данный момент в сцену по умолчанию. Затем сцена будет скопирована в файл с именем .B.blend в вашей домашней директории.

Имеется в виду рабочая директория Blender'a где хранятся настройки, плагины и пр.
Прим. пер.

Вы можете очистить проект и вернуться к сцене по умолчанию в любое время, воспользовавшись пунктом меню File>>New или нажав CtrlX. Но не забудьте сохранить предыдущую сцену сначала!