From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Окно Outliner

Описание

Outliner Window используется для упрощения навигации в системе сцены. Есть 2 вида, Outliner вид и OOPS Schematic вид. OOPS Schematic и Outliner дают вам двухмерное представление вашего запутанного трехмерного мира. Используйте эти виды для поиска любых вещей в вашей сцене.

Например, вы чихнули во время перемещения объекта; ваша мышка улетела со стола (ой!) и объект оказался заброшенным за пределы экрана куда-то далеко в пространство. Просто воспользуйтесь schematic/outliner что бы найти его; выберите его, затем вернитесь в ваше 3d окно что бы поставить курсор на него и переместить его обратно.

Другой более практический пример: оценить влияние изменения на зависимые блоки данных. Предположим, вы смотрите на ваш объект TableTop, и он смотрится неправильно; материал Wood выглядит неправильно; вы хотите что бы он выглядел как красное дерево. Так как один и тот же материал может быть использован множеством объектов (mesh), вы не уверены на какое количество предметов повлияет изменение цвета при изменении материала. используя вид OOPS Schematic, вы можете найти этот материал и отследить его связи с каждым объектом в вашей сцене.


Вид Outliner

Окно Outliner в режиме списка.

Outliner - это такой список, который организовывает зависимые вещи между собой. В Outliner вы можете:

  • Просмотреть данные в сцене
  • Выбрать и отменить выбор Объектов в сцене
  • Спрятать или показать объект в сцене
  • Позволить или запретить выбор (сделать объект "невыбираемым" в 3D окне)
  • Включить или отключить отрисовку (rendering) объекта
  • Выбрать данные напрямую, такие как материалы и текстуры (они показываются автоматически в окне Buttons!)
  • Удалить объекты из сцены
  • Разорвать связь (unlink) с данными (равносильно нажатию кнопки "X" рядом с именем блока данных)
  • Легко выбрать слой RenderLayer для отрисовки (render)
  • Легко выбрать, который из проходов отрисовки (render pass) будет отрисован (например, вы можете выбрать для отрисовки только слой Specular).


Вид OOPS Schematic

Вид OOPS schematic в окне Outliner.

OOPS schematic представляет из себя своего рода картину, показывающую как связаны вещи между собой. OOPS является очень забавной аббревиатурой от Object-Oriented Programming System (Система Объектно-Ориентированного Программирования). Да, верно. Я думаю, кто-то пролил чашку кофе на свою клавиатуру одним поздним вечером и это слово было первым, пришедшим в его ум ;) В виде OOPS вы можете:

  • Посмотреть на отношения между объектами (например, которые из объектов используют одну и ту же текстуру)

Основное отличие в том, что вид OOPS schematic показывает все доступные вещи (блоки данных) в вашем .blend-файле, организованных по типу: сцены в самом низу, объекты посередине, материалы в направлении вверх. Outliner показывает вам используемые вещи вашим .blend-файлом, организованных по родительскому объекту с его потомками в виде подстрок.

Выбор окна типа Outliner

Превращение окна в окно типа Outliner используя меню Window Type.
Окно Outliner в режиме списка.


Выберите окно и щёлкните по его кнопке Window Type (самый левый значок на его заголовке) и выберите Outliner.

Переключите между видом Outliner и видом OOPS Schematic используя пункты меню View → Show OOPS Schematic или View → Show Outliner.


Размер окна
Выберите или установите размер окна таким, который наиболее подходит виду с которым вы будете работать. Вид OOPS Schematic требует широкого окна, а вид Outliner требует высокого узкого окна.


Использование вида Outliner

Каждая строка в виде Outliner отображает блок данных. Вы можете кликнуть по стрелке-вниз слева от имени чтобы развернуть текущий блок данных и увидеть какие блоки данных он содержит.

Вы можете выбирать блоки данных в Outliner, но это необязательно повлечёт за собой их выбор в самой сцене. Чтобы выбрать блок данных в сцене вы должны активировать этот блок.

Выбор и активизация


Одиночный выбор не требует никакого предварительного выбора: просто работайте напрямую с LMB Template-LMB.png и/или RMB Template-RMB.png внутри именованной области/пиктограммы.

Выбор и отмена выбора блока данных.
  • Toggle pre-selection of a group of datablock
    Useful when you want to select/deselect a whole bunch of datablocks. For this you must prepare the selection using, to your liking:
    RMB Template-RMB.png or LMB Template-LMB.png,
    ⇧ ShiftRMB Template-RMB.png or ⇧ ShiftLMB Template-LMB.png,
    RMB Template-RMB.png and drag or LMB Template-LMB.png and drag
    all outside the name/icon area.
    You then confirm with a RMB Template-RMB.png on the name/icon area to bring on a dialog.


When you select an object in the list,| it is selected and becomes the active object in all other 3D View window panes. Use this feature to find objects in your 3D View; select them in the outliner, then snap and center your cursor on them via ⇧ ShiftS->Cursor to Selection, and then C


Click LMB Template-LMB.png on the mesh data of the cube to activate Edit Mode.
  • Activate the datablock with LMB Template-LMB.png on the icon or the name of the datablock. Activating the datablock will automatically switch to the relevant mode or Buttons context. For example, activating the mesh data of the cube will select the cube and enter Edit Mode (see right). Another example is that activating the material datablock for the cube will show the material in the Material context of the Buttons window.


Context menu for the Cube object.
  • Show the context menu for a datablock with RMB Template-RMB.png on the icon or name. Depending on the type of datablock, you will have the following options (Note: some datablock types will not have a context menu at all):
    • Select
    • Deselect
    • Delete
    • Unlink
    • Make Local
  • Delete selected datablocks with X.
  • Expand one level with + NumPad.
  • Collapse one level with - NumPad.
  • Collapse/Expand all levels with A


Toggling object-level restrictions

Icons for toggling

The following options are only available for objects:

  • Toggle visibility by clicking the 'eye' icon for the object on the right-hand side of the Outliner. Useful for complex scenes when you don't want to assign the object to another layer. This will only work on visible layers - an object on an invisible layer will still be invisible regardless of what the Outliner says.
  • Toggle selectability by clicking the 'arrow' icon. This is useful for if you have placed something in the scene and don't want to accidentally select it when working on something else.
  • Toggle rendering by clicking the 'camera' icon. This will still keep the object


Searching

You can search the file for datablocks, either by using the Search menu in the header of the Outliner, or by using one of the following hotkeys:

  • ⇧ ShiftF - Find again
  • CtrlAltF - Find complete (case sensitive)
  • AltF - Find complete
  • CtrlF - Find (case sensitive)
  • F - Find

Matching datablocks will be automatically selected.

Filtering the display

Outliner Display dropdown

The window header has a field to let you select what the outliner should show in the outline. By default, the outliner shows All Scenes. You can select to show only the current scene, datablocks that have been selected, objects that are on currently selected layers, etc. These selects are to help you narrow the list of objects so that you can find things quickly and easily.

  • All Scenes - Shows everything the outliner can display (in all scenes, all layers, etc...)
  • Current Scene - Shows everything in the current scene.
  • Visible Layers - Shows everything on the visible (currently selected) layers in the current Scene. Use the Layers buttons to make objects on a layer visible in the 3D window.
  • Groups - Lists only Groups and their members.
  • Same Types - Lists only those objects in the current scene that are of the same types as those selected in the 3d window.
  • Selected - Lists only the object(s) currently selected in the 3D window. You can select multiple objects by ⇧ ShiftRMB Template-RMB.png
  • Active - Lists only the last selected object.


Example

The Outliner window in list mode.

The outline example shows that the blend file has three scenes: Ratchet in Middle, Ratchet on Outside, and Ratchet Out White. By clicking on the little arrow to the left of the name, the outline is expanded one level. This was done for the Ratchet in Middle scene. As you can see, this scene has some world material settings, a Camera, an Empty, a HandelFixed object ... all objects that were added to the scene.

By clicking the arrow next to ratchetgear, we can see that it has some motion described by the ObIpo.001 curve; that it was based on a Circle mesh, and that it is the parent of HandleFixed.002. HandleFixed is in turn the parent of Plane.003, and so on.

The neat thing is: If you select any of these datablocks here, they will be selected in the 3d Window as well as far as this is possible. Pressing

  • on your keypad with your mouse cursor in any 3D Window will center the view to that object. Very handy. Also, pressing X will delete it, as well as all the other hotkeys that operate on the currently selected object.


Using the OOPS Schematic

Layout of the OOPS Schematic

In this view, the window has a clear background that, by default, shows the OOPS Schematic and a header:

Outliner Window in OOPS Schematic mode
A) OOPS Schematic, B) Menu, C) Zoom, D) Display Select, E) Currently selected datablock

The OOPS Schematic window & header have the following areas:

A) The schematic picture
B) Menus with the basic functions: View, Select, and Block
C) A zoom control that allows you to focus on a certain area of the schematic.
D) Visible Select - A number of buttons that toggle what kinds of datablocks are displayed in the schematic.
E) The name of the currently selected datablock. The datablock is also highlighted in the OOPS schematic. (A)

Making sense of the OOPS Schematic

The schematic is a sort of map that shows the connections between datablocks. Each datablock is shown as a colored box. Boxes (datablocks) are connected by lines. Common types of connections between datablocks are:

Parents 
One datablock, let's say an object called "TableTop", is held up by four other objects "leg.001", leg.002", etc. The TableTop would be the parent of each of the legs, so that as the table top moves, the legs move as well. In the schematic, four lines would be shown going from the TableTop to each of the Legs.
Material Use 
Datablock can share the same material. In our Table example, the TableTop and each of the legs might share the same material, "Wood", so that they all look the same. In the schematic, there would be a box called "Wood" with five lines connecting it to each of the mesh datablocks TableTop, Leg.001, Leg.002, Leg.003 and Leg.004.

The schematic uses different colored boxes for each type of datablocks: green for scenes, grey for objects, taupe for text, sea green for materials, etc. to help you visually distinguish between types of datablocks.

The OOPS Schematic Header

View 
Handy functions include switching between the schematic and outliner view. Also, you can change the size of the boxes, so more can fit in the window.
Select 
Key functions include finding users and links between connected boxes, as indicated in the useage examples previously.
Block 
Scales (S) the distance between multiple selected datablocks, and grabs/moves (G) an datablock or set of selected datablocks around the schematic - very useful for arranging and organizing your schematic.
Zoom controls 
As you can imagine, depending on what you have selected and your scene complexity, these schematics can start looking like the piping diagram for a nuclear power plant. The schematic header provides two buttons to help you zoom in. Hold down LMB Template-LMB.png over the OopsSchematic-ZoomButtons-zoom.png button and move your mouse up and down (forward and backward) to zoom your view in and out. Click on OopsSchematic-ZoomButtons-area.png to start a border select. Select a region in the window, and your window view will be zoomed to that region.
Standard Window Controls
The window, like any Blender window, can be panned by clicking the middle mouse button while your cursor is in the window, and moving the mouse.
Visible Select 
The series of icons in the header allow you to select what type(s) of datablocks are visible in the schematic. They are, left to right:
  • OopsSchematic-DatablocksButtons-layer.png - Only show the datablocks from the shown layers.
  • OopsSchematic-DatablocksButtons-scene.png Scenes - Your stage, a set, where action occurs.
  • OopsSchematic-DatablocksButtons-object.png Objects - Cameras, empties, and other misc items
  • OopsSchematic-DatablocksButtons-mesh.png Meshes - The main things you model, not to be confused with Objects. e.g. One Mesh can be used in multiple objects and is displayed accordingly in the schematic.
  • OopsSchematic-DatablocksButtons-curve.png Curves, Surfaces, Fonts
  • OopsSchematic-DatablocksButtons-metaball.png Metaballs - Mathematically calculated meshes that can mush together.
  • OopsSchematic-DatablocksButtons-lattice.png Lattices - Deformation grids
  • OopsSchematic-DatablocksButtons-lamp.png Lamps - All types of lights.
  • OopsSchematic-DatablocksButtons-material.png Materials - Colors, paints.
  • OopsSchematic-DatablocksButtons-texture.png Textures - Color maps or gradients used commionly in materials and other places.
  • OopsSchematic-DatablocksButtons-ipo.png Ipos - Actions,
  • OopsSchematic-DatablocksButtons-image.png Images - Imported pictures
  • OopsSchematic-DatablocksButtons-library.png Libraries - Collections of Objects


Datablocks

The base unit for any blender project is the datablock. The datablocks and the ways those are linked together are all there is to it, may it be a simple still image of a sphere floating over a plane or a full featured film. These datablocks can reside within as many files as needed for the good organization of the project.

Scene Datablock

Each "scene datablock" contains a scene. "Scene datablock" is the parent of the rest datablocks.

Object Datablock

Each "object datablock" has the properties of Scale, Location and Rotation and is the 'meeting place' for other datablock that define the other properties of that object when they are linked to it. An object can be linked to other datablock that determine its nature: mesh, curve, camera, lamp or armature datablock are a few examples of such datablocks. Other datablocks, will define the material, the texture, the animation... for that object.

ObData Datablocks

These datablocks are such datablocks that are always connected to "Object datablock" in a way or another.

Curve Datablock

"Curve datablock" may contain NURBS curves or circles, Bezier curves or circles, or Text objects. It may also be linked to a "material datablock".

Camera Datablock

"Camera datablock" contains a camera.

Lattice Datablock

"Lattice datablock" contains a lattice.

Lamp Datablock

"Lamp datablock" contains a lamp.

Metaball Datablock

"Metaball datablock" contains a metaball.

Mesh Datablock

Each "mesh datablock" contains a mesh. "Mesh datablock" may contain link to one or more "material datablocks".

Material Datablock

"Material datablock" contains a material. It may contain links to "texture datablocks".

Note that "material datablocks" can be linked to "object datablock" instead if desired. You can set this in the "User Preferences" window below "Edit Methods".

Texture Datablock

"Texture datablock" contains a procedural or image texture.

Copying and Linking Datablocks

It is possible to copy object and scene datablocks.

Copying and Linking Scene Datablock

To copy scene datablock, use Scene list found in the header of "User Preferences" window. The list is right to menus and window workspace list. Select "ADD NEW" to make a copy of the current scene. Select "Full Copy" from the list that opened to make a copy. The current scene will be copied to the new scene.

Instead of copying everything, you can link datablocks by selecting "Link Objects" or "Link ObData" on the list (the later copying the objects, but not there ObDatas - meshes, curves, materials, etc.). Note that if you select "Link Objects", it means that the objects are linked on deeper level as Object Datablock is parent of ObData datablock. So for instance if you move an object, the move is reflected to other scenes linked this way as well.

Copying and Linking Object Datablocks

Use ⇧ ShiftD to make normal copy of the selected objects: the object and some of its child datablocks will really be duplicated, the other childs being just linked; you can define the attributes to be duplicated in User PreferencesEdit Methods, button group Duplicate with object:.

AltD makes a linked copy: all datablocks but the object one are linked.

Copying and Linking other Datablocks

You can see a number next to the name of a datablock. This number indicated the number of links. If you click the number, it removes the link to the datablock and creates a new copy.