From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Обзор

Каждый .blend файл содержит базу данных. Эта база данных содержит все сцены, объекты, meshes, текстуры, и т.д. всё что есть в файле. Файл может содержать множество сцен, а каждая сцена может содержать множество объектов. Объекты могут содержать множество материалов которые в свою очередь могут содержать множество текстур. Также есть возможность создавать связи между разными объектами.

Mode: All Modes, Any Window

Hotkey: ⇧ ShiftF4 - Datablock Browser

Для просмотра базы данных, press ⇧ ShiftF4 and the window will change to an Datablock browser window, which lists the Objects in your .blend file. To go up a level, click the breadcrumbs (..) and then you will see the overall structure of a file: Action, Armature, Brush, Camera, Curve, Group, ... and so on (including Objects).

LMB Template-LMB.png Selecting any datablock type, Mesh, for example, will give you a listing of the Meshes used in the file, along with how many users there are for that class. For example, if you had a car mesh, and used that car mesh for six cars in a parking lot scene, the Mesh listing would show the Car and then the number 6.

Mode: Data Select Browser

Hotkey: F - Fake User

RMB Template-RMB.png Selecting certain kinds of datablocks (Materials, Images, Textures...) and pressing F will assign a Fake user to those datablocks. With a fake user in place, Blender will keep those datablocks in the file, even if they have no 'real' users. Datablocks without a user, real or fake, are not saved in the .blend file. Pressing F again toggles the Fake-user assignment. Performing this action is the same as clicking the F button next to Material names, Image names, etc.

Outliner and OOPS Schematic

You can easily inspect the contents of your file by using the Outliner window. This window displays the Blender data system. (Fully documented here.) This window offers two views of the database. The Outline view allows you to do simple operations on the objects. These operations include selecting, renaming, deleting and linking. The OOPS (Object-Oriented Programming System) Schematic view allows you to easily see how datablocks are linked. You can filter the view by using buttons found in the header.

Users (Sharing)

Many datablocks can be shared among other datablocks; re-use is encouraged. For example, suppose you have a material for one object, named "Glossy". You can select a second object, for example, one that does not have a material yet. Instead of clicking ADD NEW for the material, click the little up-down arrow next to the ADD NEW, which brings up a list of existing materials. Select "Glossy". Now, these two objects share the same Material. You will notice a "2" next to the name of the material, indicating that there are two users (the two objects) for this material. Other common examples include:

Sharing textures among materials
Sharing meshes between objects ("clones")
Sharing IPO curves between objects, for example to make all the lights dim together.

Fake User

Blender removes all datablocks that have not been linked to anything when you open the file. Because of this, sometimes you may find it useful to link unlinked datablocks to a "fake user". You can do this by hitting the F button next to the name of the datablock.

Copying and Linking Objects Between Scenes

Sometimes you may want to link or copy objects between scenes. This is possible by first selecting objects you want to link or copy and then using the "Make Links" and "Make Single User" items found in Object menu in the 3D viewport header. Use "Make Links" to make links between scenes. To make a plain copy, you first make a link and then use "Make Single User" to make a stand-alone copy of the object in your current scene. Further information on working with Scenes can be found here.

Appending or Linking Across Files

The content of one .blend file is easily accessed and put into your current file by using the File → Append function (accessed at any time by ⇧ ShiftF1). To find out more about how to copy or link objects across .blend files, click here.

Proxy Objects

Proxy Objects allow you to make (parts of) Linked data local. For example, this allows an animator to make a local 'copy' of the handler bones of a character, without having the actual rig duplicated. This is especially useful for character animation setups, where you want the entire character to be loaded from an external library, but still permit the animator to work with Poses and Actions. Another example: you can have a modeler working on the shape (mesh) of a car and another painter work on the materials for that car. The painter cannot alter the shape of the car, but can start working with color schemes for the car. Updates made to the shape of the car are applied automatically to the painter's proxy.


See also this for more useful information about the database system.

Pack and Unpack Data

Blender has the ability to encapsulate (incorporate) various kinds of data within the .blend file that is normally saved outside of the .blend file. For example, an image texture that is an external .JPG file can be put "inside" the .blend file via File → Pack Data. When the .blend file is saved, a copy of that .JPG file is put inside the .blend file. The .blend file can then be copied or emailed anywhere, and the image texture moves with it.

You know that an image texture is packed because you will see a little Christmas present gift box displayed in the header.

Unpack Data

When you have received a packed file, you can File → UnPack Data. You will be presented with the option to create the original directory structure or put the file in the // (directory where the .blend file is). Use "original locations" if you will be modifying the textures and re-packing and exchanging .blend files, so that when you send it back and the originator unpacks, their copy of the textures will be updated.