From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

A Renderização é o processo final de CG (ou uma abreviatura de pós processamento, é claro) e é a fase na qual a imagem correspondente a sua cena 3D é finalmente criada. A Renderização é um processo intensivo de CPU. Você pode Renderizar uma imagem em seu computador, ou utilizar uma Fazenda de renderização que consiste em uma rede de PCs em que cada um trabalha em uma seção diferente de imagem em quadros diferentes. Esta seção provê uma completa explanação das funcionalidades do Blender relacionadas ao processo de produzir a sua imagem ou animação.

Introdução

Botões de Renderização.

A Janela de Botões de Renderização é acessada pelo Contexto Scene, dentro do Sub-Contexto Render , pelo atalho (F10 ou pelo botão Manual-Part-I-RenderingButton.png). Os painéis de Renderização e os botões são mostrados dentro dos Botões de Renderização .

Estes botões são organizados em painéis, que são:

  • Output – controla a saída do ciclo de trabalho de rendrização.
  • Render Layers - controla quais "Layers" (Camadas) e passos serão Renderizados
  • Render – Controla o processo atual de Renderização de uma Tomada de Imagem estática (Quadro atual).
  • Anim – Controla a Renderização de uma série de quadros para produzir uma animação.
  • Bake – Executa a computação prévia de certos aspectos de uma renderização.
  • Format – Controla o formato e codificação da figura da animação.
  • Stamp – Cria estampas nos quadros com identificações e informações sobre os itens de controles e configurações.
Abas
Para economizar espaço na tela, alguns dos painéis podem estar organizados abaixo de outros; por exemplo, o painel de "Layers" (Camadas) é uma aba de pasta abaixo do painel "Output" (Saída). Para revelá-lo, simplesmente clique no cabeçalho da aba.
Yafray
Caso você tenha instalado o Yafray, as opções para controlá-lo irão aparecer como outras duas abas abaixo do painel de Render, uma vez que você o tenha selecionado como sua máquina de Renderização


Visão Geral

A renderização da cena corrente é performada pelo pressionamento do grande botão RENDER dentro do painel de Render, ou pelo pressionamento do atalho F12 (você pode definir como a imagem renderizada é mostrada na tela dentro das Opções de saída de Renderização). Veja também a Janela de Renderização.

Uma finalização de animação é produzida pressionando o grande botão ANIM dentro do painel Anim. O resultado de uma renderização é mantido em um Buffer ( ou seja, guardado na memória ) e mostrado em sua própria Janela. Ele pode ser salvo pressionando o atalho F3 ou via menu File->Save Image utilizando a opção de formato de saída dentro do painel Output. Animações são salvas de acordo com o formato especificado, usualmente como uma série de quadros dentro do diretório de saída. A imagem é renderizada de acordo com as dimensões definidas dentro do painel Format (Tipos de Imagens e Dimensões.).

Ciclo de Trabalho

Em geral, o processo de renderização é:

  1. Criar todos os Objetos dentro da cena.
  2. Iluminar a cena e posicionar a câmera.
  3. Renderizar uma imagem de teste em 25% mais ou menos sem Oversampling ou Raytracing, etc para se ter uma noção do que estará saindo e essa operação será rápida e não te atrasará.
  4. Terminar o ajuste de Materiais/Texturas e iluminação.
  5. Interagir com os passos acima até que você esteja satisfeito com algum nível de qualidade
  6. Renderizar progressivamente imagens de alta qualidade e tamanho pleno, executando pequenos refinamentos e utilizando mais tempo de computação
  7. Salvar as suas imagens

Integração das Frentes de Trabalho de Renderização

Manual-Render-Pipeline.jpg

O Blender possui três frentes de trabalho Independentes para a Saída de Renderização que fazem com que o processamento de imagens flua através dos seguintes ciclos de trabalho, a partir de uma para o outro na seguinte ordem:

  • Máquina de Renderização
  • Compositor
  • Sequenciador

Você pode utilizar cada uma dessas frentes independentemente, ou em um clico de trabalho interligado. Por exemplo, você pode utilizar o sequenciador por si mesmo para fazer pós processamento em faixas de Arquivos de Vídeo. Você pode utilizar o Compositor por si mesmo para fazer certos ajustes de cores em um imagem. Você pode renderizar a cena, pelas camadas ativas de Renderização, e salvar esta imagem diretamente, com a imagem da cena computada de acordo com a camada ativa de renderização, sem a utilização do Compositor ou Sequenciador. Estas possibilidades são mostradas dentro da parte de cima, da imagem a direita.

Você pode também ligar cenas e renderizações dentro do Blender como mostrado, ou diretamente ou através de um arquivo intermediário guardado em algum recipiente (Dispositivo de armazenamento). Cada cena pode possuir múltiplas Camadas de Renderização, e cada Camada de renderização é Mixada dentro do Compositor . A Camada de Renderização ativa é a camada que está sendo mostrada e marcada como ativa. Caso a camada de renderização não esteja marcada para ativa/habilitada, então a próxima camada de renderização dentro da lista é utilizada para computar a imagem. A imagem é mostrada como a renderização final caso os botões Do Composite e Do Sequence não estejam habilitados.

Caso o botão Do Composite esteja habilitado, as camadas de renderização são alimentadas dentro do Compositor. Os nódulos manipulam a imagem e a enviam para a saída de Composição, aonde ela poderá ser salva, ou, caso o botão Do Sequence esteja ligado, ela será enviada para o Sequenciador.

Caso o botão Do Sequence esteja habilitado, o resultado a partir do Compositor ( caso o Do Composite esteja habilitado) ou a Camada de Renderização ativa (caso o Do Composite NÃO esteja Habilitado) é alimentado dentro da faixa de cena dentro do Sequenciador. Ali ele será manipulado de acordo com as configurações do VSE, e finalmente entregue como uma imagem para aquela cena.

As coisas ficam um pouco mais complicadas quando um arquivo Blender possui múltiplas cenas , por exemplo, a Cena A e a Cena B. Dentro da Cena B, caso o botão Do Composite esteja habilitado, o Nó da Camada de Renderização dentro do Compositor da Cena B pode puxá-lo de dentro de uma Camada de Renderização a partir da Cena A . Note que esta imagem não será a imagem pós processada. Caso você queira empurrar dentro do resultado sequenciado e/ou composto a partir da Cena A, você terá de renderizar a Cena A para um arquivo a partir do uso do compositor e/ou sequenciador utilizando as configurações da Cena A, e então utilizar a imagem de entrada para o Nó dentro do Compositor da Cena B para colocá-lo lá.

A parte mais básica das possibilidades gráficas mostra o máximo do Blender: imagens pós processadas e camadas de componentes dinâmicos de Renderização a partir da cena A são mixados com duas camadas de renderização vindos da Cena B dentro do Compositor, e então sequenciadas e finalmente salvas para a sua visão de divertimento.

Estes exemplos são somente uma pequena parte das possibilidades dentro do uso do Blender. Por favor, leia para aprender sobre todas as opções, e então exercite sua criatividade dentro do desenvolvimento único do seu próprio ciclo de trabalho.

Do Sequenciador para/a partir do Compositor

Para ir do Compositor ao Sequenciador, habilite ambos os botões '"Do Sequence"' e '"Do Composite"'. Dentro do Compositor, a imagem que é colocada em tarefa para a Saída do Nó de Composição é a imagem que será processada dentro da faixa de Cena dentro do VSE.

A maneira de ir a partir do Sequenciador para o Compositor é através de um arquivo guardado. Tendo uma Cena guardada através do uso de '"Do Sequence"' e feita a sua saída para uma sequência de imagens ou então um arquivo mov/avi. Então, dentro de outra Cena, habilitar o '"Do Composite"' e usando uma imagem de entrada para que o Nó leia dentro da sequencia de imagem ou então dentro do arquivo mov/avi.

Opções da Janela de Renderização

Uma vez que você pressiona F12 ou clica no grande botão de Render, sua imagem é computada e a sua amostragem é iniciada. Dependendo das opções presentes no Painel de Saída ( Output Panel ), a imagem é mostrada em uma Janela separada de renderizaçao, em Tela cheia ou dentro de uma Janela do Editor de imagens UV.

Você pode renderizar um único quadro, ou muitos quadros em uma animação. Você pode cancelar a renderização pressionando Esc. Caso esteja renderizando uma sequência de quadros, o quadro com o número mais baixo especificado em STA é usado e então os quadros são renderizados sucessivamente até o último quadro, especificado em END', em uma sequência progressiva.

A Janela de Renderização pode ser invocada de muitas maneiras:

Render Panel->Render ou F12
Renderiza o quadro corrente, como visto pela câmera ativa, utilizando a máquina de renderização selecionada (Blender Internal ouYafray)
3D View Window Header->LMB Template-LMB.png Botão de Renderização por OpenGL (o mais a direita, na Janela de visualização 3D )
Executa a Renderização de uma previsão da janela de Visualização 3D em OpenGL
Anim Panel->Anim CtrlF12
Renderiza a Animação a partir do quadro de início (STA e vai até o quadro incluído no final (END). Conforme configurado dentro do Painel Anim.
3D View Window Header->CtrlLMB Template-LMB.png Botão de Renderização por OpenGL (o mais a direita, na Janela de visualização 3D )
Executa a Renderização de uma animação da previsão da janela de Visualização 3D em OpenGL

A Renderização da Animação da Janela de visualização 3D em OpenGL é útil mostrar animações de Armaduras.

Mostrando Renderizações Anteriores

Caso o Renderizador Interno do Blender tenha sido utilizado para computar a imagem, você pode olhar para a Renderização Prévia:

Render->Show Render Buffer
F11 – Faz aparecer a Janela de Renderização e mostra a última imagem Renderizada (mesmo se estava em um arquivo Blender aberto anteriormente e renderizado).
Render->Play Back Rendered Animation
CtrlF11 - Similar ao que se faz para uma única imagem, mas ao invés disto, ele toca todos os quadros da animação renderizada.

Uso da Janela de Renderização

Visite esta página para mais informações sobre o uso da Janela de Renderização

Saltos nos Quadros de Renderização

Opção de Salto de Quadros.

O Blender permite a você executar renderizações de animações rápidas pulando alguns quadros. Você pode configurar o passo de quadros dentro do Painel de Renderização conforme você pode ver na figura.

Uma vez que você tenha seu arquivo de vídeo renderizado, você pode tocá-lo em velocidade real (fps) . Para isto você só precisa ajustar o mesmo parâmetro de Passo (Step) que você utilizou para renderizá-lo.

Caso você toque o vídeo onde foi ajustado o Passo dentro do Blender, em um tocador externo, a velocidade em geral será a quantidade de *Passos* mais rápida do que o vídeo renderizado com todos os quadros( por exemplo, um vídeo com 100 quadros renderizado com valor de Step de 4 a 25 Quadros por segundo terá somente 1 segundo. O Mesmo vídeo renderizado com valor de Step igual a 1 ( o valor padrão ) terá 4 segundos de comprimento).

Caso você queira utilizar este parâmetro para a renderização através de linha de comando, você pode utilizar o comando -j STEP, aonde STEP significa o número de passo que você quer utilizar.

Caso você queira utilizar este parâmetro para tocar arquivos de vídeo através da linha de comando, você precisa utilizar o parâmetro -J STEP logo após o parâmetro -a ( que significa que o Blender estará em modo de tocador ). Exemplo abaixo:

./blender -a -s 1 -e 100 -p 0 0 -f 25 1 -j 4 "//videos/0001.jpg"


  • Quadros renderizados com passos com saída em formato de vídeo como os que são feitos em FFMpeg (sempre) ou AVI Jpeg (algumas vezes) produzem um vídeo corrompido ( faltando os quadros finais ) no Blender 2.48a. Portanto o vídeo não pode ser tocado apropriadamente.

Portanto eu sugiro a você que sempre utilize um formato de saída de vídeo como JPG, ele trabalha bem o tempo inteiro.

Fazenda de Renderização Distribuída

Existem muitos níveis de alocação de CPU que você pode utilizar para diminuir o tempo de renderização em geral, aplicando um pouco mais de inteligência na tarefa.

Primeiro, caso você tenha CPUs Multi-Core, você pode aumentar a quantidade de tarefas, e o Blender irá utilizar esse número de CPUs para computar a renderização.

Segundo, caso você tenha uma rede local com PCs disponíveis , você pode dividir a tarefa por quadros. Por exemplo, se você quer renderizar uma animação de 200 quadros, e possui 5 Pcs de quase igual poder de processamento, você pode alocar o PC#1 para produzir os quadros de 1-40, o PC#2 para produzir os quadros de 41-80, e assim por diante. Caso um PC seja mais lento que os outros, simplesmente aloque poucos quadros para aquele PC. Para fazer renderizações via LAN ( Rede ) mapeie a pasta contendo o arquivo Blender (no qual você deve ter empacotado as suas texturas, dados externos, etc... ) como um drive compartilhado. Inicie o Blender em cada PC e abra o arquivo Blender. Altere o quadro especificado em STA e END para que a contagem seja específica para aquele PC, mas não salve o arquivo Blender. Inicie a Renderização. Caso você utilize caminhos relativos, para a sua especificação de saída, os quadros renderizados serão colocados no PC que está hospedando o arquivo Blender que está sendo Renderizado.

Em terceiro, você pode utilizar WAN ( Wide Area Network ou Internet ) pata renderização, o que é aonde você envia por e-mail ou compartilha, ou então utiliza o Verse para compartilhar o seu arquivo Blender (com os dados empacotados !) ao longo da Internet, e utiliza o PC de qualquer um para fazer parte da renderização. Eles então retornam em e-mail para você os quadros renderizados conforme eles são feitos. Caso você possua amigos confiáveis, esta é uma maneira de se trabalhar em conjunto ou em grupo.

Quarto, você pode utilizar um serviço de Fazenda de Renderização. Este serviço, como o BURP, é rodado por uma organização. Você manda para eles o seu arquivo via E-mail , e então eles distribuem em seus PCs para renderização. O serviço BURP está mencionado aqui por que é gratuito, e é um serviço que utiliza alguns PCs de colegas Blendeiros com um tipo de serviço que roda em plano de fundo parecido com o BOINC para processamento. Outros serviços são subscrições pagas ou serviços tipo pague-conforme-utilize.