From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Há duas visões da sua animação, e também dois modos de definir e ajustar animações: curvas e quadros-chave. Uma curva liga dois pontos. A forma da curva é ajustada movendo os pontos de manipulação pela janela. Os manipuladores ditam o grau da influência que o ponto tem na curva. Um quadro-chave é uma combinação de valores dos pontos em um particular ponto no tempo. O uso de quadros-chave na animação é chamado de Keyframing.

Curvas Ipo

Mode: Ipo Curve Editor

Hotkey: C

Menu: View->Show Keys (para desligar)

A janela Ipo - modo de exibição de curvas

A janela de curvas Ipo permite a você editar as curvas 2D que definem a animação no Blender. As curvas representam os valores editados para posição, tamanho, rotação, energia, etc. no eixo vertical (Y) e o tempo no eixo horizontal (X). A taxa de mudança desses valores através do tempo pode ser vista na inclinação da curva.

Você pode transformar qualquer janela em uma janela do tipo Ipo Curve Editor com o menu Window Type, mas geralmente é útil ter simultaneamente uma 3D View e uma Ipo Curve Editor. Isso mostra todas as curvas Ipo, os canais usados e disponíveis. Você pode aproximar ou afastar a janela Ipo e movê-la assim como qualquer outra janela do Blender.

Além dos canais padrão, que são definidos via I, você tem as opções delta, como o dLocX. Esses canais permitem que você defina uma mudança relativa. Essa opção é principalmente usada para controlar múltiplos objetos com a mesma Ipo. Além disso, é possível trabalhar na animação em 'camadas'. Para definir uma curva Ipo para esses canais, selecione o canal e aí crie pontos de controle via CtrlLMB Template-LMB.png clicando na janela Ipo.

As curvas Ipo têm uma característica importante que as distinguem das curvas normais: é possível colocar mais de um segmento de curva horizontalmente. Loops e círculos em uma Ipo são ambíguos e sem sentido. Uma Ipo pode somente ter 1 valor em um tempo. Isso é automaticamente detectado e corrigido no Ipo Editor. Cada canal Ipo que já foi configurado é mostrado na lista de canais na direta da janela com um botão colorido ao seu lado.

Mostrando/escondendo curvas

Você pode mostrar uma curva Ipo usando LMB Template-LMB.png no respectivo nome do canal Ipo à direita (uma que já tenha um botão colorido ao lado de seu nome). Fazendo isso, você esconde todas as curvas mostradas anteriormente. Se você quer mostrar várias curvas Ipo juntas (por exemplo se você está trabalhando com um conjunto de canais como LocX, LocY, LocZ) use ⇧ Shift LMB Template-LMB.png em cada nome de canal que você quer mostrar (seus nomes aparecem em branco).

Seleção de curvas

Modo: Todos os modos

Menu: Editor de Curvas Ipo → Select

Alguns dos métodos padrão de seleção do Blender funcionam na janela de Edição de Curvas Ipo. Clique com RMB Template-RMB.png em uma curva para selecioná-la. Você também pode usar LMB Template-LMB.png no botão colorido ao lado de seu nome. Você pode selecionar várias curvas usando ⇧ ShiftRMB Template-RMB.png em cada curva que é mostrada ou usando ⇧ ShiftLMB Template-LMB.png em cada botão. Uma curva que é selecionada exibe seus pontos de manipulação em branco e seu respectivo botão colorido aparece destacado em preto (se for o último selecionado do grupo e os outros aparecem como pressionados).

Opções

RMB Template-RMB.png
Seleciona uma curva Ipo sob o cursor do mouse
Selecionar/Deselecionar Todas A
Seleciona todas as curvas Ipo visíveis
Seleção em caixaB
Seleciona as curvas Ipo interativamente com uma caixa de seleção do mouse

Manipulação de curvas

Modo: Todos os modos

Menu: Editor de Curvas Ipo → Curve → Transform

As curvas Ipo também podem ser manipuladas com várias das transformações 2D padrão. A mesma opção de travamento de eixo aplica-se aqui também. Mover curvas para a esquerda e direita irá movê-las adiante ou atrás no tempo.

Opções

Arrastar/Mover G
Move a curva Ipo selecionada
Escalonar S
Escalona (aumenta/diminui) a curva Ipo selecionada

Interpolação de curvas

Modo: Todos os modos

Atalho: T

Menu: Editor de curvas Ipo → Curve → Interpolation Mode

O modo de interpolação determina como os valores de uma curva Ipo são calculados entre cada ponto na curva.

Opções

Constante
Após cada ponto da curva, o valor permanece constante (horizontal). Nenhuma interpolação acontece.
Linear
Cada ponto da curva é conectado com uma linha reta
Bezier
A interpolação suave e curvada padrão

Modo de Extensão de Curvas

Modo: Todos os modos

Atalho: E

Menu: Editor de Curvas Ipo → Curve → Extend Mode

O modo de extensão determina como os valores da curva Ipo são calculados fora dos limites horizontais dela. Isso pode ser usado para repetir um pequeno trecho de animação ou fazê-la continuar infinitamente.

Opções

Constante
Os extremos das curvas selecionadas são extrapolados continuamente (horizontalmente).
Extrapolação
Os extremos das curvas selecionadas continuam na direção em que terminaram
Cíclico
O comprimento inteiro da curva é repetido ciclicamente
Extrapolação Cíclica
O comprimento inteiro da curva é extrapolado ciclicamente

Exemplos

IPOs extendidas


Editando Pontos de Curva

Modo: Todos os modos

Atalho: ⇆ Tab

Menu: Editor de Curvas Ipo → Curve → Edit Selected

Assim como manipular as curvas como um todo, você também pode editar os pontos individuais que definem a curva. Pontos de curva são adicionados quando um quadro-chave é inserido (geralmente com o menu Insert Key I), e esses pontos podem ser manipulados em tempo (eixo X) e em valor (eixo Y). Tecle ⇆ Tab para ir ao modo de edição e poder selecionar cada ponto da curva independentemente. Se você selecionar um ou mais pontos com RMB Template-RMB.png, você pode movê-los (G), esaloná-los (S) ou rotacioná-los (R). Você também pode selecionar e editar os pontos de manipulação, o que permite um controle mais apurado da curva de interpolação. Você pode também definir os valores dos pontos numericamente teclando N e entrando com o valor nos campos "Vertex X" e "Vertex Y" dentro do painel de propriedades de Transformação.

Adicionando Pontos de Curva

Modo: Todos os modos

Atalho: CtrlLMB Template-LMB.png / ⇧ ShiftD

Menu: Editor de Curvas Ipo → Point → Duplicate

Alternativamente a inserção de pontos de curva via inserção de quadros-chave (ex. na 3D View ou janela de botões), pontos de curva também podem ser adicionados manualmente no Editor de Curvas Ipo usando CtrlLMB Template-LMB.png. O ponto será adicionado à curva ativa (aquela cujo botão colorido próximo ao seu nome está destacado em preto mesmo que ainda não tenha nenhum ponto de curva definido), na posição do cursor do mouse.

Pontos são adicionados de acordo com as seguintes regras:

  • Ainda não há bloco de dados Ipo (nessa janela) e um canal é selecionado: um novo bloco de dados Ipo é criado juntamente com a primeira curva Ipo com um vértice colocado onde o mouse foi clicado.
  • Já existe um bloco de dados Ipo, e um canal é selecionado sem uma curva Ipo: uma nova curva Ipo com um vértice é adicionada.
  • Já existe um bloco de dados Ipo, e um canal é selecionado com uma curva Ipo definida: Um novo ponto é adicionado à curva Ipo selecionada e ligado com os pontos mais próximos antes e depois dele. Se múltiplas curvas são selecionadas, e/ou você está no Edit mode, os pontos são adicionados à curva ativa (cujo botão perto ao seu nome de canal está destacado em preto).

Os pontos de curva selecionados também podem ser duplicados. Note que isso não irá duplicar os segmentos da curva, mas os pontos em si, conectados à curva original.

Dicas

Clicar repetidamente CtrlLMB Template-LMB.png ao longo de uma curva pode ser uma boa forma de adicionar aleatoriedade e imprevisibilidade à animação.

Tipos de Pontos de Manipulação

Modo: Todos os modos

Atalho: H, ⇧ ShiftH, AltH, V

Menu: Editor de Curvas Ipo → Point → Handle Type

Similarmente ao objetos de curva 3D, pontos de curvas Ipo possuem dois pontos de manipulação, um em cada lado. Esses pontos manipuladores podem ter uma variedade de tipos, que podem ser usados para controlar especificamente a interpolação dos segmentos entre os pontos.

Opções

Manipulador livre H (preto)
Os manipuladores são desconectados e podem ser alterados de qualquer forma. (H alterna entre livre e alinhado)
Manipulador alinhado H
Os manipuladores são conectados em uma linha reta. (H alterna entre livre e alinhado)
Vetor V
Ambos os extremos de um manipulador sempre apontam para o manipulador seguinte ou anterior
Auto ⇧ ShiftH (amarelo)
Esse manipulador tem comprimento e direção completamente automaticos, baseados na proximidade de um ponto com outro

Assim que os manipuladores são rotacionados, movendo-se um de seus pontos, o seu tipo é mudado automaticamente:

  • Manipulador Auto se torna Alinhado.
  • Manipulador Vecor se torna Livre.

Chaves Ipo

Modo: Todos os modos

Atalho: K

Menu: Editor de Curvas Ipo → View → Show Keys

Tão fáil quanto trabalhar com curvas de animação, algumas pessoas acham ainda mais fácil manipular as chaves. Mudar o Editor Ipo para exibição de chaves faz duas coisas acontecerem:

  • O Editor de Curvas Ipo agora desenha linhas verticais através de todos os pontos de todas as curvas visíveis (as curvas agora são mostradas em preto). Pontos com o mesmo valor de 'quadro' são ligados com linhas verticais. As linhas verticais (as "Chaves Ipo") podem ser selecionadas, movidas ou duplicadas, assim como os pontos. Você pode mover os pontos apenas horizontalmente.
  • O objeto não só é mostrado na 3D View em sua posição atual, mas objetos 'fantasmas' também são mostrados em todas as posições-chave. Em alguns monitores de vídeo, você pode ter que pressionar K na janela 3D View. Além de agora poder visualizar as posições-chave do objeto, você pode também modificá-las na 3D View. Por exemplo, você pode mover as chaves Ipo selecionadas.

Papel Manteiga e Fantasmas

É possível ver as posições definidas de um objeto na 3D View. Com o editor IPO no modo Keyframe, tecle K na janela 3D View. A posição do objeto será desenhada como contornos fantasmagóricos. A localização fantasma das chaves selecionadas será desenhada em uma cor de destaque. Usando essa ferramenta, você pode ver fisicamente a localização, ou caminho, que seu objeto terá no espaço 3D.

Dicas

  • Use o modo keyframe para mudar onde um objeto está no tempo. Por exemplo se você atualmente tem um objeto em uma certa posição no quadro 100, mas descobre que ele chega lá muito cedo, vá até o modo de exibição de chaves, selecione a chave no frame 100, arraste-o (G) para a direita. Clique para deixá-lo naquela posição.
  • Segurando Ctrl enquanto arrasta quadros-chave faz com que eles se guiem pelos quadros similares.
  • O comando "Insert Key" I sempre afeta todos os objetos selecionados. As chaves Ipo para múltiplos objetos podem também ser transformados simultaneamente na 3D View. Use o comando ⇧ ShiftK: Timeline ? Show and Select Keyframes para transformar animações completas de um grupo de objetos de uma só vez.
  • Use Page up ? e Page down ? para selecionar chaves subseqüentes na 3D View.
  • Você pode criar chaves Ipo com qualquer arranjo de canais. Pela consciente exclusão de certos canais, você pode forçar uma situação onde mudanças nas posições-chave na 3D View podem somente ser feita para os valores especificados pelos canais visíveis. Por exemplo, com apenas o canal LocX selecionado, as chaves podem somente ser movidas na direção X.
  • Cada chave Ipo consiste de vértices que têm exatamente o mesmo valor de quadro. Se os vértices são movidos manualmente, isso pode resultar em um alto número de chaves, cada um tendo apenas uma curva. Nesse caso, use o comando J ("Unidr") para combinar as chaves Ipo selecionadas. Também é possível atribuir vértices de chaves Ipo selecionadas para todas as curvas visíveis: use I na janela Ipo e escolha "Chaves selecionadas".
  • A opção Desenhar Chaves e o modo Chave Ipo podem ser ligadas/desligadas independentemente. Use o botão EditButtons->DrawKey par ligar/desligar essa opção para o objeto atual. Você pode ligar/desligar o modo Chave Ipo com K na janela Ipo. Usar somente K na 3D View liga/desliga ambos o Desenhar Chaves e o modo Chave Ipo.

Exemplos

Modo Chave Ipo

Notas Especiais na Curva de Tempo

Modo: Todos os modos

Com a curva de Tempo você pode manipular o tempo de animação dos objetos sem alterar a animação das outras Ipos. De fato, ela muda o mapeamento do tempo de animação para o tempo glocal de animação (IPO de tempo linear). A curva de Tempo é um canal no objeto Ipo.

Nos quadros onde a inclinação da curva é positiva, seu objeto irá avançar em sua animação. A velocidade depende do valor da inclinação. Uma inclinação maior que 1 irá animar mais rápido do que a animação base. Uma inclinação menor que 1 irá animar mais devagar. Uma inclinação de 1 significa nenhuma alteração na animação, inclinações negativas permitem que você retroceda na animação. A curva de Tempo é especialmente interessante para sistemas de partículas, permitindo a você "congelar" as partículas ou animá-las endo absorvidas por um objeto ao invés de serem emitidas. Outras possibilidades são fazer uma movimentação acelerada ou em câmera lenta.

Exemplos

Ipo de Tempo linear

Para compreender esse conceito, faça uma animação simples com quadros-chave de um objeto se movendo de uma posição a outra em, digamos, 50 quadros. Depois, selecione o canal "Time" (Tempo) e crie uma Ipo de Tempo na janela Ipo indo do ponto (1,1) ao ponto (50,50). É fácil definir os pontos de início e o fim de uma Ipo usando N e entrando com os valores numericamente.

Múltiplas Ipo de Tempo

Você precisa copiar a Ipo de Tempo para cada sistema de animação para ter uma cãmera lenta completa. Mas se parar somente algumas animações e continuar a animar, por exemplo, a câmera você pode conseguir alguns efeitos muito bons (como os usados no filme "Matrix).