From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Basic Mesh Modelling

W tym dziale opiszemy kilka najczęściej używanych narzędzi edycji siatki: Wytłoczenie Extrude, Spin, Spin Dup, Skręcenie Screw, Zawinięcie Warp i przekształcenie w sferę To Sphere.

Każde narzędzie jest opisane jako prosty samouczek. Wytłoczenie Extrude jest pokazane na prostych krokach w których wykonujemy miecz. Za pomocą Spin zrobimy prosty kieliszek wina. Przy omawianiu Spin Dup opiszemy jak zrobić znaczniki godzin na tarczy zegara. Przy użyciu skręcenia Screw wykonamy śrubkę. I na koniec zawiniemy Warp tekst 3d.

Extrude - Wytłoczenie

Tryb: Edit Mode → Editing context F9

Panel: Mesh Tools → Extrude

Skrót: E

Jedną z kluczowych komend przy pracy z Siatką jest wytłoczenie Extrude (E). Ta komenda pozawala ci tworzyć sześciany z kwadratów i cylindry z kół, jaki i takie rzeczy jak gałęzie drzew. Pomimo że proces jest dość intuicyjny, zasady kryjące sie za Extrude są dość skomplikowane,jak opisano poniżej.

  • Po pierwsze algorytm określa zewnętrzne pętle krawędzi z zaznaczenia; czyli te, które zostaną przemienione na face'y. Domyślnie, algorytm rozważa krawędzie należące do dwóch lub więcej face'ów jako wewnętrzne, i nie czyni ich częścią pętli.
  • Krawędzie w pętli są zamieniane na face'y.
  • Jeśli krawędzie w pętli należą tylko do jednego face'a w całej siatce, wtedy zaznaczone face'y są duplikowane i łączone do nowych face'ów. Przykładowo w tym stadium, kwadrat stanie się sześcianem.
  • W innych przypadkach, zaznaczone face'y są łączone do nowych face'ów ale nie duplikowane. To zapobiega niechcianym face'om wewnątrz siatki. Ten wyjątek jest bardzo ważny, jako że zapewnia spójność konstrukcji zamkniętej objętości w każdym momencie użycia Extrude.
  • Krawędzie zaznaczone nie należące do zaznaczonych face'ów, które tworzą "otwartą" pętle-krawędzi, są duplikowane i nowe face'y są tworzone pomiędzy nowymi i starymi krawędziami.
  • Pojedyncze zaznaczone wierzchołki, które nie należą do zaznaczonych krawędzi są duplikowane i nowa krawędzi jest tworzona pomiędzy tymi dwoma.

Tryb przesuwania (Grab mode) startuje automatycznie gdy wykona się algorytm Extrude, tak więc nowo stworzone face'y i wierzchołki mogą być przesuwane razem z myszką. Wytłoczenie jest jednym z najczęściej używanych narzędzi w Blenderze. Jest proste, jasne i łatwe w użyciu, a do tego bardzo potężne. Następująca krótka lekcja opisze jak zrobić miecz za pomocą Extrude.

Ostrze

  • Uruchom Blendera i usuń domyślny sześcian. W widoku z góry ({N|7}) dodaj okrąg składający się z ośmiu wierzchołków. Przesuń (G) wierzchołki tak aby pasowały do ustawienia pokazanego na Zdeformowane okrąg staje się przekrojem ostrza..
Zdeformowane okrąg staje się przekrojem ostrza.
  • Zaznacz wszystkie wierzchołki (A) i zmniejsz je przy pomocy S tak aby kształt mieścił się w dwóch kratkach siatki. Przełącz się na widok z przodu 1 NumPad.
Przycisk Extrude w przyciskach Edycji.
  • Kształt który stworzyliśmy jest bazą ostrza. Używając wytłoczenia stworzymy ostrze w kilku prostych krokach. Z zaznaczonymi wszystkimi wierzchołkami wciśnij E, lub kliknij na przycisk Extrudew panelu Mesh Tools(en) w przyciskach edycji (F9 - Przycisk Extrude w przyciskach Edycji.).
Popup potwierdzenia Extrude.
  • Pojawi się popup z zapytaniem Ok? Extrude (Popup potwierdzenia Extrude. ). Kliknij na ten tekst lub wciśnij ↵ Enter by potwierdzić, w przeciwnym przypadku przesyń myszkę poza popup lub wciśnij Esc by anulować. Po zatwierdzeniu jeśli ruszysz myszą zobaczysz, że Blender powielił wierzchołki i połączył je z pierwotnymi krawędziami i face'ami, oraz przeszedł w tryb przesuwania.


Ostrze
  • Przesuń nowe wierzchołki w górę o 30 jednostek, regulując przesunięcie przy pomocy Ctrl, a następnie LMB Template-LMB.png aby zatwierdzić ich nową pozycję i zmniejsz je troszeczkę przy użyciu S (Ostrze).
  • Wciśnij jeszcze raz E by wytłoczyć zakończenie ostrza, następnie przesuń wierzchołki 5 jednostek w górę. Aby ostrze kończyło się jednym wierzchołkiem, przeskaluj wierzchołki do 0.000 (Trzymaj Ctrl podczas skalowania) i wciśnij W>Remove Doubles (Menu Mesh Edit) lub kliknij przycisk Rem Doubles w przyciskach edycji (F9). Blender poinformuje cię, że usunął siedem wierzchołków z zaznaczonych ośmiu, czyli że został tylko jeden wierzchołek. Ostrze jest gotowe! (Gotowe Ostrze)
Menu Mesh Edit
Gotowe ostrze


Rękojeść

  • Opuść edit mode i przesuń ostrze na bok. Dodaj UVsphere z 16 południkami i pierścieniami i odznacz wszystkie wierzchołki przy pomocy A.
UV sfera do rękojeści: wierzchołki do usunięcia
  • Zaznacz ramką trzy górne pierścienie wierzchołków przy pomocy B i usuń je używając X>>Vertices (UV sfera do rękojeści: wierzchołki do usunięcia).


  • Zaznacz górny pierścień wierzchołków i wytłocz go. Przesuń pierścień 4 jednostki w górę i powiększ go trochę. (Pierwsze wytłoczenie rękojeści), następnie wytłocz i przesuń o cztery jednostki i znów wytłocz i przesuń o cztery i zmniejsz ostatni pierścień troszeczkę. (Gotowa rękojeść).
Pierwsze wytłoczenie rękojeści
Gotowa rękojeść
  • Opuść EditMode i pomniejsz całą rękojeść tak aby była proporcjonalna do ostrza. Ustaw ją tuż pod nim.

Oslona ochronna miecza

Do teraz powinieneś już nauczyć się posługiwać sekwencją 'Wytłocz>przesuń>skaluj', więc spróbuj wymodelować ładny jelec przy jej użyciu. Zacznij od sześcianu i wytłocz różne jego ścianki kilka razy, skalując gdy potrzeba. Powinieneś być zdolny ośiągnąć coś podobnego jak (Gotowa osłona ochronna miecza).

Gotowa osłona ochronna miecza

Po otexturowaniu, miecz wyglada jak (Gotowy miecz, z teksturami i materiałami).

Gotowy miecz, z teksturami i materiałami
Jak widzisz, Extrude jest bardzo potężnym narzędziem, które pozwala ci wymodelować dosyć skomplikowane obiekty bardzo szybko; cały miecz został wykonany w mniej niż pół godziny.

As you can see, Extrude is a very powerful tool that allows you to model relatively complex objects very quickly; the entire sword was created in less than one half hour. Zaprzyjaźnienie się z 'Wytłocz>przesuń>skaluj' sprawi, że twoje życie jako modeler blendera będzie dużo łatwiejsze.

Spin i SpinDup

Spin i Spin Dup są to dwa bardzo przydatne narzędzia, pozwalające łatwo stworzyć bryły obrotoweare lub powtarzalne wycinki kątowe.

Spin

Tryb: Edit Mode → Editing context F9

Panel: Mesh Tools → Spin

Użyj narzędzia Spin do stworzenia obiektów, które chciałbyś zrobić na tokarce(lathe). (To narzędzie z tego powodu jest czasem jest nazywane "lathe"-tool "sweep"-toll.) Najpierw, stwórz siatkę przedstawiającą profil twojego obiektu. Jeśli tworzysz wydrążony obiekt, dobrym pomysłem jest zrobienie obu ścianek.(Profil kieliszka) pokazuje profil kieliszka do wina, który wymodelujemy w tym przykładzie.

Profil kieliszka

W EditMode, z zaznaczonymi wszystkimi wierzchołkami, przejdź do przycisków edycji (F9). Przycisk Degr w panelu Mesh Tools pokazuje ilość stopni o jaką obróci się obiekt (w naszym przypadku potrzebujemy pełnego 360° obrotu).

Przyciski Spin

Przycisk Steps określa ile profili znajdzie się w obrocie (Przyciski Spin).

Podobnie jak przy Spin Duplicate (opisanym dalej), efekt Spin zależy od ustawienia kursora 3D i tego które okno (view) jest aktywne. My będziemy obracać obiekt wokół kursora w widoku z góry. Przełącz się do tego widoku za pomocą 7 NumPad.

Profil kieliszka, w widoku z góry w edit mode, tuż przed spin.
  • Umieść kursor 3D na środku profilu, zaznaczając jeden z wierzchołków na środku i przeciągając kursor 3D do niego za pomocą ⇧ ShiftSCursor->Selection (Profil kieliszka, w widoku z góry w edit mode, tuż przed spin.) pokazuje profil kieliszka do wina w widoku z góry z odpowiednio umieszczonym kursorem.


Dane Siatki - Liczba wierzchołków i face'ów.

Zanim będziesz kontynuował, sprawdź ilość wierzchołków naszego profilu. Znajdziesz tą informacje na górze interfejsu Blendera (Dane Siatki - Liczba wierzchołków i face'ów.).

Profil po Spin
  • Kliknij przycisk "Spin". Jeśli masz więcej niż jedno okno otwarte, kursor myszy zmieni się w strzałkę ze znakiem zapytania, i będziesz musiał kliknąć okno zawierające widok z góry przed. Jeśli masz tylko jedno okno otwarte, spin się wykona od razu. Profil po Spin pokazuje wynik dobrze wykonanego spin.


Zaznaczenie wierzchołków szwu
  • Operacja spin zostawia zduplikowane wierzchołki w miejscu profilu. Możesz zaznaczyć wszystkie wierzchołki szwu przy pomocy zaznaczenia ramką (B) jak pokazano na

(Zaznaczenie wierzchołków szwu) i wykonać operacje usuwania podwójnych wierzchołków Remove Doubles.

Pamiętaj liczbę zaznaczonych wierzchołków przed i po Remove Doubles (Liczba wierzchołków po usunięciu podwójnych.). Jeśli wszystko poszło dobrze, końcowa liczba wierzchołków (w tym przypadku 38) powinna być taka sama, jak liczba wierzchołków w profilu wspomniana w Dane Siatki - Liczba wierzchołków i face'ów. Jeśli nie, oznacza to że niektóre wierzchołki zostały pominięte i będziesz musiał je spajać ręcznie, lub co gorsza za dużo wierzchołków zostało połączonych.

Liczba wierzchołków po usunięciu podwójnych.
Menu Merge
Spajanie dwóch wierzchołków w jeden
Aby połączyć (spoić) dwa wierzchołki ze sobą, zaznacz je oba trzymając ⇧ Shift i kliknij RMB Template-RMB.png na nich. Wciśnij S by zacząć zmniejszać i trzymaj Ctrl podczas skalowania by zmniejszyć do 0 w osi X,Y i Z. LMB Template-LMB.png aby zakończyć skalowanie i wciśnij przycisk Remove Doubles w oknie EditButtons (dostępne także przez WRemove Doubles). Alternatywą do tego może być wciśnięcie W i wybranie Merge z menu które się poawi (Menu Merge). Następnie, w nowym menu należy wybrać w jakim miejscu te wierzchołki zostaną spojone, w środku czy też na cursorze 3D. Wybór tego pierwszego jest lepszy w naszym przypadku.


Jedyne co pozostaje teraz to przeliczenie normalnych. W tym celu zaznaczamy wszystkie wierzchołki, wciskamy CtrlN i wybieramy Recalc Normals Outside z menu które się pojawi. Teraz możesz opuścić EditMode i przypisać materiały bądz wygładzenie, dodać trochę świateł i kamerę i wykonać render. (Końcowy render kieliszków.) pokazuje nasze kieliszki do wina w końcowej fazie.

Końcowy render kieliszków.

SpinDup

Tryb: Edit Mode → Editing context F9

Panel: Mesh Tools → Spin Dup

Narzędzie Spin Dup jest bardzo przydatne gdy potrzebujemy wykonać szereg kopii obiektu po obwodzie koła. Przykładowo, jeśli wymodelowałeś zegar, i chcesz wstawic w nim znaczniki godzin. Wymodeluj tylko jeden, na godzinie 12 (Znacznik godziny wskazany przez strzałkę). Zaznacz go i przejdzi do przycisków Edycji za pomocą F9.

Znacznik godziny wskazany przez strzałkę

Ustaw liczbę stopni w polu Degr: panelu Mesh Tools(en) na 360. Chcemy zrobić 12 kopii obiektu tak więc ustaw Steps na 12 (Przyciski Spin Dup).

Przyciski Spin Dup


Zaznaczona i gotowa siatka do SpinDup
  • Zmień widok do tego, w którym chcesz obrócić używając klawiatury numerycznej. Zauważ że wynik Spin Dup zależy od widoku w którym używasz gdy wciskasz przycisk.
  • Ustaw 3D kursor w środku obrotu. Obiekt zostanie obrócony wokół tego punktu. Zauważ: by umieścić kursor dokładnie na miejscu istniejącego obiektu lub wierzchołka, zaznacz go i wciśnij ⇧ ShiftSCursor->Selection.
  • Zaznacz obiekt który chcesz duplikować i wejdź w EditMode używając ⇆ Tab.
  • W EditMode, zaznacz wierzchołki, które chcesz duplikować (pamiętaj że możesz zaznaczyć wszystkie przy użyciu A lub wszystkie połączone z punktem pod kursorem używając L). Zobacz (Zaznaczona i gotowa siatka do SpinDup).


  • Wciśnij przycisk Spin Dup. Jeśli masz więcej niż jedno 3DWindow otwarte, twój kursor myszy zmieni się w strzałkę ze znakiem zapytania. Kliknij okno w którym chcesz dokonać obrotu. W naszym przypadku będzie to widok z przodu (Wybór widoku dla Spin Dup.).

Jeśli widok który potrzebujesz jest niewidoczny, możesz odwołać strzałkę/pytajnik przy pomocy Esc dopóki nie wybierzesz ustawisz okna przy pomocy klawiatury numerycznej.

Wybór widoku dla Spin Dup.
Usuwanie zduplikowanego obiektu

Gdy duplikowanie po okręgu jest wykonywane w 360 stopniach, zduplikowany obiekt jest ustawiony w tym samym miejscu co pierwszy biekt, tworząc podwójny kształt.

Zauważysz, że po kliknięciu przycisku Spin Dup, pierwotna siatka pozostaje zaznaczone. By ją usunąć wciśnij po prostu XVertices. Obiekt źródłowy zostanie usunięty, ale jego wersja pozostanie (Usuwanie zduplikowanego obiektu).

Jeśli lubisz trochę matematykę nie musisz bawić się z duplikatami ponieważ możesz ich uniknąć na początku. Wystarczy zrobić 11 duplikatów, nie 12, i nie obracać o całe 360°, ale tylko w 330° (to jest 360*11/12). W ten sposób żaden duplikat nie zostanie ustawiony na pierwotnym obiekcie.

Ogólnie aby zrobić n duplikatów na 360 stopniach bez nachodzenia na siebie, wystarczy obrócić n-1 razy w 360*(n-1)/n stopniach.

(Końcowy render zegara.) pokazuje ostateczny render zegara.

Końcowy render zegara.

Screw - Skręcenie

Tryb: Edit Mode → Editing context F9

Panel: Mesh Tools → Screw

Narzędzie Screw łączy powtarzalny"Spin" z przesunięciem, by wytworzyć śrubkopodobny, lub spiralny obiekt. Użyj tego narzędzia by tworzyć śrubki, sprężyny lub muszelkowate kształty.

Jak zrobić sprężyne: Przed(lewy) i po(prawy) użyciu Screw.

Metoda używania "Screw" jest określona:

  • Ustaw 3DWindow na widok z przodu (1 NumPad).
  • Umieść kursor 3D na pozycji przez którą oś obrotu będzie przechodzić. Ta oś będzie pozioma.
  • Twój obiekt musi zawierać zarówno elementu skręcanego, jaki otwartą linię wierzchołków by określić przemieszczenie obrotu. Ta otwarta linia może być pojedynczą krawędzią, jak pokazano na obrazku, lub półkolem, lub czymkolwiek. Musisz się tylko upewnić że istnieją dwa 'wolne' końce; dwa wierzchołki należące do jednej krawędzi łączącej je. Funkcja Screw znajduje te dwa punkty i używa ich do obliczenia wektora przesunięcia, który zostanie dodany do "Spinu" w każdym pełnym obrocie (Jak zrobić sprężynę: Przed(lewy) i po(prawy) użyciu Screw). Jeśli te dwa wierzchołki znajdują się w tym samym miejscu wykona się normalny "Spin". W przeciwnym wypadku, ciekawe rzeczy się wydarzą!
  • Zaznacz wszystkie wierzchołki które mają brać udział w "Skręceniu".
  • Ustaw liczbę kroków Steps: i obrotów Turns: w panelu Mesh Tools na pożądane wartości. Steps: określa jak wiele profil będzie powtórzony w każdych 360° obrotu, a Turns: ustawia ilość pełnych 360° obrotów jakie się wykonają.
  • Wciśnij Screw
Powiększające się skręcenie (prawo) uzyskane przy pomocy profilu po lewej.

Jeśli masz kilka 3DWindow, kursor zmieni się w znak zapytania. Kliknij 3DWindow w którym Screw powinien być wykonany. Jeśli dwa "wolne" końce są wyrównane wynik będzie podobny do powyższego. Jeśli nie są, przesunięcie wektora w pionie jest równe składowej pionowej wektora łączącego dwa "wolne" wierzchołki, podczas gdy pozioma składowa odpowiada za zwiększenie (bądź zmniejszenie) skręcenia jak pokazano na (Powiększające się skręcenie (prawo) uzyskane przy pomocy profilu po lewej.).

Warp Tool - Narzędzie zawinięcia

Tryb: Edit Mode → Przyciski Edycji F9

Panel: Mesh Tools → Warp

Narzędzie Warp jest mało znane w Blenderze, częściowo dlatego że nie jest odnajdywane w oknie przycisków edycji, i częściowo dlatego że jest użyteczne tylko w bardzo specyficznych przypadkach. W każdym razie, nie jest to coś czego przeciętny użytkownik blendera potrzebuje każdego dnia.

Kawałek tekstu owinięty na pierścieniu jest przydatny gdy tworzymy latające loga, ale mógłby być trudny do wykonania bez użycia warp tool. Przykładowo chcemy owinąć frazę "Amazingly Warped Text" wokół sfery.

  • Najpierw dodajmy sferę.
  • Potem dodajmy tekst w widoku z przodu, w przyciskach edycji w panelu Curve and Surface ustawmy Extrude na 0.1 - tworząc tekst 3D, i ustawmy Bevel Depth na0.01, dodając ładne ścięcia na krawędziach. Ustaw Bev Resol na 1 lub 2 by mieć bardziej płynne przejścia i zmniejsz rozdzielczość tak aby liczba wierzchołków nie była za duża gdy będziesz używał później subdivide (panele Curve and Surface i Font).
  • Zamień obiekt na krzywe a następnie na siatkę, (dwa razy AltC ) ponieważ narzędzie warp nie działa na tekście czy też krzywych.
  • Podziel siatkę dwa razy(WSubdivide Multi → 2), tak aby kształt zmieniał się płynnie bez artefaktów.

Zmień na widok z góry i przesuń siatkę z dala od kursora 3D. Ta odległość określa promień zawinięcia. (See Widok z góry na tekst i sferę.)

Widok z góry na tekst i sferę

Przejdź do trybu edycji {⇆ Tab) i wciśnij A by zaznaczyć wszystkie wierzchołki. Wciśnij ⇧ ShiftW by uaktywnić narzędzie warp. Przesuń kursor myszy w górę lub w dół by dopasować stopień zawinięcia. (Zawinięty tekst). Przytrzymanie Ctrl zmienia zawinięcie co pięć stopni.

Zawinięty tekst

Teraz możesz zmienić na na widok z kamery, dodać materiały i światła i wyrenderować (Końcowy rendering).

Końcowy rendering

To Sphere - do sfery

Tryb: Tryb Edycji → Przyciski Edycji F9

Panel: Mesh Tools(en) → To Sphere

Skrót: ⇧ ShiftCtrlS

Innym mało znanym narzędziem jest To Sphere (⇧ ShiftCtrlS). Ta komenda pozwoli ci stworzyć sferę z podzielonego sześcianu.

Najpierw, zacznij od Sześcianu. Ja zacząłem od niego, usuwając wszystko (Ctrl X).

  • Wciśnij ⇆ Tab by przejść do Edit Mode.
Przycisk To Sphere w przyciskach edycji.
  • Upewnij się, że wszystkie wierzchołki sześcianu są zaznaczone przez użycie A dwa razy. Następnie przejdź do Przycisków edycji wciskając F9. Powienieneś teraz widzieć panel Mesh Tools(en).
  • Podziel sześcian przez wciśnięcie przycisku Subdivide w panelu Mesh Tools, lub przez wciśnięcie W i kliknięcie "Subdivide". Możesz zrobić to ile razy chcesz; im więcej dzielisz tym gładsza będzie twoja sfera.
  • Kliknij przycisk To Sphere w panelu Mesh Tools. Wybierz "100" aby uzyskać pełną sferę. Oczywiście, możesz równie dobrze wcisnąć ⇧ ShiftCtrlS i wpisać "1.000" by uzyskać ten sam efekt.

Sfera jest gotowa!

Gotowa sfera niskiej rozdzielczości!