From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

はじめに

多くのプログラムにおいて、選択とは操作の対象となる要素がどれになるかを決める事です。そのため、選択ツールの改善がより進めば意図する操作を行いやすくなります。Blender におけるツール類と機能はとても多様であり、それは選択方法についても同様です。

以下に示すのは概要と Object モード において利用可能な選択ツールについてです。

選択とアクティブな Object

Blender は選択において2つの異なる状態を区別します:

未選択の Object は暗く、選択された Object はオレンジ、アクティブな Object は黄色
  • Object モード では最後に選択 (選択解除) されたアイテムを "アクティブな Object" と呼び、外形が黄色で (その他はオレンジで) 表されます。アクティブな Object は (たとえ何も選択されていない状態であっても) ただ1つだけいつでも存在します。
Blender における多くの操作は、例えばリンク操作のように、アクティブな Object を参照します。あなたが既に Object を選択していて現在と違う Object をアクティブにしたい場合は、その Object を ⇧ ShiftRMB Template-RMB.png によって選択します。
  • アクティブでないそのたの Object は単なる選択された Object です。Object はいくらでも選択する事ができます。


ポイント選択

最も単純な Object の選択方法で、Object 上で RMB Template-RMB.png を押すだけです。

選択に追加するためには、他の Object 上で ⇧ ShiftRMB Template-RMB.png を押してください。

View 上でObject 同士が重なり合っていた場合、AltRMB Template-RMB.png によって選択可能な Object のリストが得られます。

この方法で選択された Object に追加するためには ⇧ ShiftAltRMB Template-RMB.png というショートカットを利用します。

既に選択された Object をアクティブ化するには、その Object 上で ⇧ ShiftRMB Template-RMB.png をクリックしてください。

アクティブな Object を選択解除するには、⇧ ShiftRMB Template-RMB.png をもう一度押してください -  つまりアクティブではないが選択された Object を選択解除するには2回押すことになります。

境界(矩形)選択

モード: Object モード

ホットキー: B

メニュー: SelectBorder Select

説明

境界選択 では LMB Template-LMB.png を押しながら長方形を描きます。部分的でも描かれた長方形の領域内に存在した全ての Object が選択されます。

Object を選択解除するには、MMB Template-MMB.png を利用してください。

選択をキャンセルするには、RMB Template-RMB.png を利用してください。

境界選択の段階

上図では、最も左の画像で境界選択が適用され交差する点線のカーソルの表示によってそれが分かります。続いて真ん中のの画像では選択範囲LMB Template-LMB.png を押しながら長方形を描くことで選択されています。最も右の画像では選択は LMB Template-LMB.png ボタンを離すことで完了します。

最も右の画像において、左側のより明るい色の立方体に注目してください。これが"アクティブな Object" であり、境界選択ツールを利用する直前に選択されていた Object です。

ヒント

境界選択は直前までの選択に Object を追加するので、長方形で囲まれた Object のみを選択する場合は、最初に A キーを押して全ての選択を解除してください。

投げ縄選択

モード: Object モード

ホットキー: CtrlLMB Template-LMB.png

メニュー: メニューには項目無し

説明

投げ縄選択は Object モード において Object のピボット・ポイントの周りを点線で囲んで利用します。

使い方

Ctrl キーを押している間、ピボット・ポイントの周りで選択したい Object をLMB Template-LMB.pngを押しながら囲みます。

投げ縄選択は直前の選択範囲に追加されます。投げ縄選択の範囲を選択解除をするためには、Ctrl⇧ ShiftLMB Template-LMB.png を利用してください。

投げ縄選択


メニューによる選択

ここまでに示された方法は一般的な選択手法です。 3D ビューの Select メニューのにはさらに多くの利用可能なオプションが存在します。

それぞれの小節ではより場合ごとの操作に関連した説明がなされます。

グループ選択

モード: Object モード

ホットキー: ⇧ ShiftG

メニュー: SelectGrouped

説明

Grouped selection menu

1つの Object をその他1つに関連付けるには2通りの方法が有ります。最初の方法は親子関係にする事、もうひとつが単なるグループ化です。これらの関係を、それぞれの親子関係やグループ毎の要素を選択する上で利用できます。

オプション

Object モードSelect → Grouped メニューではアクティブな Object を他の Object を選択する際の基礎として利用します。

利用可能なオプションは:

Children
アクティブな Object の全ての子を再帰的に選択します。
Immediate Children
アクティブな Object の直接的な子を全て選択します。
Parent
アクティブな Object の親が存在すれば選択します。
Siblings
アクティブな Object の親が共通の Object を選択します。これは (親となる Object が存在しない時に) ルート・レベルの Object を全て選択する際にも利用できます。
Type
アクティブな Object とタイプが同じ Object を選択します。
Layer
アクティブな Object と少なくとも1つのレイヤーを共有している Object を選択します。
Group
アクティブな Object が含まれるグループ内の Object が選択されます。
Object Hooks
アクティブな Object に対してフックしている Object 全てを選択します。
Pass
Render passe を共有している Object が選択されます。Render passe は PropertiesObjectRelations で設定でき、Node Compositor (AddConvertorID Mask) で利用されます。
Color
共通の Object Color を持つ Object が選択されます。Object Color は PropertiesObjectDisplayObject Color で設定できます。
Properties
共通した Game EngineProperties を持つ Object が選択されます。


リンク選択

モード: Object モード

ホットキー: ⇧ ShiftL

メニュー: SelectLinked

説明

リンク 選択メニュー

アクティブな Object と1つのデータブロックを共有している Object が全て選択されます。

オプション

Object モードSelect → Linked メニューではアクティブな Object を他の Object を選択する際の基礎として利用します。

利用可能なオプションは:

Object Date
同じ Object データにリンクされている全ての Object を選択します。データ・ブロックとは Object のタイプ (メッシュ、Curve等) と構造 (頂点、空間上では調整された頂点等) を特徴付ける物です。
Material
共通したマテリアルのデータ・ブロックにリンクされた全ての Object を選択します。
Texture
共通したテクスチャのデータ・ブロックにリンクされた全ての Object を選択します。
Dupligroup
共通した Duplication のグループを利用している全ての Object を選択します。
Particle System
共通したパーティクル・システムを利用した全ての Object を選択します。
Library
共通したライブラリを持つ全ての Object を選択します。
Library (Object Data)


タイプによる選択

モード: Object モード

ホットキー: 無し

メニュー: SelectSelect All by Type

説明

タイプによる 選択メニュー

ここに有るタイプは MeshCurveSurfaceMetaArmatureLatticeTextEmptyCameraLamp です。

このツールによって特定のタイプの見える Object を選択する事ができます。

オプション

Select メニューの Select All by Type メニューは ObData データブロックに記述された全てのタイプの選択肢を提供します。

ご自由に選択ください。

レイヤーによる選択

モード: Object モード

ホットキー: 無し

メニュー: SelectSelect All by Layer

説明

レイヤーによる選択メニュー

レイヤーは Object 群を区分けするという目的に適している別の方法です。

この選択方法は可視不可視に関わらず、1つのコマンドでレイヤー毎に属する Object の選択を可能にします。

オプション

Tool Shelf において以下のオプションが適用可能です:

Extend
この設定を有効にすると、現在の選択を置き換えるのではなく、Object を追加できます。
Layer
Object が有るレイヤーを示します。
Blender3D FreeTip.gif
Object の選択
Select All by Layer を利用するよりも、必要なレイヤーを可視状態にして A キーを押してそれらを全て選択するほうが効果的かもしれません。この方法は Object を選択解除する際にも使えます。


その他の選択方法

3D View のメニューの第1段階で利用可能な選択法は:

Random
現在アクティブなレイヤーで未選択の Object からパーセントで表される可能性に基づいてランダムに選択されます。このコマンドを選択した際は Tool Shelf 内の数値選択ボックスを利用できます。
注意すべき事はこの設定されるパーセンテージは未選択の Object から選択される可能性を示しているのであり、選択されうる全ての Object の量に対する割合を示している訳ではない事です。
Inverse (CtrlI)
現在選択されていない全ての Object を選択し、選択されている Object は全て選択解除されます。
Select/Deselect All (A)
何らかの Object が選択されていた場合はそれらが選択解除されます。そうで無い場合は可視状態にあるすべての Object の全ての選択と選択解除を切り替えます。
Border Select (B)
既に示した 境界(矩形)選択 をご参照ください。