From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

複製

Mode: Edit and Object modes

Hotkey: ⇧ ShiftD

Menu: ObjectDuplicate

概要

これは、選択しているオブジェクト(複数可)と視覚的に同一なコピーを作成します。 コピーは元のオブジェクトと同じ位置に作成され、あなたは自動的に Grabモードに入ります。 以下の記述では (Duplicate Example) 図を参考に。

このコピーは新規のオブジェクトで、いくつかのデータブロックを元のオブジェクトと“共有”していますが (デフォルトでは、すべてのマテリアル、テクスチャ、 Ipos)、しかしそれ以外、例えばメッシュは、コピーになります。 この方式の複製が時々“浅いリンク”と呼ばれる理由がこれで、すべてのデータブロックが共有されるわけではなく、その一部が“ハードコピー”されます!

複製する際にどのタイプのデータブロックをリンクまたはコピーするか選択できることを覚えておきましょう: User Preferencesの(File メニューで利用可能) Editing “tab”で、 本当にDuplicate Dataリストにコピーしたいものだけを、そのタイプのデータブロックで有効にしましょう — 他のものは単にリンクされます。

The mesh Cone.006 of object Cone.002 is being edited. The mesh's Unique datablock ID name is highlighted in the Outliner.

真ん中のコーンから、 (1)リンク複製を左へ、 (2) 複製を右へ行なっています。.

  • 複製した右のコーンには編集を加えていても、中央のオリジナルコーンは変更されないままです。 メッシュデータが、リンクではなくコピーされています。
  • 同様に、右側のコーンがオブジェクトモードで編集されている場合も、オリジナルのコーンは変わりません。 新しいオブジェクトの変形プロパティまたはデータブロックは、リンクではなくコピーされます。
  • 右の円錐を複製すると、中央の円錐のマテリアルを継承します。 マテリアルの特性は、コピーではなくリンクされます。

データブロックが標準的にリンクされた別個のコピーが必要な場合は、上記を参照してください。

リンク複製

Mode: Object mode

Hotkey: AltD

Menu: ObjectDuplicate Linked

Description

また、 複製のかわりにリンク複製を作成する選択肢もあります。これはディープリンクと呼ばれています。 この方法で作成する新規オブジェクトは、元のオブジェクトにリンクされている すべての データを持ちます。 リンクされたオブジェクトのいずれかを編集モードで変更した場合、リンクされているすべてのコピーが変更されます。 変形プロパティ (object datablocks)はまだコピーのままで、リンクではないので、回転、拡大縮小、および移動は他のコピーに影響を与えることなく自由にすることができます。 以下の記述では (Duplicate Example) を参考に。

Examples

オブジェクト Cone.001はリンク複製されたものです。 これらのコーンは両方とも、 Coneという名前のついたメッシュとは別の一意の単一のオブジェクトですが、 アウトラインで強調表示されているところは 、両方で共有されています。

左のコーンは、中央のコーンをリンク複製したものです (AltDを使用)。

  • いずれかのオブジェクトの頂点を 編集モード で移動させると、オリジナルのコーンの同じ頂点も同様に移動されます。 メッシュデータはコピーではなく、リンクされます。
  • これとは対照的に、これら2つの円錐形の一方をオブジェクト·モードで回転または再スケーリングした場合、他方はそのまま変わりません。 変形プロパティはコピーされ、リンクはされません。
  • 前の例のように、新しく作成されたコーンは、元のコーンのマテリアルを継承しています。 マテリアル特性はコピーではなく、リンクされます。

一般的なテーブルは、天板と4本の脚を持っています。 脚を1本モデリングし、次にリンク複製を三回行って、残りの脚それぞれに使います。 後でメッシュに変更を加えると、すべての足を同じに揃えてくれます。 リンク複製はコップのセット、車のホイール、にも適します… 繰り返しや対称性はあらゆるところにあります。

Procedural Duplication

Mode: Object mode and Edit mode

Panel: Object settings

オブジェクトを手続き的に複製する方法は、Blenderには現在4つあります。 これらのオプションは、 Objectメニューに配置されています。

Verts 
これは、このオブジェクトの各頂点にあるすべての子のインスタンスを作成します(メッシュオブジェクトの場合のみ)。
Faces 
これは、このオブジェクトのそれぞれの面のすべての子のインスタンスを作成します(メッシュオブジェクトの場合のみ)。
Group 
これはグループのインスタンスを、オブジェクトの変形といっしょに作成します。 グループ複製は、アクションを使用してアニメーション化することができ、また Proxyになってもらうこともできます 。
Frames 
アニメーションオブジェクトにおいて、これがすべてのフレーム上でのインスタンスを作成します。 このトピックのサブページでわかるように、これは、オブジェクトを配置したり、それらをモデリングする用途でも非常に強力なテクニックです。


Linked Library Duplication

Hotkey: ⇧ ShiftF1

Menu: FileLink Append

Linked Libraries 
Linked Libraries もまた、複製のいち形態です。 他の.blendファイル内のあらゆるオブジェクトやデータブロックが、現在のファイルで再利用できます。

ヒント

  • 変形プロパティ (つまり object のデータブロック) を “リンク”、させたい場合は、 親子化のページを参照しましょう。
  • マテリアルの透過度は、 dupli-groups で実体化させると表示されません。 これはblenderの view-port からくる制限だということがわかっています。