From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

View Shading

(ビューの陰影処理)

モード: 全モード

ホットキー: Z / ⇧ ShiftZ / AltZ / ⇧ ShiftAltZ / D

Description

(解説)

コンピュータの速度、シーンの複雑さ、作業内容に応じて、複数の描画モードを切り替えることができます(訳注:モード種類はバージョンによって多少変わります):

3Dビューの描画モードボタン
レンダード(Rendered)
レンダリングプレビューを表示します。
テクスチャ(Textured)
OpenGL ライティングを使って、UV画像テクスチャを貼ったモデルを表示します。プロシージャル(procedural)や UVマップされていないテクスチャは表示されません。
Shaded
(訳注:Blender 2.6 にはありません)各頂点のすべてのテクスチャとライティングを概算し、次々に混ぜ合わせます。レンダーエンジンを使ってテクスチャを確認するよりもかなり正確性に欠けますが、高速です。なお、シーンに照明がないと何もかも黒いままです。
ソリッド(Solid)
面を組み込みの OpenGL ライティングでベタ塗りする、デフォルトの描画モードです。この描画モードはシーンの光源に左右されません。設定はユーザー設定 ウィンドウの システム タブにある ソリッド OpenGL ライト(Solid OpenGL lights) で変更できます。
システム設定についてもっと詳しく »
ワイヤーフレーム(Wireframe)
オブジェクトが線だけで描かれ、形状がわかりやすくなります(つまりメッシュやサーフェスの辺です)。
バウンディングボックス(Bounding Box)
オブジェクトはまったく描かれません。替わりに、オブジェクトのサイズや形状に応じた直方体だけを表示します。

描画モードの切り替えには次のいずれかを使います:

  • 3D ビューのヘッダーにある 描画モード のドロップダウンリスト(図「3Dビューの描画モードボタン」)。
  • D を押して 描画モード メニューをポップアップさせます。
  • Z-ベースのショートカット。下記参照:
描画モードとZベースのショートカット。
Z描画モード ワイヤーフレーム(Wireframe)ソリッド(Solid) を切り替えます。
⇧ ShiftZ描画モード ワイヤーフレーム(Wireframe)Shaded を切り替えます。
AltZ描画モード ソリッド(Solid)テクスチャ(Textured) を切り替えます。
⇧ ShiftAltZテクスチャ(textured) 描画モードに切り替えます。

View Properties Panel

(ビューのプロパティパネル)

モード: 全モード

パネル: Properties(プロパティ)

メニュー: View(ビュー) » View Properties(プロパティ)...

Description

(解説)

上述のヘッダーにあるコントロールに加えて、View(ビュー)のプロパティ) パネルで 3D ビューに関するその他の設定を行えます。View(ビュー) » Properties(プロパティ)... メニューから表示できます。

View

(ビュー)

レンズ(Lens)
3Dビューのカメラの焦点距離を、レンダリングカメラ の設定とは別の、ミリメートル単位で調整します。
オブジェクトに注視(Lock to Object)
オブジェクト欄にオブジェクト名を入力すると、そのオブジェクトにビューを固定します。つまり、オブジェクトが常にビューの中心になります(唯一の例外はアクティブカメラビュー 0 NumPad です)。
注視するオブジェクトがアーマチャなら、さらに ボーン(Bone) 欄に名前を入れて、そのボーンを注視できます。
カーソルを注視(Lock to Cursor)
ビューの中心を 3Dカーソルの位置に固定します。
カメラをビューにロック(Lock Camera to View)
カメラビューにいるとき、カメラビューにとどまったまま 3D 空間にあるカメラを動かすのに使ってください。
クリップ開始(Clip Start)クリップ終了(Clip End)
ビューポートに表示されるものの最小/最大距離を調整します。
註記
Exclamation mark.png
クリップ範囲を広くすると遠近両方のオブジェクトを見ることができますが、深度の精度が下がります。

これを回避するには...

  • 大きな画面で作業するときはクリップ開始値を増やします。
  • オブジェクトを遠くから見ないときはクリップ終了値を減らします。

透視投影が無効の場合はクリップ終了値だけが使われます。非常に高い値にすると描画の乱れ(artifacts)が起こる可能性があります。

これは blender 特有の問題ではなく、OpenGL/DirectX グラフィックスを使うアプリケーションはすべて、同じ制限を持ちます。

例:


ローカルカメラ(Local Camera)
このビューで使われているアクティブなカメラ
3D カーソルの位置(3D Cursor Location)
3D カーソルの位置を精密に定義できます。

Item

(アイテム)

このセクションには、現在選択しているオブジェクトを表示します。

Display

(表示)

レンダリングのみ(Only Render)
レンダリングされるものだけを表示します。
選択時にアウトライン表示(Outline Selected)
無効にすると、 ソリッド(Solid)/Shaded/テクスチャ(Textured) 描画タイプで選択オブジェクトの周囲に描かれるピンクのアウトラインが表示されなくなります。
全てのオブジェクトの原点(All Object Origins)
有効にすると、オブジェクトの中心を示す点が、オブジェクトの非選択時を含めて常に表示されます(デフォルトでは、ソリッド/shaded/テクスチャシェイディングでは、非選択のものの中心はジオメトリに隠されるかもしれません…)。
関係の線(Relationship Lines)
親子関係(parenting)、拘束(constraining)、フック(hooking)を示す点線の表示/非表示を切り替えます。
All Edges
オブジェクト コンテキストでワイヤーオーバーレイ(wire overlay)が有効のとき、すべてのワイヤーフレームをビューポートに表示します。
グリッドフロア(Grid Floor)
無効にすると、平行投影の上面図/正面図/側面図以外のビューでグリッドを表示しません。
X軸, Y軸, Z軸
平行投影の上面図/正面図/側面図以外のビューで、どの軸を表示するか決めます。
ライン(Lines)
平行投影の上面図/正面図/側面図以外のビューで、グリッドを構成する線の数を調整します(両方向)。
拡大縮小(Scale)
グリッドフロアのサイズを調整します。
細分化(Subdivisions)
ズームインしたときに各マス目の内側に現れる線の数を調整します。したがって平行投影の上面図/正面図/側面図専用の設定です。
シェーディング(Shading)
3D ビューにあるオブジェクトのシェーディング方式を調整します。
テクスチャソリッド(Textured Solid)
テクスチャを割り当てた面をソリッドビューで表示します。
四分割表示(Toggle Quad View)
4つ描画域のある 3D ビューの切り替えです。フレームの配置についてもっと詳しく »

Background Image

(下絵)

モード: 全モード

パネル: Background Image(下絵)

メニュー: View(ビュー) » Properties(プロパティ)...

3Dビューに下絵を置くと非常に役立つ状況が多くあります。モデリングは当然のこと、ペインティングや(モデルに直接テクスチャを描くときに、各面の参照画像を設定できます)アニメーション(動画を下絵にするとき)などです。

Exclamation mark.png
下絵には特筆すべき点がいくつかあります。:
  • ウィンドウに対して指定します(つまり 3D ビューごとに別の下絵を指定できます。例:上面図/正面図/側面図の下絵を対応するビューに置く、など)
  • 平行投影の 上面図側面図正面図 (およびそれぞれの反対側のビュー)にしか使えません! これら6つのビューを切り替えても、画像は同じままです。
  • 画像サイズはウィンドのズーム率に結びついています(例えばズームインすると大きくなります)。
  • 動画やアニメーションシーケンスを使えます。

Settings

(設定)

下絵パネル

この機能はビューのプロパティパネル (N) にある 下絵(Background Image) メニューから利用できます。最上段にあるチェックボックスで 下絵 機能をオン/オフ切り替えします。デフォルトでは1枚の画像用のスペースしかありません。白い三角形を LMB Template-LMB.png すると設定の一覧が現れます。

有効化すると、下絵に使う画像を既存のデータブロックから選ぶか、新たに画像を読み込むことができます。座標軸(Axis) メニューは下絵を表示するビューを決めます。画像を追加(Add Image) ボタンをLMB Template-LMB.png して、さらに画像を追加することができます。画像を読み込むと、次の設定が利用できるようになります。

ソース(Source)
使うファイルの種類を選びます。選んだ種類によって、オプションがその下に現れます:
ファイル
画像ファイルを使います
ソースファイル(Source File)
現在のデータブロックにリンクされた実際のファイルを表示します。サポートされる形式には bmp、gif、jpg、png、tga、tif があります。
シーケンス(Sequence)
番号が振られた一連の画像ファイル
フレーム(Frames)
シーケンス内で使う画像ファイルの数
開始(Start)
開始フレーム番号
オフセット(Offset)
シーケンス内で使うフレーム番号のオフセット
Fields
描画フレームごとのフィールド(fields)数
自動更新(Auto Refresh)
フレームの変更時、画像を自動更新します
繰り返し(Cyclic)
シーケンス内の画像を繰り返します
動画(Movie)
動画ファイルを使います:
動画の長さとマッチ(Match Movie Length)
フレーム数を動画に合わせます
生成(Generated)
Blender 内で生成した画像を使います:
幅(Width), 高さ(Height)
画像の幅と高さをピクセル単位で指定します。
ブランク(Blank)
空の画像を生成します。
UVグリッド(UV Grid)
UVマッピングのテスト用のグリッドを作ります。
カラーグリッド(Color Grid)
UVマッピングのテスト用のカラーグリッドを作ります。

不透明度(Opacity)

下絵の透明度を調整するスライダーです(0.0(完全な不透明)から 1.0(完全な透明)の範囲内)。

サイズ(Size)

3D ビューでの画像のサイズを調整します(単位は Blender Unit です)

X オフセット, Y オフセット

ビュー内の下絵の横方向/縦方向のオフセット(デフォルトは原点上に置かれます。単位は Blender Unit です)。
Blender3D FreeTip.gif
低解像度の代用品を使いましょう
PC の処理効率向上のため、下絵を使うときは低解像度の代用品を使う必要があるかもしれません。モニタが解像度が 800×600 なら、フルスクリーン、ズームなしの下絵は 800×600 あれば十分です。もし下絵が 2048×2048 なら、コンピュータはピクセルの放棄に精を出します。2k×2k 画像を使うのではなく、(Blenderや Gimp を使って)例えば 512×512 などに縮小してみてください。画質や正確さを失うことなしに、処理効率は16倍良くなるでしょう。そして、モデルが洗練されるに従って、解像度を増やすことができます。


Shortcuts

(ショートカット)