From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Préférences utilisateur et thème

Dans Blender, vous pouvez personnaliser vos réglages par défaut, et une fois satisfait, les enregistrer via File » Save Default Settings (CtrlU). Si jamais vous voulez repartir de zéro, restaurez simplement les réglages “d’usine” via File » Load Factory Settings.

Blender a quelques options qui ne sont pas enregistrées dans chaque fichier, mais qui s’appliquent à tous les fichiers d’un utilisateur. Ces préférences concernent avant tout des détails de gestion de l’interface utilisateur, des propriétés système comme la souris, les polices de caractères, et les langues.

Puisque ces préférences utilisateurs sont rarement utilisées, elles sont cachées derrière le menu principal. Pour les afficher, faites glisser vers le bas la bordure de ce menu (normalement, tout en haut de l’écran). Les réglages sont regroupés en sept catégories qui peuvent être sélectionnées avec la ligne de boutons inférieure montrée dans (La fenêtre User Preferences).

La fenêtre User Preferences.
L’onglet View & Controls.
L’onglet Edit Methods.
L’onglet Language & Font.
L’onglet Themes.
L’onglet Auto Save.
L’onglet System & OpenGL.
L’onglet File Paths.
Note
Étant donné que la plupart des contrôles sont explicites, ou affichent une info-bulle utile si vous maintenez la souris immobile au-dessus d’eux, nous ne les décrirons pas en détail ici. Nous vous donnerons plutôt un aperçu des catégories de préférence, ainsi que quelques suggestions.
De toute manière, ces réglages seront également abordés dans les chapitres concernés…


View & Controls

Ces réglages concernent les réactions de l’interface aux actions de l’utilisateur, comme quelle méthode de rotation utiliser dans les vues 3D. Vous pouvez aussi y activer l’émulation d’une souris à trois boutons si vous n’en avez que deux sur la vôtre. MMB Template-MMB.png peut alors être simulé avec AltLMB Template-LMB.png.

En particulier, mettons en avant le réglage Smooth View utilisé lors des transitions de votre fenêtre 3D d’une vue à l’autre (par ex. de la vue de dessus à celle de côté). Une plus grande valeur (par ex. 1000ms) adoucit la transition de vue à vue, au lieu du saut abrupt. C’est un effet très plaisant présent dans d’autres paquets logiciels, bien qu’il soit plus une “friandise visuelle” que réellement utile !

Edit Methods

Vous pouvez ici spécifier les détails concernant le fonctionnement de certaines commandes d’édition, telle que la duplication (Duplicate with object). Vous pouvez également spécifier le nombre d’annulations possibles et préciser si elles doivent fonctionner localement ou globalement, voyez la page sur l’annulation.

Groupe Add New Objects
Activez Switch to Edit Mode si vous voulez que Blender passe automatiquement en mode Edit quand vous ajoutez un objet.
Activez Aligned to View et, quand de nouveaux objets seront ajoutés, ils seront automatiquement orientés face à la vue courante. Sinon, ils seront alignés avec les axes globaux (c-à-d qu‍’ils auront toujours des rotations nulles).

L’automation des clés d’animation est également partiellement contrôlé d’ici, voyez la page sur la timeline du chapitre sur l’animation pour plus de détails.

Language & Font

International Fonts, une fois activé, vous permet de choisir la langue et la police de l’interface (par ex. pour avoir les caractères Kanji ou Pharsi (?)).

Si vous choisissez une autre langue que l’anglais, vous pouvez choisir quelles parties de la GUI devraient être traduites – Tooltips (les info-bulles), Buttons (les contrôles) et/ou Toolbox (boîte à outils – une bonne idée serait de n’activer que les info-bulles, de façon à conserver l’interface elle-même en anglais, comme dans ce manuel, mais à avoir les petits messages d’aide dans votre langue natale).

Themes

Blender permet l’utilisation de thèmes pour définir des couleurs et icônes d’interface personnalisées. Vous pouvez gérer les thèmes d’ici, et deux sont intégrés par défaut : Default et Rounded. Beaucoup d’autres sont disponibles sur Internet, comme “Dark Alpha” ou “GONX”. Chaque thème est un script Python, finissant généralement par *theme.py. Vous pouvez importer les thèmes d’autres personnes en copiant simplement leur script Python dans votre dossier Blender/scripts et en redémarrant Blender. Une fois cela fait, ouvrez une fenêtre Scripts, cliquez Scripts » Themes et sélectionnez le thème choisi. Fermez Blender. Une fois celui-ci à nouveau relancé, vous verrez vos thèmes listés dans la fenêtre User Preferences, onglet Theme. Pressez finalement CtrlU pour enregistrer ce thème comme celui par défaut.

Pour conserver votre thème courant quant vous ouvrez un nouveau fichier, désactivez le bouton Load UI.

Default
Toutes les images de ce wiki ont été capturées avec le thème et les icônes par défault (Default), afin que tout soit clair et cohérent. Si vous consultez un tutoriel privé, ou une capture sur un forum, gardez à l’esprit qu’elles pourraient avoir des couleurs et des icônes totalement différentes, et que vous devrez alors vous baser sur les position et nom des contrôles.


Personnaliser un thème

Cliquez sur un thème personnalisé dans la liste, ou ajoutez (Add) une copie de celui par défaut. Plusieurs colonnes de contrôles supplémentaires vont alors apparaître. Dans la deuxième colonne, vous avez dans l’ordre :

  • Le nom du thème. Cliquez dans ce champ pour l’éditer.
  • La section du thème à modifier, essentiellement organisé par type de fenêtre.
  • L’élément de cette section à personnaliser (par ex. la couleur d’arrière-plan ou du texte…).

La colonne suivante affiche les réglages actuels de cet élément (souvent une couleur, mais également parfois une taille, etc.).

Vous pouvez exporter votre thème modifié en tant que fichier Python avec l’entrée de menu File » Export » Save Current Theme... (qui, au fait, appelle un script python…).

Auto Save

Cette partie est abordée dans la page sur l’annulation plus loin dans ce chapitre.

System & OpenGL

Cet onglet rassemble des réglages plus avancés, plus techniques.

Solid OpenGL lights
Quand vous travaillez en vue Solid, vous pouvez “éclairer” les objets de votre espace de travail avec jusqu’à trois sources lumineuses OpenGL. La direction de chaque source est réglée en cliquant-tirant dans le sphères-lumière, et les couleurs de l’ombrage diffus et spéculaire le sont en cliquant dans l’échantillon de couleur approprié et en utilisant le sélecteur de couleur qui apparaît.
Auto Run Python Scripts
Quand il est activé (il l’est par défaut), sélectionner un script depuis une entrée de menu exécute ce script. Cependant, Python est un langage puissant, et si vous suspectez un virus ou récupérez un fichier .blend d’une source douteuse, désactivez ce réglage avant d’ouvrir le fichier blend pour prévenir l’exécution du script.
Win Codecs
Windows seulement !
Les codecs sont des routines qui encodent et décodent les flux vidéo. Activez cela pour utiliser tous les codecs trouvés sur votre système. Certains codecs peuvent mal se comporter, et se faire de la “publicité mensongère”. Si vous avez un de ces codecs pontifiants sur votre système, désactivez ce réglage.
Color range for weight paint
Quand vous peignez les poids, par défaut nous utilisons un dégradé très coloré pour représenter les poids de 0.0 (bleu) à 1.0 (rouge). Si vous voulez utiliser un autre ensemble de couleurs pour matérialiser ces valeurs de poids, activez ColorBand et utilisez le contrôle de dégradé pour personnaliser ses couleurs.
Audio mixing buffer
Quand vous mixez de l’audio, ou en utilisez dans le moteur de jeu, cela vous permet de mettre de côté de la mémoire pour le son.
Verse
Pas toujours disponible !
Verse permet à plusieurs utilisateurs de travailler sur le même fichier blend. Entrez ici l’URL du maître (master) et votre nom d’utilisateur. Puis utilisez le sous-menu File » Verse pour vous connecter à vos camarades.
Keyboard
Activez Emulate Numpad si vous n’avez pas de pavé numérique et voulez l’émuler (pour les portables). Si vos gros doigts ne cessent de presser cette satanée touche de verrouillage majuscule au lieu de celle de tabulation, désactivez ce réglage.
Exclamation mark.png
Cette fonctionnalité semble inopérante avec les claviers français (azerty)…
System
Divers réglages système. Prefetch frames (~“précharger les images”) permet à Blender d’avoir des images d’avance en mémoire, ce qui vous permet de travailler plus confortablement. Si vous utilisez beaucoup le Video Sequence Editor, vous pourriez souhaiter augmenter votre mémoire cache (MEM Cache Limit. Si vous rendez des frames à la demande, en tant qu’esclave (!), entrez le numéro de port à écouter pour les requêtes, dans le champ numérique Frameserver Port.
OpenGL
Ce groupe de contrôles vous permet de régler finement comment OpenGL affiche les textures et fonctionne sur votre système.

File Paths

Dans cet onglet vous pouvez choisir les chemins par défaut pour divers dialogues d’ouverture de ficher. Rappelez-vous que // au début d’un chemin signifie “là où le fichier .blend est actuellement enregistré”. / au début signifie le répertoire racine du disque actif (ou le root sous les unixes).

Relative Paths Default
Ce bouton se trouve en haut à droite du panneau. Si vous l’activez, le chemin interne vers tout fichier annexe, comme une image texture, sera enregistré, non comme un chemin absolu commençant avec le lettre de lecteur ou le root, mais comme un chemin relatif démarrant à l’emplacement du fichier .blend. Cela vous permet de compresser/archiver, de déplacer des projets entiers entre PC, et de retrouver tous le fichiers annexes, même si sur le PC A vous avez enregistré le fichier .blend sur le disque C: et que sur le PC B vous enregistrez le fichier .blend sur le disque D:. Utilisez cette fonctionnalité si vous pensez avoir besoin de partager un projet, ou de travailler dessus sur plusieurs machines.
YFexport
Blender communique avec YafRay en exportant un fichier XML. Ce chemin dit à Blender où enregistrer ce fichier – le dossier temporaire de votre OS devrait être un bon choix (C:\tmp\ ou /tmp/).
Fonts
Où trouver les polices TrueType, par ex. C:\Windows\Fonts\ ou /usr/share/fonts.
Render
Où placer les fichiers de rendu, comme par exemple //render.
Textures
Où trouver les photos et images pour les textures. Vous devriez le faire pointer sur votre bibliothèque d’images locale. Ou alors, vous pouvez utiliser une copie locale de vos textures relativement à votre projet (commençant par //, vous vous rappelez ?), si vous voulez le garder portable.
Python Scripts
Où trouver les scripts Python d’extension de Blender. S’il est laissé vide, Blender utilise les scripts distribués avec lui, qui se trouvent dans votre dossier d’installation sous .blender/scripts.
Exclamation mark.png
Ce chemin ne devrait pas finir par un slash – il s’agit là d’une exception…
Tex Plugins
Où trouver les plugins de texture.
Sounds
Où trouver les fichiers son pour les bandes-sonores et les effets sonores. Mêmes remarques que pour le chemin Texture.
Seq Plugins
Où trouver les plugins d’effet (ceux utilisés par l’éditeur de séquences vidéos)…
Temp
La corbeille-à-tout-faire, là où votre session de clôture est enregistrée (quit.blend), ainsi que les fichiers de sauvegarde automatique. Utilisez le dossier temporaire de votre OS, comme C:\tmp\ ou /tmp/

Vous pouvez entrer un chemin à la main, ou cliquer LMB Template-LMB.png sur la petite icône “dossier” à droite du champ texte pour utiliser le File Browser (navigateur de fichier) de Blender, pour naviguer dans votre disque dur/réseau. Cette dernière méthode est recommandée afin d’éviter les fautes de frappe.

Si l’un des dossiers change de nom, ou qu’il est déplacé ou supprimé, vous devrez revenir ici pour le modifier à nouveau, car Blender n’a aucun moyen d’être informé de ces changements.

Enregistrer vos préférences

Quand vous pressez CtrlU, vous enregistrez un fichier appelé .B.blend dans le dossier .blender de votre installation de Blender, qui contient les réglages actuels, y compris toutes les dispositions d’écran et toutes les scènes. Notez qu’à cause de son nom étrange (commençant par un point), beaucoup d’OS pourraient essayer de vous le cacher. Il peut également être sauvé dans un dossier “Application Data” (données d’application) spécifique à votre profil utilisateur. Si vos changements ne sont pas enregistrés, assurez-vous d’avoir les droits nécessaires à la modification de fichiers dans ce dossier – cela est particulièrement un problème avec Microsoft Vista/7, qui ne permet par défaut à aucun programme de modifier un quelconque fichier du dossier Program Files.

Quoi qu’il en soit, c’est un fichier .blend tout à fait ordinaire, donc si vous avez des objets et ainsi de suite dans votre fichier, quand vous pressez CtrlU, ceux-ci feront partie des réglages par défaut la prochaine fois que vous démarrerez Blender.

Si le fichier est perdu ou accidentellement supprimé, Blender le re-créera au prochain démarrage, avec les réglages d’usine par défaut.