From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Après le dépliage, vous devez arranger, disposer les cartes UV d'une manière qui puisse être peinte logiquement. Les buts de ces modifications sont:

  • Disposer les différentes cartes UV de manière cohérente;
  • Rassembler, recoudre certains morceaux (cartes UV) ensemble;
  • Minimiser l'espace inutilisé dans l'image;
  • Agrandir les "faces" que vous voulez détailler le plus;
  • Élargir les "faces" qui sont (trop) étirées;
  • Réduire les "faces" qui sont trop "granuleuses" ("grainy"), trop détaillées.

Moins il y a "d'espace mort", plus il y a de pixels qui peuvent être utilisés pour donner un maximum de détails et de finesse à la texture UV. Une face UV peut être aussi petite qu'un unique pixel (les petits points qui constituent une image), ou aussi grande qu'une image entière. Vous voudrez probablement faire d'abord quelques modifications importantes, puis passer aux réglages fins.

Modifications importantes

Une fois que vous avez effectué le dépliage, en utilisant peut être des coutures, vos cartes UV pourraient être assez désorganisées, voir chaotiques. Vous devez procéder en deux étapes: orientation générale du plaquage UV, puis disposition des différentes cartes UV.

Vue 3D: miroir et rotation d'UVs

Vous vous rappelez que les lignes rouges et vertes reflètent l'orientation de la texture UV par rapport à la face? Et bien, vous pourriez découvrir que, par exemple, que l'image est renversée, ou couchée sur le côté. Si c'est le cas, utilisez le menu FaceRotate UVs (dans une fenêtre 3D View, en mode Face Select) pour faire tourner l'ensemble du plaquage UV par pas de 90°. Et FaceMirror UVs retourne l'image comme une crêpe, inversant le plaquage UV, comme s'il était vu dans un miroir ("mirror").

Réunir des cartes UV

A chaque fois que vous dépliez, Blender crée un ensemble de coordonnées UV montré dans l'UV/Image Editor. Donc, si vous dépliez deux faces d'un cube, puis trois autres, et enfin la dernière restante, il y aura trois ensembles de coordonnées UV, ou "cartes UV". Vous effectueriez ainsi vos dépliages si vous vouliez utiliser trois images différentes pour ces trois cartes. Cependant, si vous changez d'avis, sélectionnez simplement toutes vos faces (les six dans notre exemple), et réutilisez l'Archimapper (menu UVsUnwrap de la fenêtre UV/Image Editor). La carte sera recalculée pour enlever les recouvrements.

Séparer des cartes UV

Si vous voulez utiliser une image différente pour un ensemble de faces particulier, mais que ces faces sont déjà dépliées dans une autre texture UV (image), sélectionnez simplement ces faces et dépliez-les de nouveau. Dans l'UV/Image Editor, une nouvelle carte apparaîtra pour elles, et vous pourrez lui assigner une nouvelle image.

Arranger la disposition UV

Menu de transformation UV.

Dans l'UV/Image Editor vous verrez une représentation de vos faces sélectionnées comme des points jaunes ou mauves reliés par des lignes en pointillés. Partout où il y avait une couture ou un sous-mesh déconnecté, il y aura une carte UV pour ce morceau. Pendant le dépliage, ces morceaux peuvent être orientés de manière illogique de votre point de vue de peintre. Vous pouvez utiliser ici les mêmes techniques que dans le mode Edit pour sélectionner, déplacer, faire tourner, mettre à l'échelle, et ainsi de suite. Avec le bouton Lock activé, vous aurez également un retour en temps réel, dans la vue 3D, de ce que vous faites. Le déplacement ou la mise à l'échelle peuvent être réalisés sur l'un des axes locaux X (U) ou Y (V) de la carte si nécessaire: tapez simplement X ou Y après la commande (Grab pour déplacer, Scale pour la mise à l'échelle). L'édition proportionnelle ("proportional editing") est également disponible, et elle fonctionne de la même manière qu'avec un mesh en mode Edit. Les vertices dans l'UV/Image Editor peuvent aussi être cachés/ré-affichés via H et AltH respectivement, exactement comme en mode Edit.

Select Linked, Grab, et Rotate pour arranger la disposition du plaquage UV.

Quand vous créer une disposition UV, gardez à l'esprit que la fenêtre entière est votre espace de travail, bien que l'image ne soit plaquée que sur les coordonnées UV situées dans le carré noir. Donc, vous pouvez déplacer des morceaux sur le côté pendant que vous les arrangez. Chaque dépliage UV est son propre ensemble relié de coordonnées. Vous pouvez les superposer, ils resteront tous visibles. Cependant, pour n'en modifier qu'un (déplacement, rotation, …), sélectionnez par RMB Template-RMB.png l'un de ses "vertices UV", puis utilisez SelectLinked UVs (CtrlL) pour ne sélectionner que les UVs qui lui sont reliés, et ne faites pas une sélection par boîte, car tous les UVs des différentes cartes superposées seraient alors sélectionnés!

Supprimer une texture UV

Un mesh peut avoir plusieurs dépliages, chacun donnant une carte UV pour la partie du mesh sélectionnée. Vous pourriez vous retrouver dans une situation où vous voudrez tout effacer et repartir de zéro. Dans la fenêtre Buttons, boutons Editing (F9), il y a un panneau Mesh. Dans ce panneau, cliquez sur le gras bouton X à côté du nom de la texture UV que vous voulez supprimer. Si vous effacez toutes les entrées ici, toutes les textures UV de ce mesh seront supprimées – et vous serez "éjecté" du mode UV Face Select. A l'instant où vous ré-entrez dans ce mode (F), vous re-créez automatiquement au moins une texture UV.

Menu de l'UV/Image Editor

Quand vous travaillez avec une disposition UV, vous passerez 99% de votre temps dans la fenêtre UV/Image Editor. Il y a beaucoup d'options et de possibilités dans cette fenêtre pour vous rendre efficace. L'en-tête est constitué d'un menu, d'un sélecteur d'image, et de quelques autres boutons. Certains de ces contrôles ne sont utiles que quand vous utilisez des images comme textures UV. Seuls ceux impliqués dans la modification du plaquage UV sont décrits dans ce qui suit.

Menu "View"

Ce menu contrôle ce que vous voyez, et comment vous le voyez, quand vous travaillez avec les UVs:

Maximize Window
Bien souvent, surtout quand vous peignez, vous souhaiterez élargir cette fenêtre en plein écran, pour voir et travailler les détails. Vous pouvez aussi user (de) la molette de votre souris…
View All
Ajuste la vue pour que toute l'image et les UVs tiennent dans celle-ci. Parfois les UVs peuvent s'en aller errer dans la nature, et ceci vous aide à les retrouver et les ramener dans la zone de l'image.
View Selected
Centre la vue sur les faces UV sélectionnées.
Update Automatically
Lorsque vous déplacez les UVs, les modifications du plaquage de texture sur le mesh (visible dans les vues 3D) sont reflétées en temps réel. Sinon, les mises à jour sont effectuées quand vous relâchez les UVs. Activez cette option si vous avez un CPU puissant.
View Navigation
Raccourcis pour (dé)zoomer l'affichage; équivalent à l'utilisation de Wheel Template-MW.png. Notez aussi que la vue de la fenêtre peut être déplacée avec ⇧ ShiftMMB Template-MMB.png. Il n'y a pas de rotation de la vue, ou de "vue utilisateur", puisque nous travaillons dans un espace 2D.
Draw Shadow Mesh
Contrôle s'il faut ou non dessiner un contour de toute la disposition UV, pour l'alignement de la peinture en arrière plan (NdT: version peu sûre de "Toggles whether to draw an outline of the whole UV Layout for background painting alignment."). Très pratique.
Draw Faces
Si activé, dessine les faces sélectionnées sur l'image.
Display Normalized Coordinates
Affiche les coordonnées UV dans le panneau Properties, normalisées à 1.0. Par exemple, une coordonnée UV avec x = 64 sur une grille (image) de 256 pixels de côtés donnerait une valeur normalisée de 0.25.
Composite Preview
Un work in progress
Curves Tool
Affiche le contrôle des courbes de couleurs Combinée (= luminosité), Rouge, Vert et Bleu (CRGB). Sélectionnez un canal (C, R, G ou B) et ajustez la courbe pour contrôler les couleurs de l'image.
Paint Tool
Affiche les outils de peinture de texture.
Propriétés UV.
Real-Time Properties
Affiche une fenêtre flottante qui vous permet de régler les infos Animation et Tile utilisées par le Game Engine (moteur de jeu de Blender).
  • Anim et Tiles– Voyez Utiliser des Images comme textures UV;
  • UV Vertex – Normalement, les informations de vertex UV sont en pixels, et l'espace de travail noir par défaut fait 256×256; avec une image chargée, cet affichage vous montre les coordonnées UV en pixels, en fonction de la taille réelle de l'image. Avec l'option Display Normalized Coordinates activée, les positions de vertex sont ramenées dans l'intervalle 0.01.0. L'origine est le coin inférieur gauche de l'espace de travail noir. Vous pouvez cliquer dans le champ X ou Y et y rentrer manuellement une position pour un seul UV, ou un point médian pour un ensemble d'UVs, ou utiliser les flèches pour modifier leur position par incréments.
Properties
Beaucoup de sources peuvent être utilisées pour la partie image d'une texture UV. Ce panneau vous montre ce que vous utilisez, et vous donne des contrôles de base pour sélectionner, recharger, (dés)activer l'entrelacement vidéo (paire ou impaire), et pour activer l'anti-aliasing sur l'image pour l'adoucir.


Menu "Select"

Ce menu vous aide à sélectionner les UVs sur lesquels travailler:

Linked UVs (CtrlL)
Cette entrée du menu sélectionne tous les UVs qui font partie de la même carte UV. Rappelez-vous qu'une carte est créée pour chaque sous-mesh et zone déterminée par les coutures, de manière analogue à une pièce de tissu d'un vêtement. Sélectionner Linked UVs fonctionne de manière similaire à cette même commande dans la vue 3D: elle sélectionnera tous les UVs qui sont liés ("linked") à ceux sélectionnés au départ.
Pinned UVs (⇧ ShiftP)
Vous pouvez "bloquer" ("to pin") des UVs, de manière qu'ils ne soient pas modifiés (déplacés) par les opérations de dépliage suivantes. Cette option sélectionne tous ceux qui sont dans cet état.
Unlink Selection (AltL)
Sépare les UVs sélectionnés de la carte. Seuls ceux appartenant à des faces totalement sélectionnées restent sélectionnés après cette commande. Comme son nom l'indique, elle est particulièrement utile pour "délier" ("to unlink") des faces et les déplacer ailleurs. Elle est analogue à la commande Separate du mode Edit.
Select/Deselect All (A)
(Dé)sélectionne toutes les coordonnées UV. Après le dépliage initial, vous voudrez sélectionner tous les UVs pour les faire tourner, les mettre à l'échelle, les déplacer, …
Border Select Pinned (⇧ ShiftB)
Utilisez la boîte pour sélectionner les UVs bloqués (pinned).
Border Select (B)
Utilisez la boîte pour sélectionner les UVs normaux.
Active Face Select
Si activé, quand vous cliquez RMB Template-RMB.png sur une "face" d'une carte UV, la face correspondante du mesh est surlignée dans la vue 3D. Utilisez cela pour avoir une bonne vue de comment le dépliage initial correspond à votre "monde réel", et pour vous aider à ré-arranger correctement les cartes UV en une disposition cohérente. De plus, (suivez-moi bien) les trois ou quatre UVs correspondant à cette face sont sélectionnés. Très pratique pour faire tourner/déplacer une face UV entière, au lieu d'UVs individuels.


Menu "Image"

Je sais, je sais, vous êtes impatient de commencer à peindre. Voyez la page suivante pour l'aide sur ce menu.

Menu "UVs"

Voila un menu suffisamment long pour se retrouver parfois en partie caché! En voici les options concernant la disposition UV, par ordre d'apparition:

Scripts
Affiche la liste des scripts Python que vous avez installés sur votre PC, qui font des choses très pratiques avec les textures UV:
  • Auto Image Layout: Si vous avez une texture UV pour une partie de votre mesh, et une autre texture UV différente (carte et image) pour une autre partie, utilisez ce script pour les relier ensemble.
  • Save UV Face Layout: Pour enregistrer une image de votre dépliage UV (lignes grises); génial comme calque-guide quand vous utilisez un programme de dessin externe. Activez l'option SVG pour produire une image vectorielle.
  • Texture Baker et UV Painter sont décrits plus loin dans ce chapitre.
Show/Hide Faces
Afficher/cacher les faces sélectionnées. Fonctionne de la même manière que pour les meshes dans les vues 3D, vous permettant de ne vous concentrer que sur certaines parties du dépliage.
Proportional Falloff et Proportional Editing
Comme avec un mesh, et tout particulièrement utile car vous travaillez souvent au milieu de beaucoup de vertices dans un espace réduit. Raccourci: O. Wheel Template-MW.png pour modifier la taille du cercle d'influence, exactement comme lors de l'édition d'un mesh.
Weld/Align
Quand vous avez fait une couture, puis avez déplié votre mesh, celui-ci a été découpé au niveau de cette couture en deux morceaux. Là où ils ont été séparés, il y a maintenant deux vertices UV pour chaque vertice du mesh: un à un coin ou sur un côté de chacune des deux cartes UV. Pour remplir l'espace entre les différentes "pièces", et faire une seule carte continue, vous pouvez les re-souder ("to weld") ensemble. Sélectionnez deux vertices puis soudez-les (Weld, W). Alignez les vertices UV sélectionnés (W), soit dans la direction X, soit dans la direction Y, pour que les vertices similaires se rapprochent. Le point de soudure est à mi-distance entre les deux vertices.
Mirror
Parfois, une carte UV sera inversée par rapport à votre point de vue. Cette option du menu retourne la carte comme une crêpe, soit dans la direction X, soit dans la direction Y.
Transform
Pour déplacer (Grab), mettre à l'échelle (Scale) et faire tourner (Rotate) les vertices sélectionnés. Indispensable, et fonctionne exactement comme avec les meshes.
Stitch et Limit Stitch
Assez proche de l'option Remove Duplicates des meshes, cette fonction soude ensemble les vertices UV qui sont suffisamment proches les uns des autres. Non pas proches au sens de fer-à-cheval et grenade à main (NdT: ??? expression anglaise?: "Not close as in horseshoes and hand grenades"), mais proches comme défini par Limit:. Différentes parties d'une carte UV peuvent être "cousues" ("stitched") si les vertices UV du bord correspondent aux mêmes vertices du mesh, par la commande Stitch. Cette commande fonctionne en joignant les bords irréguliers. Sélectionnez simplement les vertices sur ces bords – si vous utilisez Stick UVs to Mesh Vertex, les coordonnées UVs correspondantes seront aussi sélectionnées sur l'autre carte UV. Stitch (V) recoud les vertices quelle que soit la distance qui les sépare, alors que Limit Stitch (⇧ ShiftV) ne soude que les vertices qui sont plus proches que la valeur de Limit:, par défaut, 20 pixels. L'avantage de ces options sur Weld est qu'elles évitent de souder ensemble des coordonnées UV ne correspondant au même vertex du mesh.
Minimize Stretch
Très souvent, le dépliage initial aura des concentrations de vertices, séparées par des no man's land fort peu "peuplés". Comme si vous lissiez un papier froissé, cette commande très pratique disperse les concentrations de vertices sélectionnés. Une grande face, à l'un des angles de la projection, donnera une petite surface UV. Donc, n'importe quelle image apparaîtra étirée, comme une peinture sur un ballon. Utilisez cette option pour diminuer quelque peu cet étirement.
Pin et Unpin
Utiliser la commande Pin (P) sur les vertices sélectionnés les force à rester inchangés, immobiles, durant les opérations de dépliage suivantes, "épinglés" ("pinned") à leur position actuelle. Ils apparaissent rouges et plus grands que les autres coordonnées UV, comme des punaises. Unpin (AltP) les libère. Pour plus détails, voyez le paragraphe Utiliser la commande "Pin".
Layout Clipped to Image Size
Garder les UVs dans un "enclos" de la taille de l'Image. Vous empêche de déplacer un UV hors de la zone image.
Quads Constrained Regular
Trop "geek" pour moi. Désolé. Vraiment, ces trois mots ne s'assemblent tout simplement d'aucune manière compréhensible à mon pauvre petit cerveau :) (NdT: je traduirais en fait "Quads Constrained Regular" par "(les) Quadrangles (sont) contraints (à être) réguliers"…). Si activée, quand vous déplacez une coordonnée UV, cette option essaye de vous aider à faire de la face UV correspondante un "quadrangle régulier", c-à-d un rectangle ou un carré. Utilisez-la quand vous texturez une image orthogonale vers un mesh "du monde réel". Attention: elle délie automatiquement cette face UV de ses voisines si elles ne sont pas également "alignées".
Snap to Pixels
Placée ici par les développeurs pour le perfectionniste qui dort en chacun de nous, cette option force les pixels déplacés à se positionner exactement sur un pixel, de façon que les UVs s'alignent parfaitement avec l'image. Exactement. Précisément. PAS 0.126 ou 0.436 ou n'importe quel autre truc dans ce genre. Unités entières bien propres. Vous allez aimer.


Itération et raffinement

Au moins pour la plupart d'entre nous, nous ne "réussissons pas du premier coup". Il nous faut construire sur une idée, et répéter notre processus de création, jusqu'à ce que nous atteignions cette étape magique appelée "Fini". En développement de programme, c'est appelé la "méthode spirale" ("Spiral Methodology"). Appliquée au graphisme par ordinateur, nous bouclons entre modelage, "texturage", animation, puis retour à des modifications du mesh, re-dépliage UV, réglage de l'animation, ajout d'un os (bone) ou deux, besoin de quelques faces supplémentaires, donc retour au modelage, etc. Nous cerclons de cette manière jusqu'à ce que nous manquions de temps, d'argent ou de patience, ou, dans quelques rares cas, soyons réellement content de nos résultats.

Utilisation maximale de l'espace pour les zones détaillées.Utilisation de Stitch, Align, Minimize Stretch, et Scale.

Ce serait maintenant le bon moment pour enregistrer une image de votre dépliage UV (plugin Save UV Face Layout). N'ayez pas peur d'essayer différents algorithmes de dépliage UV sur le même ensemble de faces pour en trouver un qui vous semble bon et ne vous demande pas trop de travail d'arrangement supplémentaire.

Compromis

Par exemple, considérez la création d'un personnage de jeu vidéo. Nous le voulons d'aspect réaliste. Le réalisme de l'apparence d'un personnage de jeu vidéo vient de deux choses: la forme et la texture. En ce qui concerne la forme, nous voulons que notre modèle soit bien proportionné et "lisse", pas trop "anguleux". Mais plus nous le lissons et lui ajoutons des détails, plus nous avons de polygones (de faces). C'est une mauvaise chose, car cela ralentit le jeu en consommant trop de ressources matérielles (carte vidéo, mémoire, …). La texture ajoute des couleurs réalistes à la surface, mais de nouveau, des images plus détaillées signifient plus de pixels et donc plus de ressources matérielles. Il y a donc un équilibre à trouver entre nombre de faces et taille des textures d'une part, et réalisme acceptable et game play d'autre part. Les premiers jeux vidéo, par exemple, avaient en guise de tête humaine un cube des plus anguleux avec une texture de visage… disons simplement que votre imagination était fortement sollicitée. Mais ils atteignaient un certain niveau de réalisme et avaient un game play réactif sur les ordinateurs de cette époque.

Image-UV-tr3.jpg

Plus tard, les premiers jeux PC "Tomb Raider" de Eidos furent (à mon humble avis) un excellent exemple de personnage des plus "en formes", réalisé avec aussi peu de polygones que possible, et de petites mais créatives images qui simulaient les ombres et les plis. Le game play était rapide, réactif, et on pouvait bien faire abstraction de quelques angles un peu agressifs.

Utiliser la commande "Pin"

Développer un personnage de jeu vidéo est donc un processus de création itératif. Nous le modelons, le déplions, commençons à créer une image pour lui, et réalisons que nous avons trop de faces. Nous en réduisons donc le nombre, re-déplions, et reprenons notre peinture.

C'est ici que la commande Pin intervient. La première fois que nous déplions et commençons à peindre notre image, (par exemple les vêtements), nous voulons préserver ce travail. Quand nous déplions pour la deuxième fois, nous ne voulons pas que les UVs de la poitrine soient dépliés ailleurs dans l'image: nous voulons qu'ils restent où ils sont, juste sur le dessin du t-shirt. Donc, avant de déplier pour la deuxième fois, nous les épinglons ("to pin"), puis modifions notre mesh avant de le re-déplier. Nos coordonnées UV épinglées resteront là où elles sont, peu importe l'algorithme de dépliage utilisé, ou les modifications des coutures.

L'autre usage de la commande Pin est une sorte d'annulation (d'undo). Imaginez qu'en éditant la carte UV, vous vous rendiez compte que vous avez la veille accidentellement soudé (Weld) cinq coordonnées UV. Une annulation n'est donc plus possible, et vous ne voulez pas revenir à une ancienne copie de sauvegarde (si tant est que vous en ayez une!). Ne vous sentez pas stupide; l'auteur a fait la même chose en générant ces exemples. Donc, vous épinglez toutes les coordonnées UV sauf celles qui sont soudées, re-dépliez, et ces UVs seront "restaurés".

Raffiner le dépliage

Le raffinement entre en jeu quand nous regardons finalement notre personnage, et réalisons que nous avons besoin de détails supplémentaires à certains endroits. Par exemple, les coins des yeux pourraient avoir besoin de pattes d'oie, ou il nous faudrait ajouter un logo sur le t-shirt… Alors que vous commencez à éditer l'image en conséquence, vous réalisez qu'il n'y a tout simplement pas assez de pixels disponibles pour peindre les détails que vous souhaitez. Votre seule solution est d'agrandir la face UV correspondante. Vous réalisez cela en utilisant les commandes Minimize Stretch ou Scale, allouant ainsi plus d'espace (de pixels) aux coins de vos yeux, ou à la "poitrine" du t-shirt, mais "spoliant" par là même d'autres zones, comme l'arrière de la tête. Après le raffinement de votre carte UV, vous pouvez modifier votre image (vous devrez probablement l'adapter au nouveau dépliage UV!), et lui ajouter les détails voulus.

Réutiliser des textures

Un autre point à considérer est la réutilisation. Chaque fichier image est chargé en mémoire. Si vous pouvez réutiliser la même image dans différents meshes, cela économise de la mémoire. Donc, par exemple, vous pourriez souhaiter avoir une peinture générique "visage", et l'utiliser sur différents personnages, en modifiant le dépliage UV, la forme du mesh et les accessoires (lunettes de soleil, …) pour les différencier. Vous pourriez aussi avoir une texture "jeans délavé", et la plaquer sur les jambes de vos personnages. Il serait aussi bon d'avoir une image "peau" générique, à utiliser pour les mains, pieds, bras, jambes, cou… de vos personnages. Quand vous modelez une épée de fantasy, une petite image d'une "tranche de lame" serait suffisante pour texturer toute votre lame, en sélectionnant les faces de celle-ci, puis dépliage Reset: cette image sera alors "étendue", réutilisée, sur toute la longueur de votre lame.