From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.
Utilisation de "frame"
Pour éviter la confusion entre "image" en tant que photo, dessin, cliché, etc. et "image" en tant qu'élément de base d'une animation, on utilisera souvent "frame" pour le second et "image" pour le premier dans ce chapitre.


Le Video Sequence Editor (VSE, ~= "monteur vidéo") de Blender est un banc de montage vidéo flexible. Il est utile pour revoir/contrôler vos plans, et les assembler en un film. Il offre de plus plusieurs effets (transitions et autres), soit intégrés, soit sous forme de plugins, qui vous permettent de produire des vidéos au look "professionnel".

Vue d'ensemble de la fenêtre VSE

La fenêtre VSE en mode d'affichage Sequence.

La fenêtre VSE a un en-tête (où sont affichés les menus et le sélecteur de modes) et un espace de travail, et peut fonctionner dans quatre modes. En mode Sequence, l'espace de travail est composé de pistes horizontales, dans lesquelles vous placez vos plans, effets, …, et numérotées à partir de 0 (première piste en bas, réservée), sur la gauche. La figure ci-contre montre trois pistes (zéro à deux); les pistes d'en bas ont une "priorité" supérieure à celles d'au-dessus, nous y reviendrons. Sur l'axe horizontal, les secondes ou les frames (T pour choisir) de l'animation affichées vous permettent de vous repérer dans le temps (ici, les secondes 1 à 7 sont visibles). Vous pouvez modifier l'échelle temporelle comme dans les autres fenêtres de Blender (touches de zoom, molette de la souris, …).

Activer la sortie de la fenêtre VSE.

Lorsque vous cliquez sur RENDER ou sur ANIM pour générer une image ou une vidéo, Blender a le choix des sources pour la produire:

  • Utiliser les calques actifs de la scène courante (comportement par défaut);
  • Utiliser le résultat du VSE (canal 0);
  • Utiliser la sortie Composite de la fenêtre Node Editor, mode Composite Nodes.

Indiquez à Blender d'utiliser le résultat du VSE en activant le bouton Do Sequence, juste sous le bouton ANIM (fenêtre Buttons, contexte Scene, boutons Render, onglet Anim).

Menu "View"

Comme d'habitude, ce menu contrôle ce que vous voyez, et comment vous le voyez, dans l'espace de travail.

Mode: Sequence

Raccourci clavier: ⇧ ShiftSpace, Ctrl, Ctrl

Menu: ViewMaximize Window

Utilisez cette option quand vous voulez travailler sur beaucoup de pistes, et que vous avez besoin de tout votre écran pour cela.

Mode: Sequence

Raccourci clavier: T

Menu: ViewShow Frames, ViewShow Seconds

Bascule entre les deux représentations du Temps (secondes et images, ou frames), en bas de l'espace de travail. Les secondes dépendent du réglage du framerate (nombre d'images par seconde), dans l'onglet Format du sous-contexte Scene.

Mode: Sequence

Menu: ViewLock Time to Other Windows

Verrouiller le temps aux autres fenêtres ("to lock time to other windows") signifie que si vous modifiez votre position dans le temps (en cliquant LMB Template-LMB.png dans l'espace de travail pour déplacer le curseur vidéo – ligne verte verticale), les autres fenêtres se rafraîchiront en conséquence.

Mode: Sequence

Raccourci clavier: . NumPad

Menu: ViewView Selected

Ajuste la vue pour afficher juste la(les) bande(s) sélectionnée(s).

Mode: Sequence

Raccourci clavier: ↖ Home

Menu: ViewView All

Ajuste la vue pour afficher toutes les bandes présentes.

Mode: Sequence, Image, Chroma, Luma

Raccourci clavier: ⇧ ShiftAltA

Menu: ViewPlay Back Animation in 3D View

Joue l'animation dans l'intervalle d'images sélectionné, dans toutes les fenêtres: dans les fenêtres VSE, dans les différents modes (Image, Chroma, Luma); dans les fenêtres 3D, les objets en mouvements; …

Mode: Sequence, Image, Chroma, Luma

Raccourci clavier: AltA

Menu: ViewPlay Back Animation

Joue l'animation dans l'intervalle d'images sélectionné, uniquement dans la fenêtre active.

Menu "Select"

Ce menu vous aide à sélectionner les plans.

Mode: Sequence

Raccourci clavier: A

Menu: SelectSelect/Deselect All

(Dé)sélectionne tous les plans présents.

Mode: Sequence

Raccourci clavier: B

Menu: SelectBorder Select

Initie une sélection par Boîte. Cliquez-tirez une boîte rectangulaire autour des plans que vous voulez sélectionner. Quand vous relâchez le bouton de la souris, ces plans sont ajoutés à la sélection courante.

Menu "Add"

Mode: Sequence

Raccourci clavier: Space

Menu: Add

C'est le menu que vous utiliserez le plus. En général, vous chargez vos plans, créez des "plans" d'effets spéciaux (transitions, …), puis rendez votre montage en activant Do Sequence et cliquant sur ANIM. Vous pouvez utiliser ce menu soit depuis l'en-tête, soit dans l'espace de travail au niveau de votre curseur, en faisant Space.

Les plans peuvent être très lourds
Un fichier vidéo quicktime (.mov) de trois minutes peut peser 140 Mo. Le charger, même à travers un réseau haute vitesse (gigabit LAN, par ex.), peut prendre du temps. Ne vous affolez donc pas si Blender ou votre système semblent se figer pendant un moment.


"Add Movie", "Add Images"

Ajouter des vidéos et des images (fixes ou séquences).

Commençons par ajouter un élément:

  • Un plan vidéo en format "Audio-Video Interlaced" (fichier *.avi);
  • Un plan vidéo en format "Apple QuickTime" (fichier *.mov);
  • Une seule image fixe, répétée un certains nombre de fois (*.jpg, *.png, …);
  • Une séquence d'images numérotées (*-0001.jpg, *-0002.jpg, *-0003.jpg, etc. – quel que soit le format!);
  • Une ou plusieurs images d'un même dossier;
  • Une scène dans votre fichier *.blend.

Blender gère indifféremment tous ces types de plans: vous pouvez les mélanger à votre guise. Ces éléments sont représentés par des bandes de différentes couleurs dans le VSE:

  • Bleu pour des fichiers vidéo (AVI/mov);
  • Gris pour les images fixes;
  • Mauve pour les séquences d'images;
  • Vert pour les éléments audio.

Lorsque vous ajoutez un élément de ces types, la fenêtre VSE passe en mode navigateur de fichier pour vous permettre de sélectionner ce que vous voulez ajouter. Les fichiers (a priori) supportés sont signalés par un petit carré de couleur (bleu pour les images fixes, vert pour les vidéos – sic!), une indication que vous pourrez les charger avec succès:

  • Si vous ajoutez une vidéo (ou vidéo + audio) ou une seule image:
cliquez LMB Template-LMB.png sur le fichier à importer pour placer son nom dans le champ texte en haut; cela ne sélectionne qu'un seul fichier;
  • Si vous ajoutez une séquence d'images fixes, vous pouvez au choix utiliser les modes:
    • Directory: cliquez RMB Template-RMB.png sur un dossier, et tous les fichiers dans ce répertoire seront importés comme faisant partie d'une séquence animée, triés dans l'ordre;
    • Range: cliquez-tirez RMB Template-RMB.png pour sélectionner un ensemble de fichiers contigus (vous pouvez appuyez sur PageUp/PageDown pendant la sélection, pour étendre celle-ci);
    • Batch: cliquez ⇧ ShiftRMB Template-RMB.png pour sélectionner les unes après les autres vos images: elles seront importées pour former une séquence animée, et peuvent être de différents types (jpg, png, exr, …);
    • All: tapez A pour (dé)sélectionner tous les fichiers du dossier.

Quand vous cliquez sur Select (Images/Video/…), la fenêtre redevient un VSE, et le ou les élément(s) sélectionné(s) apparaissent sous la forme d'une bande accrochée au curseur de la souris. Vous ne pouvez pas charger plusieurs vidéos d'un coup en cliquant RMB Template-RMB.png sur leurs fichiers respectifs: cela ne fonctionne que pour charger des séquences d'images fixes.

Message Error
Le message ERROR: The selected file is not a movie or FFMPEG support not compiled in! signifie que le fichier sélectionné n'est pas dans un format reconnu par Blender, ou que vous l'avez sélectionné avec le mauvais bouton de la souris: RMB Template-RMB.png au lieu de LMB Template-LMB.png sur un fichier vidéo, par exemple. Sinon, c'est que vous ne disposez pas du codec nécessaire au décodage du fichier vidéo: trouvez-en un qui vous permette de lire ce fichier dans un player hors de Blender, vous pourrez ensuite l'y charger.


Pour résumer, pour ajouter des "images" dans un VSE, cliquez LMB Template-LMB.png pour un fichier vidéo, LMB Template-LMB.png pour une image fixe unique, et cliquez-tirez RMB Template-RMB.png pour une séquence d'images. Déplacez le curseur de votre souris sur la piste et à l'image (ou à la seconde) où vous voulez placer ce nouvel élément, puis cliquez LMB Template-LMB.png pour le "relâcher".

Quand vous ajoutez une image fixe unique, Blender lui donne une longueur de 50 images, soit une durée de deux secondes (en PAL – 25 fps). En plus de la repositionner, vous voudrez sûrement la redimensionner, en cliquant-tirant RMB Template-RMB.png sur l'une des extrémités de la bande (sur les flèches). En déplaçant ensuite votre souris, vous modifiez la longueur du plan (elle est donnée en images en permanence), jusqu'à ce que vous cliquiez LMB Template-LMB.png pour valider (RMB Template-RMB.png pour annuler).

Blender3D FreeTip.gif
Utiliser plusieurs résolutions
Gérer des images et des productions de définitions (tailles) différentes peut se révéler délicat. Mettez-vous à la place d'un pixel (?). Si vous avez une différence de taille entre une image d'entrée et la résolution du rendu de sortie, le VSE essaye effectivement de modifier automatiquement l'image d'entrée pour la faire tenir complètement dans la sortie. Si vous ne voulez pas de ça, utilisez Crop ("recadrer") et/ou Translate ("déplacer"), dans le panneau Input, pour sélectionner une région de votre image et/ou la déplacer dans la sortie. Quand Crop ou Translate sont activés, la mise à l'échelle automatique est désactivée, et vous pouvez la faire manuellement en ajoutant un effet Transform.


Manual-VSE-sample.png

Si vous déplacer l'espace de travail vers le haut, vous remarquerez une piste spéciale (piste/canal 0) qui vous donne des informations sur l'élément actif. L'exemple ci-dessus montre un élément "couleur", puis un fichier *.mov, et une image fixe. La piste d'information est utile pour, par exemple, donner le nom de l'image fixe, qui est "mangé" par les bords de la bande correspondante.

Passer les 9999 images (9999 frames go by)
OK, c'est une obscure référence à une chanson à propos de 99 ballons, mais nous n'avons vraiment pas anticipé la rapidité avec laquelle Blender est devenu un outil de montage vidéo. Malheureusement, nous n'avons au départ réservé que quatre chiffres dans les noms de fichier des séquences d'images animées. Même si cela fait dans les 5 min 30 en NTSC (6 min 40 en PAL), avec Blender qui s'introduit dans le montage vidéo, cela peut ne plus être suffisant: vous devrez alors manuellement gérer le 5eme (6eme, …) chiffre des noms de fichier (par ex., rendre de 0000 à 9999, puis de 10000 à 19999, en ajoutant le "1" manuellement au nom de fichier, etc.).


Codecs
Vous devez avoir installé sur votre machine les codecs nécessaires au décodage des fichiers vidéo. Blender ne contrôle pas cela. Par exemple, le codec "XVid" est disponible sur le site de XVid.


Support FFMPEG
Si vous utilisez une version de Blender avec le support FFMPEG, vous pourrez charger à la fois l'audio et la vidéo d'un fichier en sélectionnant Movie+Audio(HD): lorsque vous lâcherez l'élément dans l'espace de travail, il se divisera en deux éléments: un pour l'audio, un pour la vidéo.


"Add Scene"

Vous pouvez ajouter les images "virtuelles" de la sortie d'une scène de votre fichier .blend courant. Sélectionnez-la dans le menu pop-up, et une bande sera ajoutée à l'espace de travail, exactement comme avec une vidéo ou une image. La longueur de cet élément sera déterminée par les réglages de l'animation de la scène chargée (pas de la scène courante, à moins qu'elles ne fassent qu'une!).

Quand vous ajoutez ainsi une scène, vous devez comprendre que, pour pouvoir afficher la prévisualisation, Blender doit la rendre. Cela peut prendre du temps si la scène est complexe, il peut donc y avoir un certain laps de temps entre le moment ou vous sélectionnez votre scène, et celui ou la bande correspondante apparaît. Pour réduire ce délai, simplifiez votre scène (ou réduisez la qualité du rendu pendant les prévisualisations).

"Add Audio"

Le VSE peut importer de l'audio, que vous pourrez entendre pendant le montage.

Ajoutez une piste audio quand vous devez synchroniser vidéo et son. Voyez la page sur les pistes Audio pour plus d'informations.

"Add Effect"

Effets internes disponibles.

Blender fournit deux catégories d'effets: ceux inclus dans le programme (Built-in), et ceux disponibles en plugins (Plug-in). Les premiers sont listés ci-contre, tout le monde les a. Les plugins sont des fichiers séparés, situés dans un répertoire "sequence-plugin" de votre PC, qui sont chargés à la demande. Bien qu'un ensemble de plugins standards soit installé en même temps que Blender, chaque système peut en avoir un ensemble différent.

Mode: Sequence

Raccourci clavier: Space

Menu: AddEffect

Les effets inclus sont expliqués en détail plus loin, mais ils sont tous ajoutés et contrôlés de la même manière. Pour ajouter une bande effet, sélectionnez un élément de base (image, vidéo, scène) en cliquant RMB Template-RMB.png dessus. Pour certains effets, comme le fondu enchaîné (Cross), vous devrez sélectionner (⇧ ShiftRMB Template-RMB.png) un autre élément – cela dépend de l'effet choisi. Puis faites AddEffect et sélectionnez l'effet voulu dans le menu pop-up. Cela fait, la bande d'effet sera placée au-dessus de la(des) bande(s) source. S'il s'agit d'un effet indépendant, comme le générateur de couleur (décrit plus loin), la bande sera accrochée au pointeur de la souris, cliquez LMB Template-LMB.png pour la relâcher.

Puisque la plupart des bandes d'effet sont liées à une ou deux bandes source, l'emplacement et la durée des premières dépendent des secondes. En conséquence, vous ne pourrez souvent pas déplacer une bande d'effet: vous devrez déplacer sa(ses) bande(s) source à la place.

Pour utiliser un effet qui combine ou fait une transition entre deux éléments, vous devez d'abord sélectionner ceux-ci (sélection par Boîte ou clics ⇧ ShiftRMB Template-RMB.png). La bande d'effet sera alors ajoutée au-dessus de la (des deux) bande(s) source, en mode Grab ("déplacement") (cliquez LMB Template-LMB.png pour la lâcher). Sa durée (librement modifiable) maximale sera représentée par le recouvrement entre les bandes sources – ou la durée de la bande source!

Avec certains effets, comme l'AlphaOver, l'ordre dans lequel vous sélectionnez les bandes source est important. Vous pouvez également utiliser comme source un effet déjà présent, additionnant ainsi les effets.

Effet "Color Generator"
La seule exception est l'effet Color Generator: il ne dépend d'aucune bande source, vous pouvez l'ajouter, le déplacer, modifier sa durée comme avec n'importe quel autre élément "normal".


Mode: Sequence, Bande d'effet sélectionnée

Raccourci clavier: C

Menu: StripChange Effect

Si vous n'avez pas choisi le bon effet dans le menu, vous pouvez toujours le modifier en sélectionnant la bande (RMB Template-RMB.png) et en faisant StripChange Effect…, ou en tapant C (pour "Changer"), pour modifier l'effet de la bande sélectionnée.

"Add Effect" → "Plugin"

Manual-VSE-Plugins.png

Les plugins de séquence sont des petits programmes spécialisés écrits en C, en tant que bibliothèque dynamique (*.dll, pour "dynamic load library" – "bibliothèque chargée dynamiquement", sous Windows™, *.so, pour "shared object" – "objet partagé", sous Macintosh™ et GNU/LinuxGPL, etc.). Ils ne sont chargés (en mémoire) qu'au moment de leur utilisation (chargement dynamique), et se "branchent" ("to plug in") alors sur Blender.

L'image ci-contre montre les plugins de séquence disponibles sur mon système. Chacun d'entre eux fait quelque chose de spécial, indiqué par leur nom et/ou décrit sur la page des plugins de Blender (en anglais) et/ou sur le site web du plugin. Par exemple, le plugin Iris fait une transition entre deux éléments en ouvrant un trou au milieu du premier et faisant apparaître le second à travers, comme si l'iris (diaphragme) d'une caméra était en train de s'ouvrir. Certains de ces plugins peuvent être vieux de plus de cinq ans et toujours fonctionner parfaitement; Blender essaye d'assurer la compatibilité arrière, et ils devraient fonctionner indépendamment du format de sortie ou de la résolution.

Animer les effets audio/vidéo

Animer l'effet Add.

La "quantité" d'effet appliqué à l'image (appelée "Facteur", ou "Factor" en anglais) peut être modifiée dans le temps. Par exemple, sur 100 images, vous pouvez faire varier le facteur de 0.0 à 1.0, puis retour à 0.5, avant de remonter à 1.0. Vous faites cela en créant une courbe Ipo pour cet effet. Certains effets (Add, Multiply) peuvent être animés par ces courbes Ipo; d'autres (Color Generator, Glow) ne sont contrôlés que par leur panneau de propriétés (N).

Vous avez ci-contre un exemple d'animation de l'effet Add pour créer un effet d'éclairage stroboscopique. Pour ajouter des points de contrôle dans le fenêtre Ipo, cliquez CtrlLMB Template-LMB.png là où vous voulez les placer, et une courbe Facteur sera créée. Ici, nous ajoutons du gris (élément Color) à notre image avec une Ipo en zig-zag. Quand vous lirez (ou si vous avez déjà lu) ce qui concerne les nœuds de compositing, ce Factor est aussi présent dans beaucoup de ceux-ci, spécialement le nœud Mix. Par défaut, quand vous ajoutez un effet comme le fondu enchaîné, Cross, Blender crée une transition en douceur vers la deuxième image, de 0.0 à 1.0, sur la durée de l'effet (longueur de sa bande). Dans le cas d'un effet Add, Multiply, Substract, Blender ajoute l'effet avec une action maximale dès le départ, et sur toute sa durée: le facteur est à 1.0 tout le temps. Mais nous savons combien vous aimez tout contrôler, donc vous avez la fenêtre Ipo, qui opère sur les bandes. Voilà pourquoi il y en a une dans le coin supérieur gauche de la disposition d'écran.

En général, vous:

  • Sélectionnez la bande d'effet;
  • Décidez si vous voulez que la courbe Ipo soit relative au début de la première bande source, ou bloquée sur le timing global (activez alors le bouton IPO Frame locked);
  • Cliquez CtrlLMB Template-LMB.png pour placer les points de contrôle dans le fenêtre Ipo (en mode Sequence) et ainsi définir les variations du facteur dans le temps. Pour faire une transition douce vers la fin de l'effet, définissez simplement un point au début à 0.0, et un à la fin à 1.0. Une courbe en dents de scie donnera quelque chose de très dynamique et/ou désordonné.

Tous les effets ne peuvent pas être animés de la sorte: l'effet Glow est statique, mais il existe un plugin AnimGlow animable. Les effets Add, Multiply, Divide, Substract, et Transform sont toujours animables.

Animer une bande audio modifie son volume dans le montage final. Utilisez une animation Ipo sur une piste audio pour faire des fondus en ouverture/fermeture sur une musique d'ambiance, ou pour ajuster les niveaux. Les bandes audio superposées sont mélangées, l'une ne "coupe" pas l'autre. Cela fait de Blender un mixeur audio. En ajoutant des pistes audio et en utilisant les courbes Ipo pour ajuster leurs niveaux respectifs, vous avez un montage audio multi-pistes!

Pour raccourcir les effets de transitions (qui opèrent sur deux bandes source), il suffit de raccourcir le recouvrement des deux bandes sources (pas besoin de toucher aux Ipo!).

Si Ipo Frame locked est activé, Blender utilisera la valeur de Fac de la framex dans le fenêtre Ipo pour l'appliquer à la framex dans la fenêtre VSE. S'il est désactivé, la frame1 dans la fenêtre Ipo correspond à la première image de la première bande source. En général, vous voudrez que vos effets soient relatifs aux bandes sur lesquelles ils opèrent, mais dans certains cas, vous les voudrez en position absolue.

Menu "Strip"

Ce menu vous permet de travailler sur les bandes.

Mode: Sequence

Raccourci clavier: M, AltM

Menu: StripMake Meta Strip, StripSeparate Meta Strip

Une "méta-bande" est un groupe de bandes. Sélectionnez toutes les bandes que vous voulez grouper, et faites-en une Méta-bande. La méta-bande commence au début du premier élément inclus, et finit à la fin du dernier, et réunit toutes les bandes en une seule, un peu comme un "mixdown" en montage audio. Séparer une méta-bande restaure les bandes contenues dans leur état initial (position et piste).

Mode: Sequence

Raccourci clavier: X, ⇧ ShiftD

Menu: StripDelete, StripDuplicate

Si vous avez ajouté un élément par erreur, ou n'en voulez plus, sélectionnez-le puis supprimez-le en tapant X (ou option Delete du menu). Dupliquer une bande en fait une copie non-liée: comme à l'ajout d'une bande, placez-la où vous voulez, puis cliquez LMB Template-LMB.png pour la lâcher.

Mode: Sequence

Raccourci clavier: K

Menu: StripCut at Curent Frame

Alors que réunir deux bandes se fait juste en les plaçant l'une après l'autre, tapez K pour couper en deux la bande sélectionnée, à la position courante du curseur (C était déjà utilisé par la commande Change, voyez plus haut).

Note sur le "Cut"
Lorsque vous faites un "cut" dans un élément, vous ne réalisez pas réellement une coupure au sens propre du montage "à l'ancienne" (où la pellicule était vraiment coupée… au cutter!). En fait, vous faites une copie de la bande: la fin de l'original est "enroulée" jusqu'au "cut", de même que le début de la copie.

Par exemple, imaginons que vous ayez une piste qui contient 50 images et que vous vouliez en supprimer les 10 premières. Vous vous placez alors sur la 11eme image, et vous tapez K; la coupure "divise" votre piste en deux parties. Vous sélectionnez (clic RMB Template-RMB.png) le premier petit bout de piste, qui contient les frames 1 à 10, et vous la supprimez en tapant X.
Vous pensez avoir réellement supprimé les images 1 à 10, mais elles sont toujours là, "enroulées", comme dans une bobine d'appareil photo, sous votre image 11: vous n'avez en fait supprimé que l'une des deux copies de votre élément créées lors du "cut". Et vous pouvez à tout moment retrouver vos images "perdues" (cliquez RMB Template-RMB.png sur la flèche gauche de la bande, puis G et déplacez la souris vers la gauche pour ré-afficher le nombre d'images voulu (ou vers la droite pour en "cacher" encore plus – c'est un autre moyen d'enlever des images de début/de fin!).

Ceci est à la base d'à peu près tous les logiciels/stations de montage, et c'est bien utile!


Mode: Sequence

Raccourci clavier: ⇧ ShiftS

Menu: StripSnap to Curent Frame

Placez votre curseur vidéo (ligne verte verticale) à l'endroit souhaité. Dès lors, taper ⇧ ShiftS (ou menu StripSnap to Current Frame – "Caler à l'image courante") déplacera la bande sélectionnée pour que son début soit sur ce curseur. Si l'affichage du temps est en mode secondes, vous pouvez zoomer pour atteindre une précision d'une image (autour de 30-40 millisecondes, en fonction du standard).

Mode: Sequence

Raccourci clavier: G

Menu: StripGrab

Déplace la(les) bande(s) sélectionnée(s) horizontalement (temps) et/ou verticalement (pistes). Déplacer une bande vers le haut au-dessus d'une autre signifie que celle du dessous "couvrira" celle du dessus: les pistes basses ont une plus grande priorité que celles du haut – ATTENTION: c'est exactement l'inverse de ce qui se passe dans la plupart des autres logiciels de montage vidéo! Pour que ces deux bandes soient visibles en même temps, vous devez utiliser un effet de mélange (Add, Multiply, …).

Mode: Sequence

Raccourci clavier: Y

Menu: StripSeparate Images to Strips

Convertit la bande en une série de petites, une bande par frame. Très utile pour créer des diaporamas (slide shows), et autres situations où vous voulez manipuler un ensemble d'images non-contiguës (Very useful for slide shows and other cases where you want to bring in a set on non-continuous images.).

Propriétés des bandes

Blender 2.46 étend les propriétés de bande d'un seul panneau à un sous-contexte complet du contexte Scene (F10).

Blender 2.46+

Mode: Sequence, bande d'effet sélectionnée

Menu: Fenêtre Buttons → Contexte Render (F10), sous-contexte Sequence

Panneaux des propriétés de bandes.

Les propriétés de ces bandes sont exposées et réglables dans plusieurs panneaux des boutons Sequence (contexte Render – F10 –, fenêtre Buttons). En attendant que nous en ayons fini avec la documentation de toutes ces nouvelles fonctionnalités, voyez les "Release Notes" (en anglais).

  • Input – D'où viennent les images/vidéos utilisées.
  • Filter – "Pre-processing" des images.
  • Proxy – Utiliser des "mandataires" des images réelles, pour les PC peu puissants.
  • Edit – Modifier les propriétés de la bande.

Panneau "Input" des propriétés de bande

Contrôle la source de la bande. Vous y retrouvez le nom de fichier, la frame courante, des possibilités de recadrage (Crop) et de déplacement (Translate), ainsi qu'un décalage des images de début (A-Start) et de fin (A-End).

Panneaux "Filter" des propriétés de bande

Vous permet de rapidement régler des options courantes de "pre-processing" des images.

Premul
Pré-multiplier l'alpha.
Flip
X: renverse, retourne l'image de gauche à droite; Y: retourne l'image de haut en bas; Time: inverse l'ordre des images de la séquence.
Use Color Balance
Ce bouton active trois filtres pour ajuster la balance des couleurs: Lift, Gamma et Gain. Chacun d'eux peut voir son effet inverser en cliquant sur le bouton Inv … idoine. Chaque filtre se règle via son échantillon de couleur; régler celle-ci en blanc (RGB 1.0, 1.0, 1.0) revient à le désactiver.


Panneau "Proxy" des propriétés de bande

Un "proxy" ("mandataire") est une petite image (plus rapide à manipuler) qui "remplace" l'image principale. Quand vous construisez ce "proxy" (Rebuild Proxy), Blender calcule une petite image (un aperçu) pour chaque frame de l'élément – ce qui peut prendre un certain temps. Une fois calculées, cependant, les fonctions de montage comme le balayage (scrubbing) et le défilement (scrolling), ainsi que de compositing, comme le fondu enchaîné, qui utilisent ces proxies, sont bien plus rapides et fluides, mais donnent évidemment des résultats en basse définition. N'oubliez pas de désactiver les proxies avant le rendu final!

Panneau "Edit" des propriétés de bande

Name
Pour donner un nom à vos bandes.
Blend Mode
Par défaut, une bande remplace simplement la sortie de toute bande de "priorité" inférieure (au-dessus d'elle). Cependant, beaucoup d'autres modes de mélange (blending modes) sont disponibles, en fonction du type de bande. Par exemple, Alpha-Over superpose automatiquement la bande à une bande de moindre priorité. Ces modes de mélange rendent caducs l'usage de bandes d'effet séparées. Blend contrôle l'intensité (constante dans le temps) de l'effet de mélange.
Mute
"Cache" la bande, de façon qu'elle ne participe pas du tout au rendu de l'image finale.
IPO Frame Locked
"Uses the Sequence IPO curve to determine the Blend percent." NdT: ??? À mon avis, cette courbe Ipo est toujours active, pour peu qu'elle existe! Ce bouton correspond plutôt à ce qui est décrit ci-dessus.
Start
Modifie l'image de départ de la bande, exactement comme si vous la cliquiez-tiriez dans une fenêtre VSE. Astuce: quand j'ajoute une bande, je trouve pratique de simplement la lâcher, puis d'utiliser ce contrôle pour la placer à la frame voulue, plutôt que d'essayer de la lâcher exactement au bon endroit.
Chan
Modifie le numéro de piste de la bande, comme G-Y (???).


Blender 2.45+

Mode: Sequence

Raccourci clavier: N

Menu: StripStrip Properties

Propriétés de bande.

Tapez N pour afficher un panneau flottant qui contient les propriétés de l'élément sélectionné, en l'occurrence une bande vidéo. Par défaut, le nom d'une bande est celui de son fichier associé, vous pouvez le changer en cliquant LMB Template-LMB.png dans le champ texte Name: et en y rentrant un nom approprié. L'espace de travail affichera dès lors ce nom.

Activez le bouton Convert to Premul si la bande comporte un canal alpha (transparence). Utilisez FilterY si la bande est une vidéo (ou séquence animée) entrelacée. Retouchez la saturation couleur avec le contrôle Mul: (pour "multiplier"). Inversez le sens de lecture avec Reverse Frames. N'afficher qu'une image toutes les n images se fait en rentrant n dans Strobe: (pour "stroboscope": effet de lecture saccadée, pour n = 4, par ex., seules les frames 1, 5, 9, etc., seront affichées). Pour finir, quand vous utilisez une vidéo de type MPEG (VCD, DVD, XVid, DivX, …), une image est reconstruite à partir des informations contenues dans quelques images précédentes: utilisez Preseek: pour indiquer à Blender le nombre d'images précédentes à utiliser (par ex., 15 pour du Mpeg2 DVD).

Pour tous les effets, utilisez le panneau Strip Properties pour contrôler les effets des … effets; chacun aura des options différentes, mais ils sont tous réglables ici. Modifiez la longueur des bandes d'effet de transition/transformation pour modifier la vitesse de leur exécution. Que l'effet soit inclus ou sous forme de plugin, il applique généralement un traitement particulier à une ou deux bandes source; les résultats en sont visibles à la fois dans le canal 0 et dans le canal/piste où il est placé.

Travailler avec les bandes

Voici quelques tâches que vous serez sûrement amené à effectuer avec le VSE.

"Scrubbing"

Pour faire des "aller-retour" rapides dans votre film, utilisez la fenêtre Timeline. Cliquez-tirez LMB Template-LMB.png vers la gauche ou la droite dans cette fenêtre, déplaçant ainsi le curseur vertical indiquant la frame courante. Lorsque vous faites cela, l'image située sous ce curseur est affichée dans le fenêtre VSE (en mode Image Preview, évidemment!). Vous pouvez réaliser ce "scrubbing" en temps réel sur un ordinateur décent, si vous visualisez une séquence d'images ou un fichier vidéo (sans trop d'effets!). En revanche, le rendu des images provenant de scènes Blender peut être assez long…

Modifier la longueur d'une bande

Pour modifier une bande vidéo/image:

  • Cliquez RMB Template-RMB.png au milieu de la bande pour sélectionner toute la bande; en maintenant le bouton pressé (ou en tapant G – pour "Grab", "saisir", "attraper") puis en déplaçant la souris, vous déplacez en même temps la bande.
  • Cliquez RMB Template-RMB.png sur l'extrémité (flèche) gauche de la bande pour sélectionner la position de départ de la bande; en maintenant pressé le bouton (ou en tapant G) puis en déplaçant la souris vers la gauche ou la droite, vous déplacez le point d'entrée de la vidéo:
    • Si vous avez une séquence de 20 images, et déplacez l'extrémité gauche vers la droite de 10 images, la bande commencera alors à l'image 11 (les frames 1 à 10 ne sont plus utilisées). A utiliser pour se débarrasser des premières secondes souvent inutiles dans une prise vidéo, par exemple.
    • Déplacez l'extrémité gauche vers la gauche pour insérer au début de la bande autant de copies de la première image de la vidéo que vous ajoutez d'images. Utile pour rallonger un peu le début d'une vidéo, par exemple si vous n'avez pas assez de matière pour une transition en ouverture.
  • Cliquez RMB Template-RMB.png sur l'extrémité (flèche) droite de la bande pour sélectionner la position de fin de la bande; en maintenant pressé la bouton (ou en tapant G) puis en déplaçant la souris vers la droite ou la gauche, vous déplacez le point de sortie de la vidéo:
    • Déplacez l'extrémité droite vers la gauche pour raccourcir la bande, toutes les images situées au-delà du point de sortie ainsi défini seront ignorées. Utile pour se débarrasser des dernières secondes souvent tout aussi inutiles que les premières dans une prise vidéo, par exemple.
    • Déplacez l'extrémité droite vers la droite pour rallonger la bande. Quand toute(s) la vidéo(les images) disponible(s) dans le(les) fichier(s) sont utilisée(s), Blender rajoute autant de copies de la dernière image que nécessaire. Utile si vous manquez de matière pour une transition en fermeture.
Sélection multiple
Vous pouvez sélectionner plusieurs (extrémités de) bandes en cliquant ⇧ ShiftRMB Template-RMB.png: lorsque vous taperez G, tout ce qui est sélectionné se déplacera avec votre souris – cela signifie que vous pouvez à la fois déplacer une bande, en raccourcir deux autres et en rallonger une quatrième, par ex.


  • Mode Extend ("étendre"): ce mode fonctionne avec un ensemble de bandes sélectionnées. Tapez E pour l'activer. Toutes les bandes sélectionnées situées du même coté du curseur vidéo (ligne verte) que le curseur de la souris seront déplacées; celles situées de l'autre côté ne seront pas modifiées; celles situées "à cheval" sur le curseur vidéo se verront étendues (ou raccourcies…), par l'extrémité du même côté que le curseur de la souris. Cela vous permet de rallonger/raccourcir rapidement les bandes "à cheval" sur le curseur vidéo, en déplaçant ce qui se situe avant (ou après) celui-ci.
  • Autres méthodes de sélection:
    • Cliquez AltRMB Template-RMB.png (respectivement, CtrlRMB Template-RMB.png) sur une bande pour sélectionner sa flèche gauche (respectivement, droite), ainsi que la flèche correspondante (c-à-d droite – respectivement, gauche) de la bande précédente (respectivement, suivante) située sur la même piste. Cela vous permet de déplacer aisément la limite entre deux bandes adjacentes, sans toucher à leurs limites "extérieures".
    • Cliquez CtrlAltRMB Template-RMB.png sur une bande pour sélectionner ses deux flèches d'extrémités, et les flèches droite (respectivement, gauche) de la bande qui la précède (respectivement, qui la suit) sur la piste. Cela vous permet de déplacer aisément une bande prise "en sandwich" entre deux autres, sans avoir à modifier sa longueur – mais au détriment des longueurs de ses deux voisines!
Action figée
Quand vous étendez une extrémité au-delà des images disponibles (c-à-d du début/de la fin de l'animation), gardez à l'esprit que seules la première (dernière) image est copiée: au visionnage, l'action est figée au départ (à la fin). Tenez-en compte dans vos transitions (fondus, …): si cela ne sera pas très visible dans les premiers temps d'une transition en ouverture (ou dans les derniers temps d'une transition en fermeture), n'en abusez pas (à moins que vous ne souhaitiez cet effet figé, comme dans les "sitcoms" des années 80).


Pour modifier la durée d'une bande d'effet, modifiez simplement les extrémités de la(des) bande(s) source (et/ou utilisez le courbes Ipo, comme expliqué plus haut).

Boutons d'en-tête "Zoom", "Scale Display" et "Refresh"

Boutons Zoom, Scale et Refresh.

Ces boutons sont présents dans les en-têtes de toutes les fenêtres de Blender. Cliquez-tirez LMB Template-LMB.png sur le bouton +/- vers la gauche pour "dézoomer" sur l'axe du temps (autour du curseur vert), vers la droite pour y zoomer, vers le haut pour zoomer verticalement, et vers le bas pour "dézoomer" sur ce même axe.

Cliquez sur la croix en pointillés pour placer votre souris en mode "sélection par boîte". Sélectionnez une région de votre espace de travail en cliquant-tirant LMB Template-LMB.png. Quand vous relâcherez le bouton, la zone de travail se redimensionnera pour n'afficher que ce que vous avez sélectionné.

Sur des PC peu puissants, Blender peut différer le rafraîchissement des autres fenêtres jusqu'à ce que vous arrêtiez de travailler dans l'une d'elles et qu'il récupère du temps CPU pour travailler en arrière plan aux calculs de la scène. De cette manière, il évite de vous ralentir, il vous laisse la main. Cliquez sur le bouton Refresh pour le forcer à rafraîchir/synchroniser l'affichage de toutes les fenêtres présentes.

Inverser l'action

Dans les boutons Sequence du contexte Scene (F10), sélectionnez Flip Time, dans le panneau Filters.

Ralenti, Lecture accélérée, Distorsion temporelle

Utilisez l'effet intégré Speed, documenté à la page suivante.

Rendre une vidéo en une séquence d'images fixes

Souventes fois, couper et réarranger (monter, quoi) une bande vidéo compressée avec un codec provoquera des accès de rage, car beaucoup d'algorithmes utilisés par ces codecs se basent sur plusieurs images pour en reconstruire une seule: impossible de travailler avec une précision à l'image près! Pour travailler directement sur l'ensemble des images "brut", une technique très courante consiste à importer votre vidéo dans une bande, et à la rendre immédiatement en une série d'images fixes, chacune enregistrée dans son propre fichier (au format Jpeg, le plus souvent). Pour cela, faites AddMovie et charger votre vidéo originale. Réglez la taille du rendu (SizeX et SizeY, que ce soit la même que l'originale, ou que vous vouliez la redimensionner – attention alors à conserver les proportions si vous ne voulez pas déformer votre vidéo), réglez le type de fichier sur Jpeg, la Quality, et dans l'onglet Anim, réglez End: au nombre d'images de votre vidéo (n'oubliez pas d'activer Do Sequence!). Cliquez sur ANIM et une série de fichiers numérotés sera rendue dans le dossier spécifié dans le champ texte supérieur de l'onglet Output. Vous pouvez maintenant supprimer la bande vidéo (pas le fichier de départ!), et faire AddImages, cliquer RMB Template-RMB.png sur le nom du répertoire contenant les images pour les importer comme séquence animée. Maintenant, quand vous coupez à l'image 4321, par exemple, vous pouvez être sûr que la première image de la bande ainsi crée sera vraiment l'image 4322.

Rendre une vidéo à partir d'une séquence d'images fixes

Ridiculement facile:

  1. Importez la séquence d'images comme décrit ci-dessus;
  2. Réglez le chemin et le nom du fichier de sortie comme vous le souhaitez (par ex. C:\Mes Documents\MonBoFilm<code/>

sur Windows™, ou <code>/Users/ChezMoi/MonBoFilm<code/> sur Macintosh™ ou GNU/LinuxGPL);

  1. Modifiez votre Format de sortie pour un format vidéo (AVI, MOV, FFMpeg) et choisissez votre codec;
  2. Réglez le nombre d'images par seconde ("framerate", ou "fps") pour correspondre à celui de votre séquence;
  3. Réglez la fin End: du rendu au nombre d'images de la séquence, et
  4. Cliquez ANIM.

Un fichier vidéo unique est créé et enregistré; son nom est celui spécifié, plus l'image de début et de fin du rendu (par ex. <code>MonBoFilm0000-0250.avi).