From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Utiliser la fenêtre 3D

Note
Cette page est en fait une sorte d’introduction au chapitre sur le modelage


Description

La fenêtre 3D est exactement comme une fenêtre ouverte sur un monde 3D. Pour vous aider à conserver le sens de l’orientation, en particulier de ce qui est en haut (Z), un petit repère XYZ est représenté en bas à gauche, à côté du numéro de la frame courante et du nom de l’objet actif. Le reste de la vue, s’il s’agit d’une des vues orthographiques normales (de face, de côté ou d’en haut), affiche une grille. L’espace entre chaque ligne de la grille représente une (ou un multiple de) Unité Blender (BU) par défaut, une unité de mesure arbitraire. Si vous modelez quelque chose du monde réel, vous pouvez décider (dans votre esprit) qu’une BU est égale à n’importe quelle unité de mesure actuellement en vogue dans votre pays ou culture. Si vous êtes un physicien suisse du CERN, ce sera peut-être l’angström. Si vous êtes un ingénieur allemand, les millimètres devraient faire l’affaire. Et si vous êtes un cadet de l’espace d’Amsterdam, les unités astronomiques pourraient réveiller votre imagination.

Dans cet espace 3D, l’objet actif est en rose. L’objet actif est le dernier de tous les objets sélectionnés, et est affiché dans une teinte légèrement plus claire que les autres objets sélectionnés. Le curseur 3D est un cercle rouge et blanc avec un réticule. Cliquer LMB Template-LMB.png déplace ce curseur à l’emplacement indiqué dans l’espace tridimensionnel. Utilisez la touche de “snap” (⇧ ShiftS) pour aligner le curseur 3D sur la grille, les éléments sélectionnés, ou l’élément actif.

Cliquer RMB Template-RMB.png sélectionne l’objet situé sous le curseur, à moins qu’il ne le soit déjà, auquel cas cliquer RMB Template-RMB.png n’a aucun effet. Cliquer ⇧ ShiftRMB Template-RMB.png sélectionne un autre objet, tous en conservant celui (ceux) qui l’est (le sont) déjà, ce qui vous permet de sélectionner plusieurs objets en même temps. Si vous cliquez ⇧ ShiftRMB Template-RMB.png sur un objet déjà sélectionné, vous le désélectionnerez (comme un interrupteur).

Mode “Edit”

Passez en mode Edit à l’aide du sélecteur de mode, ou en pressant ⇆ Tab dans la fenêtre. En mode Edit, vous sélectionnez les composants de l’objet, et leur faites subir des choses. Des choses étranges, horribles. À moins que vous ne soyez doué pour cette activité, et soyez prêt à vous exercer intensément, auquel cas vous obtiendrez de meilleurs résultats. Certains objets, comme les caméras, ne peuvent être édités. Faites à nouveau ⇆ Tab pour revenir au mode d’où vous veniez.

Boîte à outil de la fenêtre 3D

Presser Space dans la vue 3D fait apparaître un petit menu très pratique. Vous pouvez également cliquer LMB Template-LMB.png ou RMB Template-RMB.png pendant une bonne seconde pour obtenir le même résultat.

“Add”

Utilisez cette option pour ajouter des objets à votre scène. Vous pouvez y accéder en :

  • Cliquant sur le menu Add de l’en-tête de la fenêtre User Preferences (en haut de l’écran), ou…
  • Pressant Space quand votre souris survole l’une quelconque des fenêtres 3D View ouvertes.
Panneau View Properties.

L’objet est ajouté exactement là où se trouve votre curseur 3D. Il n’est plus automatiquement placé en mode Edit (comme cela était le cas avant), mais vous pouvez retrouver ce comportement en activant le bouton Switch to Edit Mode, dans le panneau Edit Methods de la fenêtre User Preferences. Pour définir l’emplacement de votre curseur 3D, vous pouvez :

  • Cliquer LMB Template-LMB.png dans une fenêtre 3D View, et le curseur 3D se déplace instantanément à cet endroit. Pour le positionner dans l’espace 3D, vous devrez cliquer dans deux vues 3D ayant des points de vue orthogonaux (une première fois, par exemple, en vue de dessus pour déterminer la position XY, puis une deuxième fois en vue de face, pour la coordonnée Z), ou…
  • Utiliser le panneau de propriétés de la vue (View » View Properties...) pour y entrer des coordonnées XYZ exactes dans les champs 3D Cursor, ou…
  • Sélectionner un objet dont le centre se trouve là où vous souhaitez placer le curseur 3D, et y “coller” ce dernier avec ⇧ ShiftS   »  Cursor -> Selection. Le curseur 3D se placera alors à l’emplacement de cet objet. Notez qu’un objet ajouté à ce moment sera placé “dans” (ou “à travers”) l’objet existant (les deux objets occuperont la même position).

Blender supporte beaucoup de primitives différentes, que vous pouvez ajouter à votre scène :

Exclamation mark.png
Si vous ajoutez un objet en mode Object, la primitive constitue un nouvel objet à part entière. Si vous ajoutez un objet alors que vous êtes déjà en mode Edit pour un autre objet, la primitive (qui sera forcément du même type) est ajoutée à cet autre objet, formant un objet composé de plusieurs primitives.
  • Mesh (“maillage”) – Ce sous-menu vous permet d’ajouter des meshes polygonaux à votre scène. Le complexe Monkey (“singe”, appelé Suzanne) est assez utile pour faire des tests (de matériaux, de fourrure, etc.).
  • Curve (“courbe”) – Ce sous-menu vous permet d’ajouter des courbes ou des chemins (paths) à votre scène. Ils sont utiles pour modéliser des objets… courbes ! (montagnes russes, pieds de mobilier décorés, etc.), ou pour réaliser des chemins à parcourir pour des objets animés.
  • Surface – Ce sous-menu vous permet d’ajouter des objets NURBS à votre scène.
  • Meta – Ce sous-menu vous permet d’ajouter des méta-objets à votre scène. Il s’agit d’objets procéduraux (générés par des algorithmes), utiles pour des effets spéciaux (comme utiliser deux metaballs pour animer une division cellulaire, par exemple).
  • Text (“texte”) – Cette commande vous permet d’ajouter des objets texte à votre scène.
  • Empty (“vide”) – Cette commande vous permet d’ajouter des empties à votre scène. Les empties ne sont pas rendus, ils sont plutôt utilisés pour contrôler certains aspects d’autres objets. Par exemple, vous pourriez utiliser un Empty pour contrôler la rotation d’un modificateur Array. Puisqu’ils ne sont pas rendus, vous pouvez les utiliser pour toutes sortes de choses, comme des hooks (“hameçons”), etc., qui requièrent un objet d’où tirer une position, une taille ou une rotation.
  • Group (“groupe”) – Ce sous-menu vous permet d’ajouter des copies de tout groupe que vous avez défini dans votre scène. Très pratique si vous avez des objets entiers regroupés ensemble, puisque vous pouvez facilement en ajouter des copies.
  • Camera (“caméra”) – Cette commande ajoute une caméra à votre scène.
  • Lamp (“lampe”) – Ce sous-menu vous permet d’ajouter des lampes à votre scène. Pour plus d’informations sur les différents types de lampes disponibles, voyez la documentation les concernant.
  • Armature – Cette commande ajoute une armature (un squelette) à votre scène. Celles-ci sont essentiellement utilisées pour animer bras, jambes, etc., encore que, si vous vous sentez d’humeur “Pixar-dienne”, vous puissiez tout à fait en installer une sur une lampe !
  • Lattice – Cette commande ajoute un lattice à votre scène. Ces objets ne “font” rien par eux-mêmes, mais vous pouvez les utiliser pour déformer d’autres objets. Afin qu’un Lattice déforme un objet, vous devez ajouter à ce dernier un modificateur Lattice. Vous pouvez alors placer le lattice autour de cet objet (comme si c’était une cage), et toute modification de la forme du lattice déformera l’objet. Plus l’objet que vous déformez est détaillé, meilleur sera le résultat – un modificateur Subsurf pourrait donc se révéler utile ici.

“Edit”

  • Enter Editmode (“entrer en mode Edit”) – Cette commande vous fera passer en mode Edit, ce qui vous permet d’éditer les vertices, arêtes et faces d’un objet particulier, au lieu de manipuler l’objet dans son ensemble.
  • Duplicate (“copie”) – Cette commande crée une copie indépendante de l’objet (des objets) sélectionné(s).
  • Duplicate Linked (“copie liée”) – Cette commande crée une copie liée de l’objet sélectionné – les datablocks ObData étant partagés, l’original et la copie utilisent les mêmes mesh (ou courbe, …), courbe Ipo, matériau, etc.
  • Delete (“supprimer”) – Cette commande supprime l’objet (les objets) sélectionné(s).
  • Object Keys (“clés d’objet”) – Ce sous-menu contient des commandes concernant les images-clé (d’animation).
    • Show/Hide (“afficher/masquer”) – Cette commande vous permet d’afficher la version fil-de-fer (le “fantôme”) des images-clé de l’objet sélectionné. C’est fort utile, car cela vous permet de visualiser le chemin parcouru par l’objet sélectionné.
    • Select Next (“sélectionner la suivante”) – Cette commande sélectionne l’image-clé suivante, pour l’objet actif.
    • Select Prev (“sélectionner la précédente”) – Cette commande sélectionne l’image-clé précédente, pour l’objet actif.

“Select”

Ce sous-menu contient exactement les mêmes options que le menu Select de l’en-tête, voyez les pages sur la sélection du chapitre sur le modelage.

“Transform”

  • Grab/Move (“attraper/déplacer”) – Cette commande vous permet de déplacer librement l’objet (les objets) sélectionné(s).
  • Grab/Move on Axis (“attraper/déplacer le long d’un axe”) – Ce sous-menu contient des commandes vous permettant de déplacer un objet le long d’un axe particulier : X Global, Y Global, etc.
  • Rotate (“faire tourner”) – Cette commande vous permet de faire tourner un objet autour de l’axe Z de la vue (c-à-d qu’il tourne dans le sens (inverse) des aiguilles d’une montre “autour” de l’écran ; l’axe de rotation traverse perpendiculairement l’écran).
  • Rotate on Axis (“faire tourner autour d’un axe”) – Ce sous-menu vous permet de faire tourner un objet autour d’un axe particulier : X Global, Y Global, etc.
  • Scale (“redimensionner”) – Cette commande redimensionne l’objet (les objets) sélectionné(s).
  • Scale on Axis (“redimensionner le long d’un axe”) – Ce sous-menu vous permet de redimensionner un objet le long d’un axe particulier : X Global, etc.
  • ObData to Center (~“ObData au centre”) – Cette commande déplace les données de l’objet (vertices du mesh/points de contrôles de la courbe/etc.), afin que leur centre (point médian) soit à la même place que le centre de l’objet.
  • Center New (“recentrer”) – Cette commande déplace le centre de l’objet vers le centre des données de l’objet.
  • Center Cursor (“centrer [sur le] curseur”) – Cette commande déplace le centre de l’objet à la position courante du curseur 3D.
  • Properties (“propriétés”) – Cette commande affiche le panneau flottant Transform Properties, qui vous permet de spécifier les coordonnées exactes des vertices, ainsi que les position, rotation et taille des objets.
  • Mirror (“miroir”) – Cette commande vous permet de faire une symétrie miroir de la sélection, le long de l’axe spécifié. Comme pour toutes les options dépendantes des axes, “Global” se réfère à la scène en général, alors que “Local” se réfère aux axes particuliers d’un objet (dépendant de ses rotations).
  • Snap (~“coller”) – Ce sous-menu vous permet de “coller” le curseur 3D ou la sélection à la grille, ou l’un à l’autre.
    • Selection -> Grid – Cette commande “colle” la sélection au point le plus proche de la grille.
    • Selection -> Cursor – Cette commande “colle” la sélection à l’emplacement du curseur 3D.
    • Selection -> Center – Cette commande “colle” l’élément (les éléments) sélectionné(s) au centre de l’objet (des objets) sélectionné(s). C’est surtout utile en mode Edit, car cela vous permet de “coller” des vertices, arêtes, ou faces au centre de l’objet sur lequel vous travaillez.
    • Cursor -> Selection – Cette commande “colle” le curseur 3D au centre de l’élément (des éléments) sélectionné(s).
    • Cursor -> Grid – Cette commande “colle” le curseur 3D sur le point le plus proche de la grille. C’est très pratique si vous placez manuellement le curseur 3D (par un clic), et qu’il n’atterrit pas exactement à l’endroit voulu.
    • Cursor -> Active – Cette commande “colle” le curseur 3D au centre de l’élément actif.
  • Clear/Apply (“nettoyer/appliquer”) – Ce sous-menu contient des commandes vous permettant de “nettoyer” (réinitialiser) ou appliquer (rendre définitif) les position, rotation, taille, déformation, ou copies de l’objet (des objets) sélectionné(s).
    • Clear Location – Cette commande réinitialise la position de l’objet (des objets) sélectionné(s) à (0,0,0).
    • Clear Rotation – Cette commande réinitialise la rotation de l’objet (des objets) sélectionné(s).
    • Clear Scale – Cette commande réinitialise la taille (l’échelle) de l’objet (des objets) sélectionné(s).
    • Apply Scale/Rotation – Cette commande applique les taille et rotation. Le datablock de données de l’objet (les vertices du mesh/points de la courbe/etc.) est modifié afin que, sans modifier son aspect, l’échelle de l’objet soit de nouveau de 1.0, sans aucune rotation.
    • Apply Visual Transform (“appliquer les transformations visuelles” ?) – ???
    • Apply Deformation – Cette commande applique les déformations à l’objet. Note : Cela n’est maintenant disponible qu’au travers des boutons Apply du panneau Modifiers (contexte Editing).
    • Make Duplicates Real – Cette commande rend les copies (produites par DupliVerts ou DupliFrames) réelles (vous pouvez donc les éditer individuellement).

“Object”/“Mesh”/“Curve”/…

Ce sous-menu contient une partie des options du menu correspondant de l’en-tête, voyez les pages sur l’édition du chapitre sur le modelage.

“View”

Ce sous-menu contient une partie des options du menu View de l’en-tête.

“Render”

  • Passepartout – Cette option active l’option Passepartout de la caméra sélectionnée. Une fois activée, en vue Camera, elle assombrit la zone autour de la caméra, vous permettant de vous concentrer sur la zone qui sera effectivement rendue (le champ de vision de la caméra).
  • Set Border (“définir les bords”) – Cette option vous permet de sélectionner (par cliqué-tiré) une zone particulière de la vue caméra à rendre. C’est utile si vous êtes en train de régler un détail sur un objet, et ne voulez pas avoir à rendre toute la scène (si vous travaillez sur un objet entier, la vue locale pourrait mieux correspondre à vos besoins). Si vous voulez supprimer cette région “limitatrice” de vos rendus à venir, désactivez le bouton Border (activé par défaut quand vous utilisez l’option Set Border), en bas du panneau Render, sous-contexte Render, contexte Scene (F10).
  • Render (“rendre”) – Cette option rend la scène courante. Ça fait la même chose que le gros bouton RENDER du contexte Scene, correspondant au raccourci F12.
  • Anim (“animer”) – Cette option rend une animation en utilisant les réglages d’animation courants. Ça fait la même chose que le bouton ANIM du contexte Scene, correspondant au raccourci CtrlF12.
  • Preview (“prévisualisation”) – Cela active le panneau flottant Preview, qui affiche une prévisualisation (sans anti-aliasing) de ce qui ce trouve sous le panneau.