From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Projections orthographique et en perspective

Mode: Tous les modes

Raccourci clavier: 5 NumPad

Menu: View » Perspective / View » Orthographic

Description

Chaque vue 3D supporte deux types différents de projection. Elles sont illustrées dans (Projection orthographique (à gauche) et en perspective (à droite)) :

Projection orthographique (à gauche) et en perspective (à droite).

Notre œil est habitué à la projection en perspective, car les objets distants apparaissent plus petits. La projection orthographique semble un peu étrange au début, car les objets conservent les mêmes dimensions quelle que soit leur éloignement. Cela revient à regarder la scène depuis une position infiniment lointaine. Néanmoins, la projection orthographique est très utile (c’est l’option par défaut dans Blender, et dans la plupart des autres logiciels 3D), car elle donne une vue plus “technique” de la scène, permettant de dessiner et juger des proportions plus facilement.

Options

Pour changer le type de projection dans une vue 3D, choisissez les entrées de menu View » Orthographic ou View » Perspective. Le raccourcis 5 NumPad permet de basculer d’un mode à l’autre.

Projection caméra
Le type de projection que vous utilisez dans une vue 3D n’influence pas le rendu de la scène. Ce dernier est par défaut en perspective. Si vous avez besoin d’un rendu orthographique, sélectionnez la caméra et activez le bouton Orthographic du panneau Camera, contexte Editing (F9) – voyez également cette page sur les perspectives de rendu.


Démonstration de la vue caméra.

L’entrée de menu View » Camera met la vue 3D en mode caméra (0 NumPad). Vous voyez alors la scène comme elle sera rendue (voyez Démonstration de la vue caméra) : l’image rendue contiendra tout ce qui se trouve à l’intérieur du rectangle pointillé extérieur. Cette vue permet de zoomer, mais pour changer de point de vue vous devez déplacer ou tourner la caméra.

Détails techniques

Définition de la projection en perspective

Voici la façon dont est construite une projection en perspective : vous avez une scène en trois dimensions, et vous êtes un observateur placé en un point O. La scène 2D en perspective est construite en plaçant un plan, une “feuille de papier”, là où la scène 2D doit être dessinée, devant le point O, et perpendiculaire à la ligne de vue. Pour chaque point P de la scène 3D vous construisez une droite PO passant par P et O. Le point d’intersection S entre cette droite PO et le plan est la projection en perspective de ce point. En projetant ainsi tous les points P de la scène sur le plan, vous obtenez une vue en perspective.

Définition de la projection orthographique

Dans une projection orthographique, vous avez une direction (ligne) de vue, mais pas de “point de vue” O. La droite passant par le point P est alors parallèle à la ligne de vue. L’intersection S entre cette droite et le plan est la projection orthographique du point P. Et en projetant ainsi tous les points P de la scène, vous obtenez une vue orthographique.

“Shading” d’une vue

Mode: Tous les modes

Raccourci clavier: Z / ⇧ ShiftZ / AltZ / ⇧ ShiftAltZ / D

Description

Selon les performances de votre ordinateur, la complexité de votre scène, et le type de travail que vous êtes en train de faire, vous pouvez choisir parmi différents modes d’affichage:

Bouton des modes d’affichage de la vue 3D.
Textured (“texturé”)
Affiche les objets UV-texturés par une(des) image(s), avec éclairage OpenGL. Ni les textures procédurales ni les textures plaquées différemment ne seront affichées.
Shaded (“ombré”)
Affiche une approximation des textures et de l’éclairage au niveau de chaque vertex, et fait un “fondu” entre eux. C’est beaucoup moins précis qu’en passant par le moteur de rendu, mais beaucoup plus rapide. Notez bien que si votre scène n’est pas éclairée, tout sera noir.
Solid (“uni”)
Les surfaces sont affichées dans une couleur unie, avec un éclairage OpenGL pré-défini (indépendant de celui de la scène elle-même, il est réglé dans la fenêtre User Preferences, onglet System & OpenGL, groupe de contrôles Solid OpenGL lights, voyez cette page). C’est le mode d’affichage par défaut.
Wireframe (“fil de fer”)
Les objets sont représentés par des lignes qui rendent leurs formes reconnaissables (par ex. les arêtes des meshes ou surfaces…).
Bounding Box (“boîte englobante”)
Les objets ne sont pas dessinés. Ce mode montre seulement des boîtes parallélépipédiques englobant tout juste chaque objet.

Vous pouvez basculer entre ces modes en :

  • Utilisant la liste déroulante Draw type de l’en-tête des vues 3D (Bouton des modes d’affichage de la vue 3D).
  • Pressant D pour afficher le menu Draw mode.
  • Utilisant les raccourcis basés sur Z comme détaillé ci-dessous :
Modes d’affichage et raccourcis basés sur Z.
ZAlterne entre les modes d’affichage Wireframe et Solid.
⇧ ShiftZAlterne entre les modes d’affichage Wireframe et Shaded.
AltZAlterne entre les modes d’affichage Solid et Textured.
⇧ ShiftAltZPasse en mode d’affichage Textured.

Découpage de la vue (“clipping”)

Mode: Tous les modes

Raccourci clavier: AltB

Menu: View » Set Clipping Border

Description

Afin de vous aider dans le travail avec des objets ou scènes complexes, vous pouvez modifier le “découpage” (clipping) de la vue pour isoler visuellement ce sur quoi vous travaillez.

Cet outil n’affichera que ce qui se trouve à l’intérieur d’un volume défini par vos soins.

Une fois activé avec AltB, vous devez dessiner un rectangle à la souris, dans la vue 3D de votre choix. Le volume de clipping créé sera alors :

  • Un parallélépipède rectangle (de longueur infinie) si votre vue est orthographique.
  • Une pyramide à base rectangulaire (de hauteur infinie) si votre vue est en perspective.

Pour supprimer ce clipping, faites à nouveau AltB.

Exemple

Découpe de région/volume.

(Découpe de région/volume) est un exemple d’utilisation de l’outil de clipping avec un cube. Commencez par activer l’outil avec AltB, c’est la situation illustrée en haut à gauche de l’illustration (“Start”). Cela provoque l’apparition d’un curseur “croix” pointillé. Cliquez-tirez LMB Template-LMB.png pour dessiner une région rectangulaire, comme illustré en haut à droite de l’illustration. Maintenant, la région est définie, et le découpage lui est appliqué, en trois dimensions. Notez qu’une partie du cube est devenue invisible (découpée). Utilisez MMB Template-MMB.png pour effectuer une rotation de la vue et vous remarquerez que seul ce qui se trouve dans le volume pyramidal est visible. Tous les outils d’édition se comportent comme d’habitude, si ce n’est qu’ils n’agissent qu’au sein du volume pyramidal de clipping.

La zone grise représente le volume de clipping lui-même. Une fois le clipping désactivé avec un autre AltB, tout l’espace 3D redeviendra visible.

Image d’arrière-plan

Mode: Tous les mode

Panneau: Background Image

Menu: View » Background Image...

Description

Avoir une image de fond dans vos vues 3D est très utile dans nombre de situations : modelage, évidemment, mais également peinture (par ex. vous pouvez avoir des images de référence de visage pendant que vous peignez des textures directement sur votre modèle…), animation (quand vous utilisez une vidéo en arrière-plan), etc.

Exclamation mark.png
Il y a quelques points qui méritent d’être soulignés à propos des images d’arrière-plan :
  • Elles sont spécifiques à leur fenêtre (c-à-d que vous pouvez avoir des fonds différents pour chacune de vos vues 3D, par ex. des images de dessus/de face/de côté pour les vues correspondantes…).
  • Elles ne sont disponibles que pour les vues orthographiques Top, Side et Front (et leurs versions complémentaires) ! L’image reste la même quand vous changez entre ces six vues.
  • Leur taille est liée au niveau de zoom de la fenêtre (c-à-d qu’elles grandissent quand vous zoomer, etc.).
  • Vous pouvez utiliser des fichiers vidéo et des séquences animées.
Le panneau Background Image par défaut, vide.
Le panneau Background Image en utilisation.

Blender gère cette fonctionnalité à travers le panneau flottant Background Image, affiché par l’entrée de menu View » Background Image.... Par défaut (Le panneau Background Image par défaut, vide), ce panneau n’a qu’un seul bouton Use Background Image, qui (dés)active l’ensemble.

Une fois activé (Le panneau Background Image en utilisation), vous avez les réglages spécifiques à l’arrière-plan en haut, et en-dessous, un ensemble de contrôles standard aux datablocks image :

  • Use – Désactivez-le pour éteindre l’image de fond.
  • Blend – Ce curseur contrôle la transparence de l’image d’arrière-plan (de 0.0 – complètement opaque – à 1.0 – totalement transparent).
  • Size – Contrôle la taille, ou échelle, de l’image dans la vue 3D (en unités Blender).
  • X Offset, Y Offset – Le décalage horizontal et vertical de l’image d’arrière-plan dans la vue (par défaut, elle est centrée sur l’origine), en unités Blender.

Les autres contrôles sont communs à la plupart de ceux des datablocks image, et sont complètement documentés dans le chapitre sur les textures. Disons simplement que vous pouvez charger (bouton Load) une image ou en utiliser une déjà existante (bouton double-flèches), utiliser des images statiques, vidéo, séquences ou générées, et ainsi de suite…

Blender3D FreeTip.gif
Utilisez un “proxy” basse-définition
Pour améliorer les performances de votre PC quand vous utilisez des images de fond, vous pourriez avoir à employer des “proxies” en basse-définition. Si la définition de votre écran est de 800×600, alors l’image de fond, en plein écran, sans zoom, n’a pas besoin de dépasser les 800×600. Si votre image de référence fait 2048×2048, votre ordinateur va ramer pour éliminer ces pixels surnuméraires. Essayez plutôt de prendre cette image 2k×2k, et réduisez-la (avec Blender, ou Gimp…), à 512×512 par exemple. Vous aurez des performances seize fois supérieures, sans perte notable de qualité ou d’exactitude. Ensuite, à mesure que vous affinerez votre modèle, vous pourrez augmenter cette résolution.


Exemple

Voici une illustration de la fonctionnalité d’image d’arrière-plan :

Un exemple d’image d’arrière-plan.

Puisqu’il s’agit d’un fichier vidéo et que Auto Refresh est activé, quand vous changez de frame ou faites AltA, l’image de fond suit ou est jouée…