From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Základy uživatelského rozhraní programu Blender, a jak ho rychle používat

Initial Blender screen setup

Předpokládá se, že v této fázi máte nainstalovaný a sthnutý program Blender.

Když spustíte Blender porpvé,objeví se Vám obrazovka na pravé straně.

  • Hlavní ovládací panel se nachází v horní části obrazovky. Herní engine má zde svůj ovládáací panel, který probereme později. Herní engine má zde vlastní Game panel, který probereme později.
  • Hlavní 3D pohled je ukázán jako oblast, přes kterou je natažená mřížka. Ukazuje aktualní scénu z pohledu zeshora.
  • Nabídkový panel pro pohled 3D je umístěn pod ním..
  • V dolní části obrazovky uvidíte Buttons panel. Ještě jednou, herní engine má svůj vlastní panel F4 (který je rovněž representován fialovou ikonou ve stylu PacMan Manual-Part-I-Interface-Context-Logic.png) k čemuž se rovněž dostaneme později.


Bližší pohled na výchozí scénu

Výchozí scéna obsahuje...

  • Krychli - čtverec uprostřed. Když je toto vybráno, označení je provedeno jednak použitím růžového obrysu, rovněž také použitím 3D transformovacího manipulátoru (šipkami, kterými můžete posouvat za účelem manipulace objektu).
  • Světlo - malý kruhový objekt s čárkovanou linkou.
  • A kameru - tu můžete vidět přilepenou na dolní části obrazovky.

Interakce s 3D scénou

thumbs

Držte stisknutý prostřední tlačítko myši MMB Template-MMB.png a táhněte jim za účelem rotace scény. Pokud pracujete s laptopem nebo máte myš pouze s dvěmi knoflíky můžete držet stisknutý AltLMB Template-LMB.png aby jste nahradili prostřední tlačítko myši.

Rotujte pohledem kolem dokola až se díváte na krychli z vrchu, z levého pohledu, jak je demonstrováno na animovaném obrázku vlevo.


Můžete rovněž přiblížit a odtáhnout přiblížení pohledu na 3D scéně tak, že rolujete prostřední tlačítko na myši MMB Template-MMB.png nebo držte CtrlMMB Template-MMB.png a pohybujte myší nahoru a dolů.

Abyste mohli projíždět po scéně držte stiknutý ⇧ ShiftMMB Template-MMB.png a pohybujte myší kam je třeba.

Změna 3D scény do perspektivní pozice

thumbs


Tento stávájícípohled se nazývá orthografický pohled. Může být jednodušší hledět na scénu v perspektivním pohledu, který bere v úvahu hloubku.

thumbs


Pro změnu do perspektivního pohledu zvolte View -> Perspective alternativu z 3D Wiew menu.

BSoD-Introduction to the Game Engine-Orthographic To Perspective menu.gif


Manipulace objektu uvnitř scény

Budete schopni pohybovat objekty kolem, pomocí kliknutí a držením držáčku na 3D transformovacím manipulátoru. Klikněte a držte držáček na krabici, abyste ji mohli pohybovat po scéně.

Pohyb, rotace a změna velikosti 3D manipulatoru jsou ukázány dole, včetně komba 3D manipulátoru, který zahrnuje všechny tři aspekty.

Translate
Rotate
Scale
Combo


Pro změnu typu 3D manipulátoru klikněte na ikony ukázané dole v 3D pohledovém menu.

Výběr ikon manipulátoru.
Menu pro výběr manipulátoru.

Další rychlá cesta jak změnit typ 3D manipulátoru je stisknout CtrlSpace a zvolit Translate, Rotate a Scale z menu.

Pro jednoduchost použivání se tento návod soustředí na používání 3D manipulátoru pro ovládáníobjketu v 3D pohledu. Další návody, které budete číst budou vysvětlovat jak používat Grab, Rotate a Scale zkratky pro manipulaci objektu za použití 3D manipulátor.

Pro více informací o 3D manipulátoru se odvolejte na Manual/Manipulators.

Výběr dalších objektů uvnitř scény

V programu Blender pokud kliknete pravým tlačítkem myši RMB Template-RMB.png na určitý objekt, tímto způsobem tento objket vyberete.

Kliknutím levého tlačítka LMB Template-LMB.png posune kurzor programu Blender 3D do prostředí. Nové objekty budou přidány dle lokality tohoto 3D kurzoru.

Kliknutí pravým RMB Template-RMB.png na lampu se vybírá a potom se pohybuje za použití 3D manipulátoru. Kliknutím pravým RMB Template-RMB.png znovu na krychli se vybírá a pohybuje se kolem opět za použití 3D manipulátoru.

Přidávání a vyjímání objektu ve scéně

BSoD-Introduction to the Game Engine-Add Object Menu A.gif

Odstranění objektu je jedoduché... vyberte objekt a zmáčkněte Del tlačítko.

Pro přidání objektu na scénu použijte Add menu položku ve vrchní části obrazovky a potom zvolte Mesh sub-option.

BSoD-Introduction to the Game Engine-Add Object Menu B.gif

Můžete také zmáčknout Space tlačítko během 3D pohledu za účelem znázornění menu s celou řadou použitelných funkcí, včetně Add menu.

Toto Vám umožní přidat celou řadu jednoduchých (nebo primitivních) modelů na scénu, včetně rovin, krychlí, koulí a kuželů. Můžete rovněž přidat Suzanne, model opičí hlavy (primitivní model / model opičí hlavy... to je vtip vývojáře programu Blender :))

Zafixování nově přidaných 3D objektů

Animovaný obrázek ukazuje novou krychli zahrnutou do scény a kroky potřebné pro to, aby se umístila do scény, jak je předpokládáno.

Když přidáváte nový objekt, Blender udělá dvě věci.

  • Nový objekt bude automaticky umístěn do Edit modulu. Extensivní editování komplexních objektů je mimo schopnost tohoto článku, takže pro tuto chvíli budete potřebovat zmáčknout ⇆ Tab tlačítko za účelem eliminace Edit modulu a navrácení se zpět do Objekt módu vždy, když přidáte nový objekt do scény.
  • Nový objekt bude nejprve rotován do pozice původního pohledu.

Toto může znít velice zmateně pro nové uživatele, takže pro zjednodušení vždy následuje tuto sekvenci, když přidáváte nový objekt na scénu. Můžete zmáčknout AltR abyste eliminovali rotaci objektu.

Pro shrnutí, vždy když přidáte nový objekt na scénu jako část tohoto návodu, okamžitě zmáčkněte ⇆ Tab a následně AltR.

Přejmenování objektu

Když přidáte nový objekt, Blender mu přisoudí nové výchozí jméno (jako Krychle, or Krychle.001 pokud

Krychle už existuje).

Je velice dobrou taktikou přejmenovat objekty názornějšími termíny, jako je hráč, kára, dodávka atd. Toto umožní, aby scéna byla daleko více čitelná, když se stane komplexnější, bez ohledu na to, že se také stane daleko více srozumitelnější pro lidi, kteří ji přohlížejí.

Pokud chcete objekt přejmenovat, zvolte Objekt panel a změňte jméno uvnitř OB: area.

BSoD-Introduction to the Game Engine-Rename Object A.gif

Můžete rovněž přejmenovat objekt uvnitř Editing panelu.

BSoD-Introduction to the Game Engine-Rename Object B.gif

Practice, Practice, Practice

Měli byste strávit trochu času tím, aby jste se naučili navigovat 3D pohled a také vybírat a manipulovat objekty uvnitř současného prostředí. Až se budete cítit, že zvládáte bez problému základy rotace modelu v 3D prostředí a jejich přesun do nových lokací, potom můžete pokračovat k další sekci tohoto návodu, ktéra následuje.

--Mal_CanDo 17:00, 18 August 2006 (GMT)