From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Otevření souborů

Mode: All Modes

Hotkey: F1

Menu: File → Open

Popis

Blender používá souborový formát .blend, k ukládání skoro všeho: Objektů, Scén, Textůr, a všech nastavení oken vašeho uživatelského prostředí.

Warning
Blender předpokládá, že víte co děláte! Pokud nahrajete soubor, nebudete dotázaní, zda chcete uložit změny, provedené na scéně, na které jste předtím pracovali.


Možnosti

Pro nahrání souboru Blenderu z disku, stiskněte F1. The window underneath the mouse pointer then temporarily becomes the File Selection window as shown in (File Selection Window - loading.). The bar on the left can be dragged with LMB Template-LMB.png for scrolling. To load a file, select it with LMB Template-LMB.png and then press ↵ Enter, or click the Open File button. A file can also be loaded by using the MMB Template-MMB.png over the name of the file you want. It is then loaded up as if you had pressed enter.

Loading the UI

Inside each Blend file, Blender saves the user interface layout - the arrangement of screen layouts. By default, this saved UI is loaded, over-riding any user defaults or current screen layouts that you have. If you want to work on the blend file using your current defaults, start a fresh Blender, then open the file selector (F1). Turn off the "Load UI" button, and then open the file.

Navigating your Hard Disk

File Selection Window - loading.

The upper text box displays the current directory path, and the lower text box contains the selected filename. (P) moves you up to the parent directory. The button beneath, with the up and down arrow, maintains a list of recently used paths and on the windows platform a list of all drives (C:, D:, etc.). The breadcrumb files (. and ..) refer to the current directory and upper-level directory, respectively.

Other File Open Options

Open Recent
Lists recently used files. Click on one to load it in.
Recover Last Session

If autosave is turned on, this attempts to load the last hot backup for you. If the file cannot be found, you might need to manually go to your temp directory and find it.


Saving Files

Mode: All Modes

Hotkey: F2

Menu: File → Save

Description

Saving files is like loading files. When you press F2, the window underneath the mouse pointer temporarily changes into a File Selection Window, as shown in (File Selection Window - saving.).

Options

File Selection Window - saving.

Click the lower edit box to enter a filename. If it doesn't end with ".blend," the extension is automatically appended. Then press ↵ Enter or click the Save file button to save the file.

If a file with the same name already exists, you will have to confirm that you want to save the file at the overwrite prompt.

Depending on the number of save versions you have set, all existing files with the same name will be rotated to a .blendX file extension, where X is 1, 2, 3 etc. So, if you were working on MyWork.blend, and saved it, the existing MyWork.blend is renamed to MyWork.blend1, and a new MyWork.blend is saved. This way, you have hot backups of old saved versions that you can open if you need to massively undo changes.

Compress Files

Enable File->Compress Files to squash large files, removing dead space.

Hints

The save dialog contains a little feature to help you to create multiple versions of your work: Pressing + NumPad or - NumPad increments or decrements a number contained in the filename. To simply save over the currently loaded file and skip the save dialog, press CtrlW instead of F2 and just confirm at the prompt.

Other File Menu Options

Append or Link
You don't have to load a complete file; you can load in only selected parts from another file if you wish. Appending and Linking is discussed here.
Import
Blender can use information stored in a variety of other format files which are created by other graphics programs. It does this by running a script to import the file.
Export
Normally you save your work in a .blend file, but you can export some or all of your work to a format that can be processed by other graphics programs. To do so, you run an export script.