From BlenderWiki

Jump to: navigation, search

Blender 2.77 - Grease Pencil(グリースペンシル)

このページでは GPencil_Editing_Stage3 ブランチで開発され、2.77に入った新機能と改良を解説しています。

ハイライト:

  • ストロークスカルプティング
  • 3Dビューでの正しい「編集モード」
  • 筆圧対応に書き直された消しゴム機能
  • アクティブレイヤーのみに編集を制限するオペレーター(Isolate Layer(レイヤーをソロ化))
  • トランスフォームマニピュレーター対応
  • アニメーション編集が改善、コピーアンドペーストやもっと詳しいチャンネルフィルタリングなど。
  • …そして他にもたくさんの UI 調整など


Stroke Sculpting(ストロークスカルプティング)

最も大きな新機能は「ストロークスカルプティング」です。これはストロークを、メッシュモデリングやパーティクルのグルーミングでお馴染みの、ブラシベースのスカルプティングを使用して編集できます。

デモ動画:

最初のストロークスカルプティングデモ Joshua Leung (aligorith)氏作


GP - Doodle#2 - グリースペンシルでのドローイングとスカルプティングツールの使用とアニメーション Daniel M. Lara (pepeland)氏作


ホットキーと使用方法

スカルプティング:

  • ELMB Template-LMB.png - 押しっぱなしとドラッグでスカルプト
  • ECtrlLMB Template-LMB.png - 上と同じですが、エフェクトが反転します(ブラシにエフェクトの反転を適用するオプションがある場合)


スカルプティング中(要はペンを下ろしている、またはLMB Template-LMB.png中):

  • WheelUp Template-MWUP.png - ブラシサイズ拡大
  • WheelDown Template-MWD.png - ブラシサイズ縮小
  • ⇧ ShiftWheelUp Template-MWUP.png - ブラシの Strength(強さ)増加
  • ⇧ ShiftWheelDown Template-MWD.png - ブラシの Strength(強さ)減少


ツールとメニュー(スカルプティング時ではなく、Edit Stroke(ストローク編集)モード中):

  • DE - ストロークスカルプトツール用オプション付きパイメニューを表示。ここから現在のブラシ設定へのアクセスや、アクティブブラシの切り替えが可能です。
  • ⇧ ShiftF = ブラシの強さを設定
  • CtrlF = ブラシのサイズを設定

ブラシ

グリースペンシルのストロークを編集するツールがいくつかブラシの形で提供されました。これらは大量の選択→調整→選択→調整というつまらない編集パターンを繰り返すことなしに、ストロークの見た目を「ペイント」または「スカルプト」できます。現在実装されているブラシは以下の通りです。

  • Smooth(スムーズ)
  • Thickness(厚さ)
  • Grab(ひっぱる)
  • Push(押す)
  • Twist(ねじり)
  • Inflate/Shrink(つまむ/膨らます)
  • Clone(クローン)

Smooth(スムーズ)ブラシ

Smooth(スムーズ)ブラシはスケッチの揺らぎや震え、凸凹などの汚い部分をスムーズにして綺麗にします。ワンクリックで済ますのと比べ、このブラシはスムージングする量、そして重要な'場所'をコントロールできます。

  • Affect Pressure(筆圧を使用) - このオプションはストローク幅の値をスムージングするのに使用します。

Thickness(厚さ)ブラシ

Thickness(厚さ)ブラシは、カーソル下のストロークの幅を増加・減少するのに使用できます。

  • ブラシの Strength(強さ)はブラシが通り過ぎたストロークの幅を増減する速度をコントロールします。
  • 二つの用途に使用可能です。
    • Add(追加) = 太くなります。
    • Subtract(減算) = 細くなります。
  • これはタイマーを使用します。つまり、もし特定の場所にマウスカーソルを数秒間置いたままにしておいた場合、その場所は次第に太く・細くなっていくということです。
  • 注意:このブラシは幅のスムージングはしません。修正する必要がある場合、"Affect Pressure(筆圧を使用)" オプションを有効にした Smooth(スムーズ)ブラシを使用してください。

Grab(ひっぱる)ブラシ

Grab(ひっぱる)ブラシ機能は、シングルクリックの円選択と移動操作を組み合わせたような物に少し似ています。 スカルプトアクション開始時、このブラシはブラシ円の範囲内にあるストロークのポイントを取り、このポイント群を移動できるようにします。 円選択+移動に対するこの方法の主な利点は、数クリックとキー操作の節約と、制作プロセスがよりスムーズになることです。

Push(押す)ブラシ

Push(押す)ブラシは Grab ブラシと非常によく似ており、こちらもストロークポイントを移動できます。しかし Grab ブラシとは違い、Push(押す)ブラシはスカルプトアクション開始時にブラシの下にあった、最初のポイント群に操作が限定されません。代わりに、ブラシの移動毎に、ブラシが最後に評価されてから動いた量を元に、現在ブラシの下にあるポイントを移動します。

Twist(ねじり)ブラシ

Twist(ねじり)ブラシはカーソルを中心にポイントをひねり/回転し、「渦巻き」エフェクトを作成するのに使用します。ストロークポイントを軽く歪ませるのにも便利です。

CW/CCW(時計回り/反時計回り) トグルは、時計回り(ClockWise)または反時計回り(Counter ClockWise)にポイントを回転するのに使用できます。

注意:現在、これは2Dエディターではうまく動作しません。

Pinch/Inflate(つまむ/膨らます)ブラシ

Pinch/Inflate(つまむ/膨らます)ブラシはポイントをカーソルから引き離す、または近づけるのに使用できます。

  • Thicness(厚さ)ブラシのように、二つのモードが利用可能です。
    • Pinch(つまむ) = ポイントをカーソル方向へ近づけます。
    • Inflate(膨らます) = ポイントをカーソル方向から引き離します。

Clone(クローン)ブラシ

Clone(クローン)ブラシはアクティブレイヤーのコピー/ペーストバッファからクリックした場所にペーストするのに使用できます。


使用方法:

  1. 使用前に、いくつかのポイントを選択し、[Ctrl]+[C]キーでコピーしておきます。
  2. カーソルをコピーしたストロークをペーストしたい場所に置きます。
  3. マウスボタンを押しながらドラッグし、ペーストされたストロークの配置と調整をします。


デモ:

Clone(クローン)ブラシデモ(1分55秒より)


操作には3つのもーどがあります。

  • スタンプモード - 新しくペーストされたストロークの中心が、ブラシ/カーソルを追うように移動します。
  • スタンプ+スマッジ - Use Falloff(減衰を使用)オプション有効時、新しくペーストした全ストロークを同じ量移動するのではなく、現在カーソルの下にあるポイントのみ移動します。従って、このモードはむしろペースト+Push の操作に近いです。
  • 連続 - ブラシの移動と共に、現在のブラシ位置に新しくコピーのペーストを繰り返すだけです。実際には、カンバス全域にサンプルを「塗る」のに使用するため、コピーバッファの内容を「ブラシテンプレート/カーネル」として処理しています。

スカルプティング全般についてのメモ

  • Selection Mask(選択マスク) トグル(ブラシ設定毎)が、ブラシ操作を選択中のポイントのみに制限するのに使用できます。
  • Use Falloff(減衰を使用)有効時、ポイントに対するそのブラシの影響を計算する際にリニアなフォールオフが使用されます。つまり、ブラシ中心に近いポイント(要はカーソル下にあるポイント)はブラシ端の物よりも強く影響を受けるということです。
  • メッシュスカルプトツール同様、Strength(強さ)スライダーの横にある Use Pressure(筆圧を使用)トグルは、タブレットの筆圧値でブラシのエフェクトの強さをコントロールするのに使用するかどうかを決めるのに使用します。

ドローイングツールの改良

消しゴムの改良

消しゴムが書き直され、絵を描くときの使用感が改善されました。

  • 消しゴムが非常に「ソフトな」挙動になりました。特に(消しゴムの円の中心からリニアなフォールオフで)筆圧に反応し、削除する前にストロークの幅を狭くしようとするようになりました。
  • 消しゴムはアクティブレイヤーだけでなく、表示中・編集可能なレイヤーすべてに作用するようになりました。
    • これは「モード・コンテクストの間違い」を減らします(例:削除しようとして、違うレイヤーをアクティブにしてしまうなど)。

以前に誤って削除したことがなかったかもしれませんが、注意してください(例:スクリーンスペースのオーバーレイで作業時の、シーンの他の部分など)。

    • もし従来の挙動が必要であれば、他の全レイヤーをワンクリックで(または専用のホットキーにバインドすることで)簡単にロックできます。
    • アクティブレイヤーがロック中の場合、どのストロークもまったく削除できません。
  • イベントシステムの変更(後述)により、消しゴムはデフォルトでスタイラスの後についている「消しゴム」を使用するだけでアクティブ化できます。
  • 様々なバグが修正されました(例:データブロックを違うエディターと共有している時や、消しゴムのサイズでペイント操作が動作しない場合など)。


追加ドローイングオプション

新しい "Additive Drawing(追加ドローイング)" オプションは、前フレームの結果を元にして作成するショットのアニメーションを簡単にします。 下の動画はこれをアニメーションワークフローに使用する方法を披露しています。

"Additive Drawing" Demo - Ocean Ripples by Joshua Leung (aligorith)

詳細は 2cdd34e をご覧ください(英文)。

ストローク配置設定

"Stroke Placement(ストローク位置※)" 設定がデータブロック毎ではなく、ツール設定毎に格納されるようになりました。UI 内での変更点はありません(つまり、大半のエディターではまだ Tool Settings(ツール設定)領域にあります)。これは純粋に内部的な変更です。 (※2.77時点では「ストロークの設定」になっています)

この変更による主な恩恵は、データブロックを最初に作らなくても、ストロークを3D(または2D)空間に変換する方法を指定できることです。これらの設定がツール設定に格納されるようになったため、「いつでも利用可能」なのです。

技術的なレベルでは、これらの設定は4つの新しいプロパティの一つとして、context.tool_settings に格納されるようになりました。具体的にどれが使用されるかは、どのエディターで作業をしているかによります。

  • View 3D(3Dビュー)
    • context.tool_settings.gpencil_stroke_placement_view3d - "Stroke Placement(ストローク位置)" リスト
    • context.tool_settings.use_gpencil_stroke_endpoints - "Only Endpoints(エンドポイントのみ)" トグル
  • Sequencer(シーケンスエディター)(プレビュー領域)
    • gpencil_stroke_placement_sequencer_preview
  • Image Editor(UV/画像エディター)
    • gpencil_stroke_placement_image_editor
  • View2D(例:ノードエディターなど)
    • gpencil_stroke_placement_view2d
Blender3D FreeTip.gif
Python API の互換性の警告
[GreasePencil].draw_mode 設定を使用するアドオンは、context.tool_settings から新しい設定を使用するよう変更する必要があります。大半(例:context.object.grease_pencil.draw_mode を使用する大半のモデリングアドオン)の場合、現存のコードを context.tool_settings.gpencil_stroke_placement_view3d} を使用するよう変更してください。


編集 UI

  • 3Dビューでの作業時、ストローク編集が専用の編集モード(Edit Strokes(ストロークを編集))を持つように。
    • 3Dビューのヘッダーのメニュー ― 3Dビューのメニューに適切なグリースペンシルツールが表示されるようになり、ツールに簡単にアクセスできるように。
    • 3Dビューのヘッダーから便利なツール(コピー&ペーストなど)に簡単にアクセスできるように。
    • 他の Blender の形状データタイプで作業するのに似た、グリペンのストロークを編集するための専用のモードセレクターが、3Dビューのヘッダーに追加されました。
    • Blender の旧バージョンと完全互換。何も新しい・特別な物は全く必要なく、古いファイルの読み込みに何の問題もないでしょう。
    • (ツールシェルフの)"Enable Editing(編集を有効)" 切替ボタンが、(現在デフォルトで畳まれている)"▼Edit Strokes" ではなく、メインの ▼Grease Pencil(グリースペンシル)パネルに入りました(デフォルトでは)。▼Edit Strokes(ストロークを編集)と ▼Sculpt Strokes(ストロークをスカルプト)パネルは Strokes Edit(ストロークを編集)モード時(要は "Enable Editing"(編集を有効)ボタンが ON になっている時)にのみ利用可能です。
  • DW パイメニューが、レイヤー管理用ツールをもっと提供できるよう変更されました。
    • アクティブレイヤー名の横のドロップダウンでアクティブレイヤーを変更できます。
    • また、アクティブレイヤーを削除するボタンもあります。


  • Isolate Layer(レイヤーをソロ化)オペレーターは、アクティブレイヤーのみを編集可能にするかどうかを切り替えることができます。★ボタン(上下ボタンの下)か、Numpad*で有効にできます。


  • オニオンスキンの UI に多数の調整が行われ、もっと簡単に使用できるようになりました。
    • (ストローク編集モード中)ヘッダーにすばやくオニオンスキンをON/OFFできるボタンが付きました。
    • オニオンスキンの前後のデフォルトカラーが設定されました。今のところ(新しいレイヤーの)デフォルトストロークカラー同様、手動でカスタマイズする方法はありません。
    • ビューの移動やアニメーション再生中、オニオンスキンは表示されません。これは多数のオニオンスキンに埋もれないようにし、モーションが「同じ」かどうかを簡単に確認できるようにします。


  • イベントシステム - キーマップ定義時、Pen※(ペン)と Eraser(消しゴム)イベントにバインドできるように。(※訳注:原文では「Stylus Tip」。該当するイベントがないため変更)
    • デフォルトでは、Eraser(消しゴム)イベントはグリースペンシルの消しゴムにマップされています。
    • Pen(ペン)イベントはバインドするとスタイラスのみ(つまりマウスなし)で Blender を使用できなくなるため、デフォルトでは何にもバインドされていません。
    • Pen(ペン)を使用するイベントのマッピングには注意が必要です。イベントのマッチが少し過剰になる傾向があり、その結果キャッチすべきでないイベントをブロック/キャッチする可能性があります。


ツール

  • Transform(トランスフォーム)ツールがいくつか改善されました。
    • ストローク作業時のトランスフォーム呼び出し時、"gpencil_strokes" の設定がもう必要なくなりました。コンテクストが自動的に探知されるようになったためです。
    • トランスフォームマニピュレーターを、グリースペンシルのストロークのトランスフォームに使用できるように。


  • 3Dビューでの作業時、⇧ ShiftS で、"Snap To(スナップ)" メニューが現れるように(他の2Dビューには「2Dカーソル」がないので現在未対応です)。

    これにより、3Dカーソルをストロークポイントにスナップしたり(ストローク開始位置の決定などに便利)、ストロークを空間内のポイントにスナップできるようになりました。


  • ⇧ ShiftG(Select Grouped(グループ選択))が選択中のポイントと同じレイヤーの全ストロークを選択できるように。
  • M がグリースペンシルレイヤー(新規レイヤーも含む)間のグリースペンシルのストロークの移動に使用できるように。
  • AltC で "Convert to Geometry(ジオメトリに変換)" オペレーターにアクセスできるように。


アニメーション編集

  • DopeSheet(ドープシート)エディター(の "Grease Pencil" モード)でのキーフレームのコピー&ペーストが2.4x以来初めて動作するように。
  • 現在のシーンとその中のオブジェクトに添付されたグリースペンシルブロックのみを表示できるように。
  • DopeSheet(ドープシート)エディターでレイヤーを名前を元にソートできるように。
  • DopeSheet(ドープシート)エディター中に I で、特定の時間に空のグリースペンシルフレームを作成できるように。
    • Additive Drawing(追加ドローイング)が無効になっている時に空フレームが作成されます。
    • それ以外の時は、そのレイヤーのアクティブフレームがコピーされ、それを使用します。
  • 再び DopeSheet(ドープシート)エディター中に ⇧ ShiftM で、キーフレームを時間でミラー反転できます。

Sequencer(シーケンサー)統合

  • 修正:シーケンサーを使用した OpenGL プレビューがデフォルトのグレー背景(と、対応フォーマットによる保存時は透過)ではなく、各フィルムに関連したワールド背景をレンダリングするように。
    これは別々のシーンファイルのグリースペンシルのショットを集め、非破壊ワークフローにより編集・作成したフィルムをレンダリングするのにシーケンサーを使用する時に便利です。また、もっといい見た目のアニマティクスをレンダリングするのにも便利です。