From BlenderWiki

Jump to: navigation, search

Blender 2.74: ユーザーインターフェイス

ユーザーインターフェイスに次のような改良が行われました: Gooseberry 中に開発されたビューでの合成エフェクトの最初のマージ(アンビエントオクルージョンと被写界深度)、スポイトによるビュー深度の取得、アウトライナーの Orphaned Data Blocks(孤立データブロック)モードと、その他多数のユーザビリティの改良、ノードへのメモの追加、編集可能になったファイルブラウザのブックマークなど…。

ビューポート

ビューポートコンポジティング

アンビエントオクルージョンと被写界深度を使用した、Gooseberry プロジェクトの Frank

現在のビューポートコンポジティングシステムには、3Dビューポートとオフスクリーンレンダリング中にポストプロセスとして使用できる、二つのエフェクトが含まれています。

目標はこのシステムの汎用化と、将来的にノードによるエフェクトを可能にすることです。しかし現時点は二つのハードコードのエフェクトのみ使用可能です。

エフェクトのコントロールは複数の場所にあります。
各3Dビュー毎のエフェクトをコントロールするには、(3Dビューのプロパティ領域の)▼Shading(シェーディング)パネル下の "Ambient Occlusion(アンビエントオクルージョン(AO))" と、"Depth Of Field(被写界深度)" のチェックボックスを使用します。

またカメラオブジェクトにも、プロパティにリアルタイム被写界深度エフェクトをコントロールできる新しいパネル、 "▼GPU Depth of Field(GPU被写界深度)" があります。これはシーケンスエディターや、3Dビューポート内での OpenGL レンダリングとカメラビュー時に使用されます。

制限事項

  • 現在のシステムはエフェクト用の情報の生成をシーンの深度バッファーに依存しています。そのため、ウィジェットやワイヤーフレームなど、深度バッファーに描いた物はすべてエフェクトに影響します。
  • SSAO エフェクトは表面の法線に依存していますが、現在のシステムは真の遅延シェーディングではないため、これらは深度バッファから合成され、スムーズシェーディングは考慮されません。また、合成された法線の性質により、メッシュの端にアーティファクトが生じます。
  • 初めての実装である今回は、Multisampling(マルチサンプル)が動作しません ― 正しく動作させるにはメモリを大量に要求するからです。


Ambient Occlusion(アンビエントオクルージョン)
このエフェクトはスクリーン空間でレイキャストを行うことで、アンビエントオクルージョンをシミュレートしています。エフェクトを操作するため、以下のコントロールが追加されました。

Strength(強さ):
この係数は直接エフェクトの色に掛けられます。大きくするとエフェクトが強くなります。

Distance(距離):
エフェクトを計算するワールド空間での最大距離。

Attenuation(減衰):
エフェクトが距離に応じて減衰する強さ。大きくすると離れた面のこのエフェクトへの影響が減ります。縞模様ができるのを回避するのに使用します。

Samples(サンプル数):
エフェクトに使用されるサンプル数。大きいと品質が上がりますが、エフェクトは遅くなります。

Color(色):
エフェクトの色。環境ライティングから汚れや錆びまで、違った感じにすることができます。


Depth Of Field(被写界深度)

このエフェクトはカメラの被写界深度をシミュレートするものです。 アクティブカメラの Object Data(オブジェクトデータ)プロパティの▼Depth of Field(被写界深度)パネルにある、Viewprt F-stop(ビューのF-stop)と、焦点距離(Distance)、センサーサイズ(Size)、焦点距離/焦点用のオブジェクト(Focus:)でコントロールします。

エフェクト用のオプション。Ambient Occlusion(アンビエントオクルージョン)設定は緑、Depth of Field(被写界深度)設定は黄色の部分

Viewport F-stop(ビューのF-stop):
この設定はカメラレンズの絞りに関する物です。小さいとボケが大きくなります。

Distance(距離):
レンズの焦点距離です。スポイト(E)で直接3Dビュー上からサンプリングし、焦点を設定することができます。

Focus(焦点):
上と同じですが、オブジェクトの原点を焦点の設定に使用できます。設定時は距離に対して優先して使用されます。

Focal Length(焦点距離):
大きくするとボケが大きくなります。

Size(サイズ):
センサーサイズが大きいとボケが小さくなります。


その他

  • ビュー深度用のスポイト。(カメラの Distance(距離)プロパティ上で[E]キー)。(3d503ea8d6fa8)
  • ペイントモード時、邪魔になる3Dカーソルが隠れるように。(0294327615bb1)
  • カメラクリッピング境界用のテーマオプション。(7a6d757a3b802)

Outliner(アウトライナー)

Orphaned Datablocks(孤立データブロック)モード

アウトライナー中での孤立データブロックの表示

「孤立した」データブロックを表示する新しいモードを追加。(030b0aa)

孤立したデータブロックとは、以下のいずれかを持つ物を差します。

  • 共有するユーザー(オブジェクトなど)が 0
  • F(フェイクユーザー)のみ

前者の場合、次回の保存+リロード時に裏でファイルから削除されます。よってこの機能は、そのカテゴリから外し、保存すべき価値のある物があるかどうかを確認するのに役立ちます。

またデータブロックに上記のユーザーを一つ与える、フェイクユーザーのみを持つデータブロックも含めており、(ユーザーが間違えた場合)簡単にもう一度OFFにできるようにしています。 この表示には他にも、これらのデータブロックを保持したくなくなった時、わざわざ探さなくても、その対象から簡単にフェイクユーザーを削除できるという恩恵もあります。


データブロックの管理 ― 保存すべきか消すべきか
ユーザー数の表示と、データブロックを保存するかどうかを切り替えるのに使用する、制限設定用の列。(16689a1)

  • 最初の列にはデータブロックが保存されるかどうかを示すアイコンを表示します。チェックマークはデータブロックが保存される予定であることを、×マークはその反対を示します。これをクリックすること、そのデータブロックを保存するかどうかを切り替えられます。
  • 二つめの列はユーザー数です。
  • 三つめの列はデータブロックにフェイクユーザーがあるかどうかです。

二つめと三つめの列は(機能的にいうと)非常に重複しています。三つめの列のクリックでフェイクユーザーを切り替えできると同時に、さらにここでのその役割はパワーユーザー(と、そして願わくば他の人にも、保存するか否かの情報と、フェイクユーザーの間の関連性を想像できるよう)に、情報を与えることです。


使用していないデータブロックの全消去
"Purge All(すべて消去)" ボタンが、アウトライナーの「孤立データ」モードのヘッダーに付きました(263518e)。これは使用していないデータブロックを、ファイルやセッションを閉じたり再度開いたりせずに取り除くことができます。この動作は、Save(保存)と "revert(開き直す)"(Blenderを終了せず、保存ファイルをディスクから再読込する)オペレーターに、確認のダイアログを付けることで実現しています。

警告:

  • やはりまだファイル/データの再読み込みなしでは、現在のセッションから無条件にすべてのデータブロックを、綺麗に削除することはできません。
  • これはつまり、この操作が元に戻せないということです。特に、Undo History(操作履歴)がこの操作の実行によって失われてしまいます。警告というのはそういう意味です…(ただし実際には Undo や Redo もまた、メモリからシーン全体のデータベースをリロードしているのです。よってこれは異常なことではないのです ;)。

その他

  • オブジェクトの階層(親子関係)全体を削除できるように。(82223270a83f7)
  • アルファベット順のソートがオプションに。 (ffe56536f10507)
  • "Show Active(アクティブを表示)" がツリーを開き、子を表示するように。(3356f3f0bb15fa)
  • オブジェクトのグループへのドラッグ&ドロップに対応。(61c66a996ca5e5)
  • モディファイアーとコンストレイントが専用のコンテクストメニュー(現時点はレンダリングやビュー表示の切り替えと削除のみ)を持つように。(23214ecad03bfe)
  • 直接と間接の両方でリンクされているライブラリを、アウトライナー内で二回(最初のレベルと、最初のユーザーの子として)表示し、その状況を反映するように。(rBcaf5a325b014e)
  • レンダリングまたはビューの表示設定ボタンの上でCtrlLMB Template-LMB.pngを押すと、子にもその設定が伝播するように。rB24976dd29d16f

Node Editor(ノードエディター)

  • フレーム内でのテキストデータブロックの表示に対応。(eb150ef337597)

小さな改良

  • UIList 検索ボックスが Blender の他の検索ボックス同様、すぐ更新されるようになりました。(3e034831de8)
  • ファイルブラウザーに(アウトライナーなどのような)検索ボックスが付きました。(dcc5997527d)
  • ファイルブラウザーのブックマーク(の名前と順番)が編集可能に。(9e2abbc9ba5d)
  • Safe Areas(セーフエリア)がカスタマイズ可能に。アクションとタイトルセーフのマージンの高さと幅が設定可能です。まあ、センターカットとプリセットにも対応しました。値は Sequencer(シーケンサー)とカメラビューで共有されます。(09c83d6fea0fc)
  • 何も修飾キーを押していない時のRMB Template-RMB.pngの使用が、コンテクストメニューを開くだけになりました。(c792e546991b)
  • 一時的なフルスクリーンからの復帰が、直前のユーザー設定のフルスクリーンを考慮するように。これにより、望んでないのにフルスクリーン以外のビューに戻ったりすることがなくなりました。(3e590923485d)
  • Environment Texture(環境テクスチャ)ノードの UI が調整され、Image Texture(画像テクスチャ)ノードの UI と一貫するように。(64ef6e74f7ba525412d8ae21f3)
  • Inset Face(面を差し込む)オペレーターがツールシェルフからアクセス可能に。(cc388ccca449f5)
  • オプションリストのループが[Alt]+マウスホイールに対応しました。(4422ecbb960e8)
  • 二つの新しいテーマが公式セクションに追加:Flatty Light(今回は本当にあります!)、RTheme
Flatty Light
RTheme