From BlenderWiki

Jump to: navigation, search

アニメーション

アニメーションには次のような改良が行われています:Grease Pencil(グリースペンシル)ツールの大幅なアップグレード(ストロークの編集やアニメーション、もっと詳細な描画スタイル、UIのオーバーホールなど)、その他 Graph Editor(グラフエディター)の使いやすさの向上など…。

Grease Pencil(グリースペンシル)

2008年の最初の導入以来、初めての大規模アップグレードがグリースペンシルに行われました。このリリースではグリースペンシルを簡単に3D領域へのストーリーボードの手描きに使用できるようにすることを目的とした、多数の改善をもたらします。もちろん、これらの改善の多くは他のワークフロー(モーショングラフィックス、ドローイング中の失敗の修正、単なる日常利用)にも便利です。 (14b951747f6a93a8e87)

"ForYou" の二つの別バージョンと Blender のシーンオーバービュー.blend ファイル。

Daniel M. Lara(pepeland)氏作。CC BY-NC-SA

ストローク編集

  • グリースペンシルのストロークを編集できるように。
    • D⇆ Tabを使用するか、ツールシェルフ内の "Enable Editing(編集を有効)" ボタンをクリックし、"Stroke Edit Mode(ストローク編集モード)" に入ります。このモードでは、一般的な編集ツールの多くがグリースペンシルのストロークポイントに対して処理されます。
    • 実装済のツールには選択、Select All(全選択)/Border(矩形選択)/Circle(円選択)/Lasso(投げ縄選択),Linked(リンク選択)/More(より多く選択)/Less(より少なく選択)、Grab(移動)、Rotate(回転)、Scale(拡大縮小)、Bend(曲げ)、Shear(せん断)、To Sphere(球へ変形)、Mirror(ミラー反転)、Duplicate(複製)、Delete(削除)など。
    • トランスフォームツール使用時は、Proportional Editing(プロポーショナル編集)も動作します。
    • 注意: 3Dビュー内の "View"(ビュー)設定のストロークのトランスフォームはあまりお勧めしません。
  • グリースペンシルのストローク設定がアニメーション可能に。
    注意: 現在、これらのプロパティ上では Driver(ドライバー)は動作しません。

ドロースタイルの改良

  • ストローク内部を "Fill"(面張り)できるようになり、ストロークとは別に色と透過度を設定できます。
    これにはポリゴンのフィルに OpenGL を使用しており、凸型の形状のみフィルできるという制限があります。凹型の形状では表示がおかしくなります(パックマンの口などは塗りつぶされるでしょう)。
  • "Volumetric Strokes(ボリューメトリックストローク)" - ストロークドローイングに代わる新たなドローイングテクニックが追加されました。これはストロークを連なった2Dの円盤で描画する物です。

これは元々、3Dラインの品質を向上するための実験的技術の一部でしたが、この技術を使用したエフェクトの可能性は興味深い物で、専用の機能にする理由は十分あります。半透明にし、ストロークの Thick(厚さ)を大きくすると一番いい結果になります。

  • Onion Skining(オニオンスキニング)の改善
    • 前後のゴーストに違う色を選択できるようになりました。Onion Skining(オニオンスキニング)オプションの隣の「カラーホイール」アイコンを ON にし、色を設定してください。
    • 現在のフレームの前後に違う数のゴーストを表示できるように。
  • Grease Pencil データブロックがデフォルトではアクティブオブジェクトの代わりにシーンに添付されるようになりました。
    • 長い間、オブジェクトへの添付はユーザーにとって追跡の継続が非常に困難なことだと知られてきました。今やこれがシーンレベルとなり、大半のユーザーが簡単に使用できるようになりました。
    • 古いファイル(と、オブジェクト添付による恩恵があるアドオンすべて)では例外的に、アクティブオブジェクトに Grease Pencil データブロックを持っている場合は代わりにそれを使用します。
    • 現在、UI からオブジェクトへの添付を選択することはできませんが、代わりにコンソールから簡単に行うことができます。
      context.active_object.grease_pencil = bpy.data.grease_pencil["blah"]


UI の変更

  • レイヤーの UI が入れ子のパネルデザインからリストを使用するようにクリーンアップされました。スペースが節約でき、見た目もよくなりました。
  • UI コードは現在すべて Python で定義されています。これに対応するため、これらの設定に簡単にアクセスできるようにするための、新しいコンテクストプロパティをいくつか追加する必要がありました。
    例:
    • "gpencil_data" - データブロック用
    • "active_gpencil_layer" と "active_gpencil_frame" - アクティブデータ用
    • "editable_gpencil_strokes" - 編集可能なストローク用
  • "ストロークの位置と整列" 設定(従来のプロパティ領域内の▼Grease Pencil(グリースペンシル)最下段の "Drawing Settings(描画の設定)")がツールシェルフに移動しました。グリースペンシルを描画する方法のプロパティよりツール設定の方が多かったためです。
  • developer.blender.org での初期の議論中での提案により、"Use Sketching Sessions(スケッチセッションを使用)""Continuous Drawing(連続で描画)" にリネームされました。
  • デフォルトでは、ペインティングオペレーターはストロークの作成を開始する前、マウスボタンが押されるのを待ちます。これはこのオペレーターを様々なツールバーやメニューなどに簡単に挿入できるようにするためです。(描画時、Dを押した場合に)直接開始するには、"wait_for_input" を False にセットします。
  • "Convert to Geometry(変換...)" オペレーターがツールシェルフに入り、モデラーが簡単にカーブを手描きできるようになりました。
  • Dope Sheet(ドープシート)の "Grease Pencil(グリースペンシル)" モードで、レイヤーを再配置できるようになり、色見本が各アイテムの隣に表示され、簡単にどれがどれか判るようになりました。
  • 対応する他のエディターすべてのツールバーに(グリースペンシルの)パネルが追加されました。
  • "Continuous Drawing(連続で描画)" 有効時、Undo(元に戻す)が再び動作するように。これは少なくとも2.69以来、描画中にノードエディターで不意にドライバーが追加されるのを修正した時に壊れていました。


パイメニューによる、ツールへのすばやいアクセス

多数のツールや設定にすばやくアクセスするための、実験的パイメニューのセットが追加されました。作業にこれを使う必要はありませんが、いくつかの共通の作業を簡単にしてくれるよう設定されています。

  • DQ = メインパイメニュー。コンテキストに応じて空いた場所にツールを表示します。
  • DW = "クイック設定" パイ。これはアクティブレイヤーの設定にすばやくアクセスできます。特に色、幅、オニオンスキンのON/OFFなど。

Graph Editor(グラフエディター)

  • キーフレームエリアのカーブの表示/非表示を行うオペレーターが復活しました。以下のオペレーターがあります:
    • H = 選択中のカーブを Hide(隠す)
    • ⇧ ShiftH = 選択されたカーブのみ表示(と、他のすべてを非表示)
    • AltH = 以前隠したカーブをすべて表示
  • Circle(円)選択がグラフエディターに追加されました。


小さな改良

  • Rendered Anim Playback(レンダリングしたアニメーションを再生):オプションの反転描画(F⇧ ShiftF)。 (5f948fb77fa24)
  • スペース下側の領域の、タイムラインにアクセス可能なアニメーションスペースを表示するようになりました。行動の対象がタイムラインか、アクション・グラフエディターかどうかが簡単にわかります(マーカーの編集時に便利です)。(36da579d122fe4)
  • Stretch To(ストレッチ)コンストレイントの体積の保持の制限。(f9cbb908a3fbd7