From BlenderWiki

Jump to: navigation, search
Nota del traductor
El castellano no es my lengua materna, entonces sea indulgente por favor…


render_povray
Renderizar escenas con POV-Ray 3.7
UI location Renderer desplegable menú
Usage Si POV-Ray 3.7 es instalado, active el addon en el menú File » User Preferences. Elija eso como renderizador, y renderize con F12.
Version 0.09 Author(s) Campbell Barton, Silvio Falcinelli, Maurice Raybaud, Constantin Rahn
Blender 2.57 License GPL
Category Render Distribution Release
Note(s) Despues del dies de mayo 2011, alguna programación sobre el escripto limitó la compatilidad trasera : si registró ficheros antes eso, y siempre utiliza el último exportador desde el SVN, está animado a lanzar el escripto de puesta al día y registrar de nuevo su escena con la nueva versión. Lanza la barra de búsqueda con Space y teclea “pov” por acceder a eso mando.


Executable information
File name (Python script)+ POV-Ray 3.7
Current version download https://svn.blender.org/svnroot/bf-extensions/trunk/py/scripts/addons/render_povray/
Python modules Utiliza módulos estándar de Python
External Python Modules or dependencies POV-Ray 3.7 actual beta


Warning Los dos POV-Ray 3.7 y eso escripto son beta.
Links http://povray.org/
Release Log Dev:2.5/Py/Scripts/Render/POV-Ray
Known Issues Actualmente Importante :
  • Ficheros de texturas incorporados necesitan de ser de-incorporados.
  • Bibliotecas ligadas no funcionan.
  • Border-Render crashes Blender.




POV-Ray 3.7 Integración con Blender 2.6x

Pov-Ray es un motor de renderiza basado en SDL (Scene Description Language, idioma des descripción des escena), con larga historia, lo que le hace muy estable y rico en funcionalidades. Se puede encontrar la última versión de POV-Ray 3.7 en : http://www.povray.org/beta/

Funcionalidades

Unas de las funcionalidades clave del exportador :

  • Geometría y modificadores.
  • Propriedades de material como filtrado, emisión, translúcidencia, transporte de luz subsuperficido…
  • canales de textura : Alpha ; Diffuse ; Bump ; Specular ; Mirror (utiliza el mismo canal que specular).
  • Iluminación global : Radiosity (iluminación indirecta) ; Cáusticos fotónicos (reflexión/refracción).

Utilización

Introducción

1. Utilize el menú File » User Preferences
1
2. Elija el uñero Add-Ons y active POV-Ray 3.7 en la lista de addons de renderiza.
2
3. Eilja POV-Ray 3.7 desde las selecciones de renderizadores. Entonces puede renderizar como de siempre con el botón Image o su acelerador (F12 por defecto).
3

Propriedades de renderizar

-Radiosity in POV-Ray is diffuse inter-reflection which has nothing to do with vertex color based radiosity.

-Anti-aliasing: two sampling methods are supported: recursive and non-recursive, sampling depth, Anti-alias threshold. (POV-Ray Wiki: Anti-Aliasing Options)

Blender3D FreeTip.gif
Depth of Field Without Anti-Aliasing
Using no anti aliasing when camera Depth of field is on will speed up rendering and often provide decent enough images.



-Bounding method switched to automatic BSP by the exporter as it's generally the most efficient(POV-Ray 3.7 only) but other acceleration methods are available in POV-Ray.

-Command line switches allow some command line arguments to be passed to POV-Ray. Arguments are separated by spaces. Command line switches consist of a / (Slash), + (plus) or - (minus) sign, followed by one or more alphabetic characters and possibly a numeric value. (POV-Ray Wiki: Command line options)

Some Commonly Used Commands
-DHide image while rendering

Use the command line switch -D to not show the rendered image in POV-Ray (slightly faster and lighter on memory). The image will be sent back to Blender after completion (on Linux this is a hidden default switch to avoid OS specific editor problems).}}

+WTLimit the number of threads used

+WT1 limits POV-Ray to using only one single render thread. (Likewise, +WT2 would instruct POV-Ray to use two render threads.)

+CContinue an interrupted render

+C for "Continue trace" is able to recover the point at which your last render stopped and continue it from there (even if you switched off your computer)

/EXITClose POV-Ray after rendering the image

There is also an option in POV-Ray for windows interface to do the same:

The "On Completion" option to "Exit POV-Ray for Windows" (in the Render Menu).


Blender3D FreeTip.gif
Fast Preview Renders
When first setting up your scene, and for fast preview rendering, turn off anti aliasing, depth of field, photons, Radiosity, expensive material features, and in the scene Shading panel, turn off shadows. (other features might get turned off from this panel in future versions of the exporter) Alternatively, use the "quality" command line switches +q1 to +q11. These allow you to easily disable most of the CPU-intensive features.



-Formatting of the exported POV-Ray file: Different indentation characters to choose from. Option to add comments to POV-Ray file. Option to write long lists of coordinates in one line for easier browsing of the POV file (and slightly faster parsing by the renderer)


Propiedades de escenas

Propriedades del mundo

-Background gets exported (sky texture appears a little different because of convoluted workaround used).


PovStair.png

Atmospheric Media (to create volume lights):
-Number of samples for media calculation
-Atmospheric media color


Propriedades de objetos

Importance sampling can be set for Radiosity to shoot more rays at object that require them most.

Propriedades de Data

-Exports Sky, Lights, Meshes and Blobs (MetaBalls). (Limitation for Blobs: MetaBalls with same naming are not combined the same as in Blender. MBall, MBall.001 ...)

Camera

-Depth of field Based on Blender UI distance field, not object field. With fixed blur amount for now.

Lamp

-No Shadows toggle button can be used to deactivate tracing of shadows for specific lamps only

Blender3D FreeTip.gif
For Realistic Light Attenuation
Use Inverse square falloff, and a small falloff distance value with a higher light intensity will give the best results with Povray's implementation of inverse square law. See this discussion


Propriedades de materiales

-Emission (new in POV-Ray 3.7)

Blender3D FreeTip.gif
Mesh Lights
When used together with Radiosity, Emit property will allow you to create light bulbs or any luminous form that really illuminates other objects.




-SSS (new in POV-Ray 3.7). Exporter uses only ui presets.

-Translucency (new in POV-Ray 3.7)

-IOR Mirror option for using one consistent IOR for raytrace reflection and refraction and not breaking the law of conservation of energy between the two.

-Iridescence (Newton's thin film coating)

Caustics.png

Caustics:
-Chromatic dispersion for refractive caustics
-Fast fake caustics (somewhat like Blender Raytransp)
-Refractive caustics using photons
-Reflective caustics using photons (high IOR or no mirror IOR for easier effect.)


Blender3D FreeTip.gif
Faster Photons
To set up some caustics, try moving from the smallest photon depth value to a minimum at which you start to see the effect you are after. Check off the Receive Photons object property for any object that does not really need it. (A glass object casting caustics often doesn't need to receive any itself.) Then you can balance other parameters to tune photons distribution and smoothing (gathering). Don't set the global spacing too fine in scene settings, because then you can still make it finer on each object using its spacing multiplier. If your system has several threads, they can be used in the photons stage: one thread per light, so you can then complexify your scene lighting without overhead.



shaders emulation attempted from blender:

-Specular and diffuse toon (no edges yet)

-Phong and Cook Torrence (both the same)

-Blinn (not perfectly matched)

-WardIso

-Fresnel and Minnaert, started but not finished yet


Blender3D FreeTip.gif
Glass Like Materials
When trying to achieve some glass like material, keep low diffuse value, dark or totally black to avoid dull surface and keep clear transparency.



Propriedades de texturas

-UV coordinates: best with planar projection for now. (Silvio Falcinelli)

-Texture channels: Alpha ; Diffuse ; Bump ; Specular ; Mirror (uses same channel as specular) --(No other channel because of POV-Ray non uniform syntax for them)

-Custom gamma for image textures (read POV-Ray 3.7 doc before using since it generally needs not be used.) (POV-Ray Wiki: Gamma Handling)

Código POV persanolizado

POV-Ray files are not just pure data files (like with most other renderers). They are programs, with loops, functions, etc. This means that no matter many featurs this exporter could support, POV-Ray will always have much more under the hood.

You can add custom POV code directly in Blender's text editor, all you have to do is to make sure this pov code has directly or indirectly a #declare keyword, followed by the name of your choice and the pov item you want to use. (Current POV syntax is closer to C than Python, so anything that follows two slash character ( // ) is a comment)

-Adding items directly Pov items can be anything but for now only the equivalent of Blender materials can be replaced with this method. In Povray, it is called texture {} don't get confused, it really includes all the material properties.

Though you can directly specify a texture {} block in POV-Ray files, the #declare directive allows to assign it to a variable and reuse it more easily. The exporter makes use of this feature by default, so you won't be able to use your custom texture, unless you declare it. Here is an example:

#declare MyTexture =
texture{ 
    pigment{ 
        brick color rgb< 0.99, 0.99, 0.99>  // color mortar
        color rgb< 0.75, 0.5, 0.30>*0.75  // color brick
        brick_size <0.25, 0.0525, 0.125> // format in x ,y and z- direction 
        mortar 0.01                      // size of the mortar 
        scale 3
    } // end of pigment
    normal {wrinkles 0.75 scale 0.01}
    finish {ambient 0.15 diffuse 0.95 phong 0.2} 
    rotate<0,0,0>  translate< 0.01, 0.00, 0.00>
} // end of texture

To use this texture you must display the text properties (menue View > Properties) and check Custom Pov Code option: ADD IMAGE

Then you have to go into the material properties to the Custom Pov Code field, and just type in the name of your declared item to use: MyTexture in the example Given: ADD IMAGE

Then you can render your image normally and the material will be replaced: ADD IMAGE

-Adding items indirectly from include files In any Povray scene you can use the #include directive to add items from an external Povray file. It's like the import function in Python. The files to be included have .inc as their name extension. Then in the replacement field, you can type in any of the declared names available in the include file. "Out of the box", Povray ships with a lot of include files. So you can use them for your textures, but you can also use them for some of their elements. For instance a very often used include file is one that allows to call colors by their names instead of numbers called colors.inc, so the previous example could also be written:

#include "colors.inc" 
#declare MyTexture =
texture{ 
    pigment{ 
        brick color White*0.99  // color mortar
        color rgb< 0.75, 0.5, 0.30>*0.75  // color brick
        brick_size <0.25, 0.0525, 0.125> // format in x ,y and z- direction 
        mortar 0.01                      // size of the mortar 
        scale 3
    } // end of pigment
    normal {wrinkles 0.75 scale 0.01}
    finish {ambient 0.15 diffuse 0.95 phong 0.2} 
    rotate<0,0,0>  translate< 0.01, 0.00, 0.00>
} // end of texture

Following this method, more custom objects are planned for future versions of the exporter: In POV-Ray a triangle mesh is just one primitive among many.

Until then You can explore the POV-Ray language by modifying the output file.

Pruebas

Comparison Blender <-> POV-Ray:

RenderBranch.jpg

Setup:
i7 720M, 6GB RAM
RenderBanch 64bit build: 57 seconds 99

POV37.jpg

Same setup,
POV-Ray 3.7 beta 38, 64bit: 49 seconds 97



Limitaciones

Exclamation mark.png
This version is POV-Ray 3.7 only, it won't work with POV-Ray 3.6


-This version of the script is a Work In Progress.

-Requires Blender version 2.56 revision 34650 or later.

-Don't use "Border-Render" to render only a part of an image! That will crash Blender at the momemt. (Maybe fixed but needs testing)

-Packed texture files need to be unpacked.

-On every rendering POV-Ray will save an image in the TEMP directory, which couldn't be deleted by the script (tested only on Win7. Same behavior on other OS?).

Lista de cosas de hacer por Mayo

See Dev:2.5/Py/Scripts/Render/POV-Ray

Ejemplos de materiales

Arquitectura

#include "colors.inc" 
#declare MyTexture =
texture{ 
    pigment{ 
        brick color White*0.99  // color mortar
        color rgb< 0.75, 0.5, 0.30>*0.75  // color brick
        brick_size <0.25, 0.0525, 0.125> // format in x ,y and z- direction 
        mortar 0.01                      // size of the mortar 
        scale 3
    } // end of pigment
    normal {wrinkles 0.75 scale 0.01}
    finish {ambient 0.15 diffuse 0.95 phong 0.2} 
    rotate<0,0,0>  translate< 0.01, 0.00, 0.00>
} // end of texture

biológico