From BlenderWiki

Jump to: navigation, search
InterfazEdiciónEntradaAgregadosTemasArchivoSistema

En las preferencias de entrada, puedes configurar como Blender reacciona al mouse y al teclado. Desde Blender 2.5, también es posilbe cambiar el mapa de teclas.

User-preferences-input.jpg

Manejar Presets

Blender te permite configurar multiples configuracioines de entrada. En lugar de borrar el mapa de teclas por defecto para crear el tuyo, puedes sencillamente agragar nuevos presets. Entonces, serás capás de elegir tu configuración preferida.

Crear un nuevo preset

Add-preset.png
Before changing anything in the default configuration, just click on the + next to the preset list. Blender ask you to name your new preset. Once you've done that, just select it in the list (it will enable the preset and permit you to edit it).

Use it

Interaction-splash.png

Once you've configured your preset, you can switch from the default one to your own :

  • Open the user preferences and select your preset in the presets list.
  • At Blender start up, select your preset in the Interaction menu of the splash screen. Notice that it will change the preset only for the actual opened file. If you select File → New or File → Open, the default preset will be re-loaded.
  • Select Help → Splash Screen menu to change the interaction.
New preset by default
If you save your configuration as default (by using Save As Default in the preferences window or by using CtrlU), the selected configuration will become the default one.


Delete a preset

Remove-preset.png
When you want to remove a preset, select it on the User Preferences list, and click on the X icon next to the Key Config name.

Export/Import key configuration

In some cases, you'll need to save your configuration in an external file (if you need to install a new system, share your keymap configuration with the community...). Just click on Export Key Configuration on the Input tap header and a file browser opens so that you can choose where to store the configuration. The Import Key Configuration button installs a keymap configuration that is on your computer but not in Blender.

Mouse

  • Emulate 3 Button Mouse : It is possible to use Blender without a 3 button mouse (such as a two-button mouse, Apple single-button Mouse, or laptop). This functionality can be emulated with key/mousebutton combos. Read more »

This option is only available if Select With is set to Right'.

  • Continuous Grab : Allows moving the mouse outside of the view (for translation, rotation, scale for example).
  • Select with : You can choose which button is used for selection (the other one is used to place the cursor).
  • Double Click : The time for a double click (in ms).

Numpad emulation

The Numpad keys are used quite often in Blender and are not the same keys as the regular number keys. If you have a keyboard without a Numpad (e.g. on a laptop), you can tell Blender to treat the standard number keys as Numpad keys. Just check Emulate Numpad

View manipulation

  • Orbit Style : Select how Blender works when you rotate the 3D view (by default MMB Template-MMB.png). Two styles are available. If you come from Maya or Cinema 4D, you will prefer Turntable.
  • Zoom Style : Choose your preferred style of zooming in and out with CtrlMMB Template-MMB.png :
    • Scale : Zooming depends on where you click first in the view. Moving the mouse from there to the center will zoom you out while moving to the border will zoom in (similar to scaling the view like a 2D picture but with an appropriate movement of the viewport camera).
    • Dolly : Selecting this allows you to zoom in or out by moving the mouse in the direction specified by the radio buttons.
      • Vertical : Moving down zooms out, moving up zooms in.
      • Horizontal : Moving left zooms out, moving right zooms in.
    • Continue : Using this style you control the speed (and not the value) of zooming by moving away from the initial click-point with CtrlMMB Template-MMB.png. Moving up from the initial click-point or to the right will zoom in, moving down or to the left will zoom out. The further away you move, the faster the zoom movement will be.

Keymap editor

User-preferences-keymap-editor.jpg

The Keymap editor lets you change the default Hotkeys. You can change keymaps for each window.

  1. Select the keymap you want to change and click on Edit (on the right).
  2. Open the keymap by clicking on the small arrow (on the left).
  3. Select which Input will control the function :
    • Keyboard : Only hotkey or combo hotkey (E or ⇧ ShiftE).
    • Mouse : Left/middle/right click. Can be combined with Alt, ⇧ Shift, Ctrl, ⌘ Cmd.
    • Tweak : Click and drag. Can also be combined with the 4 previous keys.
    • Text input : Use this function by entering a text
    • Timer : TODO
  4. Change hotkeys as you want. Just click on the shortcut input and enter the new shortcut.

If you want to restore the default settings for a keymap, just click on the Restore button at the top right of this keymap.