From BlenderWiki

Jump to: navigation, search

Blender's Video Sequence Editor is a flexible workbench for editing your video footage. It is used to review your footage, and glue many sequences of your movie together. It offers a number of built-in and plug-in effects to transition from sequence to sequence, providing advanced hollywood-style effects for a professional looking video.

Overview of the Video Sequence Editor Window

Video Sequence Editor in Sequence display mode

The Video Sequence Editor has a header (where the menu and mode are shown) and a workspace, and works in one of four modes. In Sequence mode, the workspace is horizontally-striped into channels, and each video strip will go in a horizontal channel. Each channel is numbered on the left-hand side, starting from 0 (you can't put anything thing in this special one!) and going up; the picture to the right shows three channels (zero to two). Stripes toward the bottom are more dominant, which we'll get to in a minute. In the x direction, seconds of animation or frames of animation (T to choose) are used as the measure of time (seconds 1 through 7 are shown). You can scale the time using the zoom keys or mouse actions (see the Reference for more info).

Enable Sequence Output

When you click Render or Anim to generate an image or video, Blender has a choice of what image to compose for the current frame/scrub range:

  • Current Scene layer result
  • Sequence Editor channel 0 result
  • Composition Node Editor renderlayer result

Tell Blender to use the output of the Video Sequence Editor by enabling "Do Sequence" in the Buttons Window, Scene Render buttons, Anim panel.

View Menu

As usual, this menu controls what and how you view in the workspace.

Mode: Sequence

Hotkey: ⇧ ShiftSpace, CtrlUparrow, CtrlDownarrow

Menu: View -> Maximize Window

Use this when working arranging a lot of strips and you want to use all of your screen to work.

Mode: Sequence

Hotkey: T

Menu: View -> Show Frames, View -> Show Seconds

Time toggles the units of measure across the bottom of the workspace between seconds and frames. Seconds depends on the Frames/second setting in the Scene Render Format panel in the Buttons window.

Mode: Sequence

Menu: View -> Lock Time to Other Windows

Locking Time to other windows means that if you change your position in time (by left-clicking in the workspace to move your vertical green cursor), other windows will update as well to reflect what the video will look like at that time.

Mode: Sequence

Hotkey: . NumPad

Menu: View -> View Selected

Zooms in the display to fit only the selected strips

Mode: Sequence

Hotkey: ↖ Home

Menu: View -> View All

Zooms (out) the display to show all strips

Mode: Sequence

Hotkey: ⇧ ShiftAltA

Menu: View -> Play Back Animation in 3D View

Plays the animation for the selected scrub frame range in all windows: In VSE windows, shows you their respective display (Image, Chroma, Luma). In any 3D windows, shows you the objects moving.

Mode: Sequence, Image, Chroma, Luma

Hotkey: AltA

Menu: View -> Play Back Animation

Plays the animation for the selected scrub frame range in the window.

Select Menu

This menu helps you select strips.

Mode: Sequence

Hotkey: A

Menu: Select -> Select/Deselect All

Selecs all the strips loaded.

Mode: Sequence

Hotkey: B

Menu: Select -> Border Select

Begins the Box mode select process. Click and drag a rectangular lasso around a region of strips in your Sequence workspace. When you release the mouse button, the additional strips will be selected.

Add Menu

Mode: Sequence

Hotkey: Space

Menu: Add

This is the main menu you will be using. In general, you load up your strips, create strips of special transition effects, and then animate out your sequence by selecting "Do Sequence" and clicking the Anim button. You can use the Add menu in the header, or hover your mouse cursor over the Sequence workspace and press Space.

Clips can be Huge
A three minute quicktime .mov file can be 140Megs. Loading it, even over a high-speed LAN can take some time. Don't assume your computer or Blender has locked up if nothing happens for awhile.

Add Movie and Image (Stills or Sequences)

First, let's add a clip:

  • A movie clip in the Audio-Video Interleaved format (*.avi file)
  • A movie clip in the Apple QuickTime format (*.mov)
  • A single still image to be repeated for a number of frames (*.jpg, *.png, etc.)
  • A numbered sequence of images (*-0001.jpg, *-0002.jpg, *-0003.jpg, etc, of any image format)
  • One or more images from a directory
  • A Scene in your .blend file.

Blender does not care which of these you use; you can freely mix and match any of them. They all become a color-coded strip in the VSE:

  • Blue is used for Avi/mov codec strips
  • Grey is a single image that is repeated/copied
  • Purple is an image sequences or group of images played one after the other
  • Green is an Audio track

When you choose to add one of these, the VSE window will switch to a file browser for you to select what you want to add. Supported files have a little rectangle next to their name (blue for images, green for clips) as a visual cue that you can pick them successfully:

  • When adding a Movie or Movie+Audio:
LMB Template-LMB.png LEFT CLICK to put the name of the file into the text box at the top; this selects a single file (like a movie)
  • In the case of (numbered) image sequences, you have a choice:
Directory: RMB Template-RMB.png right-click on a directory name, and all files in that directory will be brought in as part of the image, in sort order, one image per frame
Range: Navigate into the directory and right-click and drag over a range of names to highlight multiple files. You can page down and continue right-click-dragging to add more to the selection
Batch: Shift-right-click selected non-related stills for batch processing; each image will be one frame, in sort order, and can be a mix of file types (jpg, png, exr, etc.)
All: Press A to select/deselect All files in the directory.

When you click the Select <whatever> button, the window pane will switch back to VSE, and the strip will be rubber-banded to your mouse. You cannot load multiple movies at the same time by right-clicking them; no movies load if you right click them. Right-clicking only works for images.

Error: The selected file is not a movie or FFMPEG support not compiled in!
means that the file is not a movie that Blender can recognize, or you selected with the wrong button. You get this error message because you right-clicked on a movie file, OR you don't have a codec that can decode the avi file. If it's the latter, find a codec so you can play the file outside of Blender, and then you will be able to load it. If it's the former, you must left-click to select movies.

In order to add items to the VSE, left-click for movies, left-click for single images, or right-click and drag for image sequences. Move your mouse to the frame/time and stripe you want, and click to break the rubberband and drop the strip in place (in a channel and starting at a frame).

When you add an image, Blender makes it into a 50-frame strip, which means that image will be in your video for two seconds (at 25 fps – PAL). Aside from re-positioning it, you will want to scale it by RMB Template-RMB.png-clicking on either the start or end arrow, and dragging left or right. As you move, the frame number updates to say where the arrow is. Click LMB Template-LMB.png to validate, or RMB Template-RMB.png to cancel the modification.

Blender3D FreeTip.gif
Dealing with Different Sizes
Dealing with different sized images and different sized outputs is tricky. Think like a pixel. If you have a mis-match between the size of the input image and the render output size, the VSE does try to auto-scale the image to fit it entirely in the output. This may result in clipping. If you do not want that, use Crop and/or Translate in the Input panel to move and select a region of the image within the output. When you use Crop or Translate, the auto-scaling will be disabled and you can manually re-scale by adding the Transform effect.
Manual-VSE-sample.png

If you scroll up the workspace, you will see an information channel (at vertical location channel 0) that gives you some helpful hints about the active strip. The example below shows a color strip from frames 1 to 25, then a mov file, and then an image strip. The info channel shows handy information about the image strip, whose name has been scrunched in the strip display, but is clearly spelled out in the information strip.

9999 frames go by (IMAGE strips only!)
Ok, so that was a very obscure reference to a song about 99 balloons, but we really have not anticipated how fast Blender has moved into mainstream video editing. Unfortunately, we initially reserved 4 digits for the filename of each video image sequence set. While that provides for up to 400 seconds of video (about 5 minutes US), with Blender moving into movies, you need to break up IMAGE strips into 4 digits only, and others 5 digits (10000-19999), (20000-29999), etc. Important: that only affects IMAGE strips at the moment. All the other strip types work fine with up to 300,000 frames (approximately 3 hours, read: Ben Hur :) ).
Codecs
You must have a codec on your machine that can decode the avi file. Blender does not control these. For example, the XviD codec is available from www.xvid.org
FFMPEG Support
If you are using a Blender build with FFMPEG support, you will be able to load audio and video strips together; select Movie+Audio(HD) and when you drop the strip, the strip will split into an audio and video channel strips.


Add Scene

You can add the virtual image output of a Scene in your current .blend file as well. Select the scene from the popup list, and a strip will be added and rubberbanded to your mouse just like a movie or image. The strip length will be determined based on the animation settings in that scene (not the current scene, unless the VSE is operating in the same scene).

When adding a Scene strip, please note that, in order to show you the strip in the VSE Image preview mode, Blender must render the scene. This may take awhile if the scene is complex, so there may be a delay between the time you select the scene and the time the strip appears. To reduce the delay, simplify the scene rendering by selecting fewer layers to render.

Add Audio

The VSE can incorporate an audio channel which you can hear as you scrub. Add an audio track when you are trying to time your video/animation to an audio track, or vice versa. Please refer to the Audio Sequences section for more information.

Add Effect

Available Built-in Effects

Blender offers two categories of effects: Built-in and Plug-in. The built-in effects are listed to the right. They are built-in to Blender and everyone has them. The plug-in effects are separate files in a sequence-plugin directory on your PC that are loaded as they are needed. While a standard set of plugins are distributed when you installed Blender, everyone's computer may have a different set.

Mode: Sequence

Hotkey: Space

Menu: Add -> Effect

Every Built-in effect is explained later individually, but they all are added and controlled in the same way. To add an effect strip, select one base strip (image, movie, or scene) by RMB Template-RMB.png clicking on it. For some effects, like the Cross transition effect, you will need to ⇧ ShiftRMB Template-RMB.png a second overlapping strip (it depends on the effect you want). Then select Add -> Effect and pick the effect you want from the pop-up menu. When you do, the Effect strip will be shown above the source strips. If it is an independent effect, like the color generator (described later), it will be rubberbanded to your mouse; click to drop the strip.

Since most Effects strips depend on one or two source strips, their frame location and duration depends on their source strips. Thus, you may not be able to move it; you have to move the source strips in order to affect the effect strip.

To use an effect that combines or makes a transition between (or composites) two strips, you must Box select or shift-right-click two of them. When you add the effect strip, it will be placed in a channel above the two in Grab mode (click to drop it on a channel). Its duration will be the overlap between the two strips as a maximum.

With some effects, like the AlphaOver, the order in which you select the strips is important. You can also use one effect strip as the input or source strip with another strip, thus layering effects on top of one another.

Note: The only exception is the Color Generator effect. It does not depend on a base strip; you can add and position it independent of any other strip. Change the length as you would any strip.

Mode: Sequence, Effects Strip Selected

Hotkey: C

Menu: Strip -> Change Effect

If you picked the wrong effect from the menu, you can always change it by selecting the strip (RMB Template-RMB.png) and using the Strip->Change Effect selection. Or, you can press Change to switch effects on a selected Effects strip.

Adding Plugin Effects

Manual-VSE-Plugins.png

Sequence Plugins are special little routines written by special programmers in the C language as a dynamic load library (.DLL). A DLL can be loaded at any time (dynamically) as it is needed, so it "plugs in" to Blender. (In case you wondered: the extension is platform dependent. These files are named .so (shared object) on Linux e.g.)

The image to the right shows the Sequence DLL's that I have available on my system. Each of them do some special effect indicated by their name or as explained on the Blender Resource Page for Plugins or programmer website. For example, the Iris plugin transitions between two strips by opening an expanding hole in the middle of the first and letting the second one show through, like an iris of a camera opening up. Some of these plugins can be five or more years old and still work very well; Blender tries to ensure backward compatibility, and they should work independent of output format or resolution (size).

Animating Audio/Video Effects

Animating the Add Effect

The degree to which some effects manipulate the image (called a Factor) can be controlled over time. For example, over the course of 100 frames, you can vary the factor from 0 to 1, then down to 0.5, then back up to 1.0. You do this by defining an Ipo Curve for that effect. Some effects (Add, Multiply) can be animated through the Ipo curve; others (Color Generator, Glow) are controlled through the Properties panel.

To the right is an example of animating the Add effect to produce the effect that lightning has. To add control points in the Ipo Window, CtrlLMB Template-LMB.png click anywhere, and a Factor curve will be added. In this case, we have added gray to our image in a jagged Ipo set. When (or if you have already) gotten into nodes, the use of this Factor is the same in many nodes, especially the Mix node. By default, when you add a special effect, like a Cross, Blender provides a smooth transition to the new picture, from 0.0 to 1.0, over the duration of the frames (the sfx strip). In the case of an add or multiply or subtract effects, Blender add the effect immediately, and keeps it there; the factor jumps to 1.0 and stays at 1.0. Now, we know how much you all like to control things, so you have the Ipo Window that can operate on a strip, or Sequence. This is why there is an Ipo Window in the upper left-hand corner of the screen layout. In general you:

  • Select the effect strip
  • Decide whether you want the Ipo curve to be relative to the start of the first base strip, or locked to the global frame number. If you want it locked to the global frame counter, enable the IPO Frame locked button
  • Ctrl-LMB Template-LMB.png click control points in the Ipo window (Sequence mode) to define the transition factor and timing. To make a smooth transition to the final effect, just define one point at the starting frame with a Fac of 0.0, and another point at the ending frame with a Fac of 1.0. You can define a jagged curve with lots of points to get a very dynamic effect.

Not all effects can be animated; The built-in Glow is fixed, but there is an AnimGlow plugin which can be animated. Add, Multiply, Divide, Subtract, and Transform effects are always animatable.

Animating an audio strip affects the volume of the strip in the resulting composite. Use IPO animation on an audio strip to fade in/out background music or to adjust volume levels. Layered/crossed audio strips are added together; the lower channel does not override and cut out higher channels. This makes Blender an audio mixer. By adding audio tracks and using the IPO curves to adjust each tracks' sound level, you have an automated dynamic multi-track audio mixer!

To shorten the transition time of any effects strip (such as Cross, Wipe, or Transform) that operates on two strips, just shorten the duration by which the two strips overlap. This will result in a change to the length of the effects strip.

If Ipo Frame locked is enabled, Blender will use the Fac value from frame x in the Ipo window to apply the Effect at frame x in the VSE window. If it is disabled, the Ipo curve is relative to the start of the first base strip. Generally, you want the transition effect to be relative to the strips they operate on, but in certain matching moves or transitions, you can lock it to a specific frame.

Strip Menu

This menu allows you to operate on video strip(s) as a whole.

Mode: Sequence

Hotkey: M, AltM

Menu: Strip -> Make Meta Strip, Separate Meta Strip

A Meta-Strip is a group of strips. Select all the strips you want to group, and Make them into one meta. The meta spans from the beginning of the first strip to the end of the last one, and condenses all channels into a single strip, just like doing a mixdown in audio software. Separating (ungrouping) them restores them to their relative positions and channels.

Mode: Sequence

Hotkey: X, ⇧ ShiftD

Menu: Strip-> Delete, Duplicate

If you have added a strip by mistake or no longer want it, delete it by pressing X or using this menu option. Duplicate a strip to make an unlinked copy; drag it to a time and channel, and drop it by LMB Template-LMB.png click.

Mode: Sequence

Hotkey: K

Menu: Strip -> Cut at Current Frame

While splicing two strips happens just by placing them finish-to-start, cut a strip by pressing K to cut. At the selected frame for the selected strips, K cuts them in two. Use Kut to trim off roll-ups or lead-ins, or roll-downs or extra film shot ("C" was already taken for Change).

Note on the 'cut'
When you 'cut' a strip, you don't really make a cut like it was with the 'old editing' on real film. In fact, you make a copy of the strip: the end of the original one is 'winded' to the cut point, as with the beginning of the new copy.

For example, imagine that you have a strip of 50 frames, and that you want to delete the first ten ones. You have to go to the 11th frame, and hit K; the cut 'divides' your strip in two parts. You now can select the first small part (frames 1 to 10), and delete it hitting X.
You might think that you have really erased the frames 1 to 10, but there are still there, 'winded', as in a film reel, under your frame 11: you just have deleted one of the tow copies of your strip created by the 'cut'. And you can at any time get your 'lost' frames back (just RMB Template-RMB.png-click on the left arrow of the strip, then Grab it to the left to display the desired number of frames again (or to the right to 'hide' more frames – this is another way to remove frames at the beginning/end of a strip!).

This is at the heart of nearly every editor solution, and that's quite handy!


Mode: Sequence

Hotkey: ⇧ ShiftS

Menu: Strip -> Snap to Current Frame

Position your cursor (vertical green line) to the time you want. Snap to current frame to start a strip exactly at the beginning of the frame. If your Time display is in seconds, you can get to fractional parts of a second by zooming the display; you can get all the way down to an individual frame.

Mode: Sequence

Hotkey: G

Menu: Strip -> Grab

Moves the selected strip(s) in time or in channels. Move your mouse horizontally (left/right) to change the strip's position in time. Move vertically (up/down) to change channels. Moving a strip above (to a higher channel) and over another strip means that it will not display during the overlap; lower channel strips are displayed "in front" of higher channels – WARNING: this is exactly the opposite that what happens with most of the other video editors! To get them both to be seen, you have to mix them using the Add, Multiply, Subtract or other compositing effects.

Mode: Sequence

Hotkey: Y

Menu: Strip -> Separate Images to Strips

Converts the strip into multiple strips, one strip for each frame. Very useful for slide shows and other cases where you want to bring in a set on non-continuous images.

Strip Properties

Blender 2.46 expanded the Strip properties from one panel to an entirely new Render (F10) subcontext.

Blender 2.46+

Mode: Sequence, Effects Strip selected

Menu: Buttons Window, Render Context (F10), Sequence sub-context

Strip Properties Panels

The properties for the strip are examined and set in various panels in the Buttons Window, Render Context, Sequence sub-context. Until we get around to documenting all of these new features, please see the Release Notes.

  • Input - where to pull images from
  • Filter - Image pre-processing
  • Proxy - Use representatives of the real image, for low-powered PCs
  • Edit - change properties of the strip

The panels for each of these sets of options and controls are shown to the right

Input Strip Properties Panel

Controls the source of the strip. Fields include filename, current frame, and auto-crop and auto-translate features, as well as an offset for starting and ending the strip.

This is here you can edit/update the path of the file used by a strip. Very useful when you moved it one way or the other – this avoid you deleting and re-creating the strip!

You have two text fields for path, the first being the path of the parent directory (Dir), and the second the file name itself.

Filter Strip Properties Panel

Enables you to quickly set common image pre-processing options.

Premul: Premultiply Alpha
Flip: X - flips (reverses) the image left-to-right, Y reverses top-to-bottom, and Time reverses strip image sequence
Use Color Balance provides three filters to adjust coloration: Lift, Gaussian, and one other. Each pass can have a positive, or inverted effect by clicking the appropriate button. Set the amount of the effect by setting the color swatch; white (RGB 1,1,1) has no effect.

Proxy Strip Properties Panel

A proxy is a smaller image (faster to load) that stands in for the main image. When you Rebuild proxy Blender computes small images (like thumbnails) for the big images and may take some time. After computing them, though, editing functions like scrubbing and scrolling and compositing functions like cross using these proxies is much faster but gives a low-res result. Disable proxies before final rendering.

Edit Strip Properties Panel

Name
You can name your strips
Blend Mode
By default, a strip Replaces the output image of any lower-level strips. However, many other blending modes are available based on the strip type. For example, Alpha-Over automatically overlays the image on top of a lower level strip. These autoblending modes obviates the need for separate effect strips. Blend percent controls how much of an (even over time) effect the strip exerts
Mute
Hides the strip so that it does not participate in the final image computation
IPO Frame Locked
Uses the Sequence IPO curve to determine the Blend percent.
Start
changes the starting frame number of the strip, which is the same as grabbing and moving the strip. Tip: when you add a strip, I like to just drop it and then use this field to place it at the frame I want, rather that trying to drag and drop in exactly the right place.

Chan

Changes the channel number of the strip, like G-Y.
Blender 2.45+

Mode: Sequence

Hotkey: N

Menu: Strip -> Strip Properties

Strip Properties

Press N to display a floating panel that shows you properties for the object selected; in this case a video Strip. By default, the name of a strip shown in the workspace is its filename. You can name strips by LMB Template-LMB.png clicking in the Name: field and entering a descriptive name; the workspace will display that name.

Use the Convert to Premul button if a strip has an Alpha (transparency) channel. Use FilterY if the strip is from broadcast video and has even or odd interlacing fields. Enhance the color saturation through the Multiply field. Play a strip backwards by enabling Reverse Frames. Tell Blender to display every nth frame by entering a Strobe value. Finally, when using MPEG video (VCD, DVD, XVid, DivX, …), an image is built up over the course of a few frames; use the Preseek field to tell Blender to look backward and compose the image based on the n previous frames (e.g. 15 for Mpeg2 DVD).

For all effects, use the Strip Properties panel to control the effects strip; each effect has different controls, but they can all be set in the Properties panel. Control the length of the strip to vary the speed with which the transform happens. Regardless of whether they are built-in or plug-in, all effect strips do some special image manipulation, usually by operating on another strip or two in a different channel. The effect strip is shown in some channel, but its resultant effect shows up as Channel 0.


Working with Strips

Here are some common tasks that you will want to perform within the VSE.

Scrubbing

To move back and forth through your movie, use the Timeline window. LMB Template-LMB.png click and drag left/right in the timeline window, moving the vertical bar which indicates the current frame. As you do, the image for that frame is displayed in the VSE window.

Real-time scrubbing and image display is possible on reasonable computers when viewing an image sequence or movie (avi/mov) file. Scene images have to be rendered individually, which may take some time.

Selecting and Changing the Length of a Strip

To edit a movie or image strip:

  • RMB Template-RMB.png in the middle of the strip selects the entire strip; holding it down (or pressing Grab) and then moving the mouse drags a strip around.
  • RMB Template-RMB.png on the left arrow of the strip selects the start frame offset for that strip; holding it down (or pressing Grab and then moving the mouse left/right changes the start frame within the strip by the number of frames you move it:
    • If you have a 20-image sequence strip, and drag the left arrow to the right by 10 frames, the strip will start at image 11 (images 1 to 10 will be skipped). Use this to clip off a rollup or useless lead-in.
    • Dragging the left arrow left will create a lead-in (copies) of the first frame for as many frames as you drag it. Use this when you want some frames for transitions to the this clip.
  • RMB Template-RMB.png on the right arrow of the strip selects the end frame of the strip; holding it down (or pressing Grab) and then moving the mouse changes the ending frame within the strip:
    • Dragging the right arrow to the left shortens the clip; any original images at the tail are ignored. Use this to quickly clip off a rolldown.
    • Dragging the right arrow right extends the clip. For movies and images sequences, more of the animation is used until exhausted. Extending a clip beyond its end results in Blender making a copy of the last image. Use this for transitions out of this clip.
Multiple selection
You can select several (handles of) strips by ⇧ ShiftRMB Template-RMB.png-clicking: when you'll hit G, everything that's selected will move with your mouse – this means that, for example, you can at the same time move a strip, shorten two others, and extend a forth one.
  • STRIP EXTEND. With a number of Image strips selected, pressing E enters EXTEND mode. All selected strip handles to the "mouse side" of the current frame indicator will transform together, allowing you to essentially extend the strips that fall exactly on the current frame marker and having all others adjust to compensate.
  • Additional Selection Methods
    • AltRMB Template-RMB.png and CtrlRMB Template-RMB.png on a strip will select the Left or Right handle of that strip and the neighboring handle on the next strip. Select with this method to move the boundary between two adjoining strips without affecting the outer limits.
    • AltCtrlRMB Template-RMB.png on a strip will select both handles of the strip, plus the neighboring handles on the immediately adjoining strips. Select with this method to move a strip that is between to others without affecting the selected strip's length.
Action Stops
When extending the start beyond the beginning or end after the ending, keep in mind that only the last image copies, so when viewed, action will stop on that frame. Start your transition (fade, cross) a little early while action is still happening so that the stop action is not that noticeable (unless, of course, you want it to be, like the 80's drama sitcoms).


Change the length of an effect strip by changing the start/end frame of the origin strips.

Zoom, Scale Display and Refresh Header Buttons

Zoom, Scale and Refresh buttons

These buttons are found throughout Blender on a window's header. LMB Template-LMB.png Click and drag the +/- button left and right to scale the display around the cursor (the vertical green line). Moving left zooms out, and right zooms in across frames. Moving up and down zooms in and out of channels.

Clicking the crosshair puts your mouse in a box-select mode. Select a region of the workspace by LMB Template-LMB.png clicking and dragging over a rectangular region of the workspace. When you release the mouse, the workspace display will zoom in to fit that region in your entire display.

Certain operations, like moving an object in 3D View, may not force the Sequencer to call for a refresh of the rendered image (since the movement may not affect the rendered image). If an image or video, used as a strip, is changed by some application outside of Blender, Blender has no real way of being notified from your operating system. To force Blender to re-read in files, and to force a re-render of the 3D View, click the Refresh button to force Blender to update and synchronize all cached images and compute the current frame.

Reverse Action

In the sequence buttons in the scene buttons (F10), select "flip time" in the "filters" panel.

Slow Motion, Fast Forward, Time Warp

Use the built-in Speed control strip documented on the next page.

Rendering a Video to an Image Sequence Set

In many cases, cuting and re-arranging (editing) a codec-encoded video strip will give you fits, because of the encoding algorithm that is used internally to reconstruct each image gets 'off' by a frame or two or three. To work directly on the 'raw' frame set, a very common technique is to import your video as a strip and render it out to series of individual frames, where each frame is stored in its own image file (JPG most commonly). To do so, Add->Movie and load your original video. Set your Format SizeX and SizeY (either to match the original, or different if you want to distort or upscale/downscale the video), set image type to JPEG, adjust your Quality settings, and in the Anim panel set your End: to the number of actual frames in the video strip. Click ANIM and a series of number files will be output to the top filespec in the Output panel. You can now delete the video strip, and Add->Image instead, and right click on the directory name to pull in all of the images, in sequence, that are within that directory. Now, when you cut at frame 4321, for example, the next frame of the second strip will really start with frame 4322.

Rendering a Video from an Image Sequence Set

Ridiculously easy (when you learned where the buttons are):

  1. Add the sequence of images as described above
  2. Set your Output file path and name to wherever you want to save the movie file (e.g. C:\My Documents\MyMovie) in the upper output box of the render buttons.
  3. Change your Format to a movie file format (AVI, MOV, FFMPEG) and CODEC
  4. Set your framerate to match whatever framerate the sequence is to be played back in. Under the Anim/Playback buttons.
  5. Set your ANIM End: to the number of images in the sequence, and
  6. ANIM

The single movie file is created and saved; the name is what you specified but with the starting frame and ending frame numbers appended (e.g. MyMovie0000-0250.avi)