From BlenderWiki

Jump to: navigation, search

Weight Paint Mode

The Weight Paint mode is used to create and modify vertex groups. A vertex may not only be a member of one or more vertex groups, but also may have a certain weight in each group. The weight symbolizes its influence on the result.

Image 1: Changing to Weight Paint mode.

Mode: Weight Paint mode

Hotkey: Ctrl⇆ Tab

Menu: Mode menu (Image 1)

When you change to Weight Paint mode you see the selected object (if you have not created any groups yet), in a slightly shaded, blue color (Image 2).

Image 2: An object in Weight Paint mode.

The color visualizes the weight of each vertex of the currently active group. A vertex drawn in blue indicates either: a weight of zero, not in the active group, or not in any group at all.

You assign the weight of each vertex by painting on the mesh with a certain color. Starting to paint on a mesh will automatically creates a new vertex weight group (when no group existed or is active). If a vertex doesn’t belong to the active group it is automatically added (if the option Vgroup is not set), even if you paint with a weight of “0”. The used color spectrum is shown in (Image 3).

Image 3: The color spectrum and their respective weights.

You paint on the mesh with a brush. The color only influences the vertices, neither the faces nor the edges. So don’t try and paint these. There is a tool panel for the brush in the Editing context (F9) as well as in the 3D Window (press N to open it).

Blender3D FreeTip.gif
Weight Painting survival tips
A few tips that will save you some hassle when painting weight:
  • Press F in Weight Paint mode to activate the Face select mode. Now you can select faces to paint and Hide faces like in Edit mode.
  • Press B to border-select faces to paint using LMB Template-LMB.png. Use the RMB Template-RMB.png border select to exclude the selected faces from painting.
  • Draw a Clipping Border with AltB. It will separate a visible part of the 3D window. You can draw only in this part. If you press AltB again the clipping border will be removed.
  • Turn off Soft in the Paint panel. If you have Soft activated you will reach the target value only after several repeated paint actions, and it’s especially difficult to reach 0.0.


Paint Panel

Image 4: The Paint panel in the Editing context.

The tools in the Paint panel are sophisticated, and you can apply weight in the finest nuances. But normally you won’t need all these options, and you will apply weight using a few techniques. The most used and important settings are drawn in bold.

  • Weight: The weight (color) that is used to paint. The button row below contains five weight presets to paint. By default, painting works with an absolute fixed amount (like Gimp or Photoshop defaults), so you can set for example “0.2 weight” to vertices while keeping the mouse button pressed, whatever their original weight was.
  • Opacity: The extent to which the vertex color changes while you are painting.
  • Size: The size of the brush, which is drawn as a circle during painting.
  • Spray: The Spray option accumulates weights on every mouse move.
  • Mix/Add/…: The manner in which the new color replaces the old when painting.
    • Mix: The new color replaces the old color. Applying more and more of the new color will eventually turn it the new color.
    • Add: The new color is added to the old. Note that you must think in weight here (not in RGB colors): adding blue (0.0) to something won’t modify it, adding green (0.5) to green will give red (1.0), …
    • Sub: The new color is subtracted from existing. Here again you have to think in terms of “weight”, and not “RGB colors”.
    • Mul: The new color is multiplied by the old.
    • Filter: Paint based on alpha value.
    • Lighter: Only paints vertices “darker” (lower weight) than the current “color”, “lightening” them.
    • Darker: Only paints vertices “lighter” (higher weight) than the current “color”, “darkening” them.
  • All faces: If this is turned off, you will only paint vertices which belong to a face on which the cursor is. This is useful if you have a complicated mesh and you would paint on visually near faces that are actually quite distant in the mesh.
  • Vertex Dist: Paints only on vertices which are actually under the brush. If you switch this off, all vertices belonging to faces touched by the brush are painted. If you have a sparse mesh and use subsurfaces you want to keep this on.
  • Soft: This specifies that the extent to which the vertices lie within the brush also determine the brush’s effect. It’s extremely difficult to paint with zero then. You want to turn this off in all normal situations.
  • Normals: The vertex normal (helps) determine the extent of painting. This causes an effect as if painting with light.
  • Vgroup: Only vertices which belong to the active vertex group are painted. Very useful for clearing up and refining vertex groups without messing other groups up.
  • X-mirror: Use the X-mirror option for mirrored painting on groups that have symmetrical names, like with extension .R/.L, or _R/_L. If a group has no mirrored counterpart, it will paint symmetrical on the active group itself. You can read more about the naming convention in Editing Armatures: Naming conventions. The convention for armatures/bones apply here as well.
  • Wire: Show additionally the wireframe of the objects. Since it shows the subsurfaced wire it’s quite useless. It’s better to use the Select mode (see below).
  • Clear: Removes all vertices from the active group.


Tools

If you have a complex mesh it is nearly impossible to reach all vertices in Weight Paint mode. And it is quite difficult to tell where the vertices are exactly. But there’s a very good and easy solution: the Select mode.

Mode: Weight Paint mode

Hotkey: F

Image 5: Select menu in Weight Paint mode.

Select mode has many advantages over the normal Weight Paint mode:

  1. The original mesh is drawn, even when subsurface is active. You can see the vertices you have to paint over.
  2. You can select faces, only the vertices of selected faces are painted on.
  3. Selecting tools include:
    • RMB Template-RMB.png – Single faces. Use ⇧ ShiftRMB Template-RMB.png to select multiple.
    • A – All faces, also to de-select.
    • B – Block/Box selection.
    • BB – Select with brush.
    • CtrlL – Select linked.
    • In the Select menu: Faces with Same UV, also invert selection (Inverse).
  4. You may hide selected faces with H and show them again with AltH (Image 6).


Image 6a: Select interfering faces…
Image 6b: … and hide them with H.
Image 7: A vertex belonging to two vertex groups.
  • To constraint the paint area further you may use the Clipping Border. Press AltB and LMB Template-LMB.png-drag a rectangular area. The rest of the 3D window is hidden. To show everything again, just hit another time AltB.
  • If you want to know which groups a vertex belongs use ⇧ ShiftLMB Template-LMB.png. You can change between the groups in the appearing pop-up menu (Image 7).
  • N in the 3D window opens a Weight Paint Properties panel instead of the Transform Properties panel (Image 8).
Image 8: Weight Paint Properties panel in the 3D window.


Scripts in Paint Menu

Weight Gradient
This script is used to fill the selected faces with a gradient (Image 3 & Image 9). To use the script, select the faces you wish to apply the gradient to. Click twice on the mesh to set the start and end points of the gradient. The color under the mouse will be used for the start and end blend colors, so you have to weight paint first. Holding ⇧ Shift or clicking outside the mesh on the second click will blend the first color to nothing.
Image 9: Setting the gradient and result.
Normalize/Scale Weight
Maximizes weights to a user set peak and optionally scales other groups too to keep the proportion of the weights even.
Grow/Shrink Weight
Uses the mesh topology to expand/contract the vertex weights (works like color bleeding).
Clean Weight
Removes vertices with low weights from the current group.


Weight Painting for Bones

This is probably the most often used application of weight painting. When a bone moves, vertices around the joint should move as well, but just a little, to mimic the stretching of the skin around the joint. Use a “light” weight (10-40%) paint on the vertices around the joint so that they move a little when the bone rotates. While there are ways to automatically assign weights to an armature (see the Armature section), you can do this manually. To do this from scratch, refer to the process below. To modify automatically assigned weights, jump into the middle of the process where noted:

  • Create an armature.
  • Create a mesh that will be deformed when the armature’s bone(s) move.
  • With the mesh selected, create an Armature modifier for your mesh (located in the Editing context, Modifiers panel). Enter the name of the armature.

Pick up here for modifying automatically assigned weights.

  • Select the armature in 3D View, and bring the armature to Pose mode (Ctrl⇆ Tab, or the 3D View window header mode selector).
  • Select a desired bone in the armature.
  • Select your mesh (using RMB Template-RMB.png) and change immediately to Weight Paint mode. The mesh will be colored according to the weight (degree) that the selected bone movement affects the mesh. Initially, it will be all blue (no effect).
  • Weight paint to your heart’s content. The mesh around the bone itself should be red (generally) and fade out through the rainbow to blue for vertices farther away from the bone.

You may select a different bone with RMB Template-RMB.png. If the mesh skins the bones, you will not be able to see the bones because the mesh is painted. If so, turn on X-Ray view (Buttons window, Editing context, Armature panel). While there on that panel, you can also change how the bones are displayed (Octahedron, Stick, B-Bone, or Envelope) and enable Draw Names to ensure the name of the selected bone matches up to the vertex group.

If you paint on the mesh, a vertex group is created for the bone. If you paint on vertices outside the group, the painted vertices are automatically added to the vertex group.

If you have a symmetrical mesh and a symmetrical armature you can use the option X-Mirror. Then the mirrored groups with the mirrored weights are automatically created.

Weight Painting for Particles

Weight painted particle emission.

Faces or vertices with zero weight generate no particles. A weight of 0.1 will result in 10% of the amounts of particles. This option “conserves” the total indicated number of particles, adjusting the distributions so that the proper weights are achieved while using the actual number of particles called for. Use this to make portions of your mesh hairier than others by weight painting a vertex group, and then calling out the name of the vertex group in the VGroup: field (Particles panel, Object context).



Introduction
What is Blender?
Introduction
Blender’s History
License
Blender’s Community
About this Manual
What's changed with Blender 2.4
Installing Blender
Introduction
Python
Installing on Windows
Installing on GNU/Linux
Installing on Mac
Installing on other Operating Systems
Configuring Blender
Directory Layout
Starting
The Interface
Introduction
Keyboard and Mouse
Window System
Arranging frames
Headers
Console window
Window Types
Screens (Workspace Layouts)
Scenes
Configuration
Modes
Contexts
Menus
Panels
Buttons and Controls
Internationalization
Your First Animation
1/2: A static Gingerbread Man
2/2: Animating the Gingerbread Man
The Vital Functions
Quick render
Undo and Redo
Default scene
Screenshots
Help!
Setting Preferences
Configuring Preferences
Interface
Editing
Themes
File
System
Interaction in 3D
Introduction
Introduction
Navigation
Introduction
3D View
3D View Options
3D View Usage
Camera View
Layers
Local or Global View
Sketch in 3D Space
Introduction to Grease Pencil
Drawing sketches
Layers and Animation
Converting sketches to geometry
Transformations
Introduction
Basics
- Grab/Move
- Rotate
- Scale
- Gestures
Advanced
- Mirror
- To Sphere
- Shear
- Warp
- Push/Pull
Transform Control
Introduction
Precision of Transformations
Numeric Transformations
Transform Properties
Reset Object Transforms
Manipulators
Transform Orientations
Axis Locking
Pivot Point
- Active object
- Individual Centers
- 3D Cursor
- Median Point
- Bounding Box Center
Snapping
Snap to Mesh
Proportional Edit
Data System and Files
Blender's Data System
Blender's Library and Data System
Blender's Datablocks
Scenes
Working with Scenes
The Outliner Window
Appending and Linking
File operations
Introduction
Opening blender files
Saving blender files
Modeling
Introduction
Introduction
Objects
Objects
Selecting Objects
Editing Objects
Groups and Parenting
Tracking
Duplication
- DupliVerts
- DupliFaces
- DupliGroup
- DupliFrames
Mesh Objects
Meshes
- Mesh Structures
- Mesh Primitives
Selecting
- Selectable Elements
- Selection Basics
- Advanced Selecting
- Selecting Edges
- Selecting Faces
Editing
Basic Editing
- Translation, Rotation, Scale
- Adding Elements
- Deleting Elements
- Creating Faces and Edges
- Mirror editing
Vertex Editing
Edge Editing
Face Editing
Deforming Tools
- Mirror
- Shrink/Fatten Along Normals
- Smooth
- Noise
Duplicating Tools
- Duplicate
- Extrude
- Extrude Dup
- Spin
- Spin Dup
- Screw
Subdividing Tools
- Subdivide
- Subdivide fractal
- Subdivide smooth
- Loop Subdivide
- Knife Subdivide
- Bevel
Miscellaneous Tools
Retopo Tool
Sculpt Mode
Multi Resolution Mesh
Vertex Groups
Weight Paint
Mesh Smoothing
Curve Objects
Curves
Selecting
Editing
Advanced Editing
Surface Objects
Surfaces
Selecting
Editing
Text Objects
Texts
Editing
Meta Objects
Metas
Editing
Empty Objects
Empties
Group Objects
Groups
Scripts
Modeling Scripts
Modifiers and Deformation
Introduction
Introduction
Modifiers Stack
Modify
UVProject
Generate
Array
Bevel
Booleans
Build
Decimate
EdgeSplit
Mask
Mirror
Subsurf
Deform
Armature
Cast
Curve
Displace
Hooks
Lattice
MeshDeform
Shrinkwrap
SimpleDeform
Smooth
Wave
Simulate
Cloth
Collision
Explode
Fluid
Particle Instance
Particle System
Soft Body
Lighting
Introduction
Introduction
Lights
Introduction
Light Properties
Light Attenuation
Light Textures
What Light Affects
Lights In Other Contexts
Shadows
Introduction
Shadow Properties
Raytraced Shadow Properties
Volumetric Lights
Introduction
Lamps
Introduction
Lamp Light
- Raytraced Shadows
Spot Light
- Raytraced Shadows
- Buffered Shadows
- Halos
Area Light
- Raytraced Shadows
Hemi Light
Sun Light
- Raytraced Shadows
- Sky & Atmosphere
Lighting Rigs
Radiosity
Introduction
Rendering
Baking
Scene Light
Ambient Light
Ambient Occlusion
Exposure
Exposure
Materials
Introduction
Introduction to Shading
Materials Introduction
Usage
Assigning a material
Material Preview
Material Options
Multiple Materials
Properties
Diffuse Shaders
Specular Shaders
Ambient Light Effect
Color Ramps
Raytraced Reflections
Raytraced Transparency
Subsurface Scattering (SSS)
Strands
Node Materials
Material Nodes
Nodes Editor
Node Controls
Nodes usage
Nodes Groups
Material Node Types
- Input Nodes
- Output
- Color
- Vector
- Convertor
- Dynamic
Vertex Paint
Using Vertex Paint
Halos
Halos
Textures
Introduction
Introduction
UV/Image Editor
Common Options
Texture Stack
Texture Types
Texture Types
Procedural Textures
Image Textures
Video Textures
Texture Nodes
- Nodes Editor
- Node Controls
- Nodes usage
- Nodes Groups
-- Textures Input Nodes
-- Textures Output Nodes
-- Textures Color Nodes
-- Textures Patterns Nodes
-- Textures Textures Nodes
-- Textures Convertor Nodes
-- Textures Distort Nodes
Texture Plugins
Texture Painting
Painting the Texture
- Projection Paint
Mapping
Mapping
Environment Maps
UV Unwrapping Explained
- Unwrapping a Mesh
- Managing the UV Layout
- Editing the UV Layout
- Applying an Image
Influence
Influence
- Material
-- Bump and Normal
-- Displacement
- Particles
- World
World and Ambient Effects
World
Introduction
World Background
Ambient Effects
Mist
Stars
Rigging
Introduction
Introduction to Rigging
Armatures
Armature Objects
Panels overview
Bones
Visualization
Structure
Selecting
Editing
- Bones
- Properties
- Sketching
- Templating
Skinning
Introduction
Linking Objects to Bones
Skinning to Objects’ Shapes
Retargeting
Posing
Introduction
Visualization
Editing Poses
Pose Library
Using Constraints
Inverse Kinematics
Constraints
Introduction
Introduction
Constraints Common Interface
Constraints’ Stack
Transform Constraints
Copy Location
Copy Rotation
Copy Scale
Limit Distance
Limit Location
Limit Rotation
Limit Scale
Transformation
Tracking Constraints
Clamp To
IK Solver
Locked Track
Stretch To
Track To
Relationship Constraints
Action
Child Of
Floor
Follow Path
Null
Rigid Body Joint
Script
Shrinkwrap
Animation
Introduction
Introduction
The Timeline
Markers
3D Views
Animation Editors
Animation Editors
Ipo Editor
Ipo Curves and Keyframes
Ipo Datablocks
Ipo Types
Ipo Editor Interface
Editing
- Ipo Curves
- Keyframes
Ipo Drivers
Action Editor
Editing Action Channels
NLA Editor
Editing NLA Strips
Strip Modifiers
Animation Techniques
Introduction
Animating Objects
- Using Constraints
- Moving Objects on a Path
Animating Shapes
- Shape Keys
- Editing Shape Keys
- Animating Shape Keys
- Shape Keys Examples
Indirect Shape Animation
Animating Armatures
- Stride
Animating Lamps
Animating Cameras
Animating Materials
Animating Textures
Animating World
Physical Simulation
Introduction
Introduction
Dynamics
Force Fields
Collisions
Particles
Particles
Types
Physics
- Newtonian
- Keyed
- Boids
Visualization
Controlling Emission, Interaction and Time
Cache & Bake
Hair
Children
Vertex Groups
Particle Mode
Soft Body
Introduction
Exterior Forces
Interior Forces
Collisions
Simple Examples
Combination with Armatures
Combination with Hair Particles
Reference
Cloth
Introduction
Fluids
Fluid
Using the Game Engine
Using the Game Engine
Rendering
Introduction
Introduction
Camera
The Camera
Perspective (Vanishing points)
Depth Of Field
Render
Displaying Renders
Basic Options
Antialiasing (Oversampling)
Rendering Animations
Panoramic
Render Baking
Using the Command Line
Output
Output
Video Output
Effects and Post Processing
Introduction
Render Layers
Render Passes
Edges & Toon
Stamp
Color Management & Exposure
Depth Of Field
Motion Blur
Render Performance
Rendering Performance
Distributed Rendering
External Render Engines
Introduction
YafRay
Compositing with nodes
Composite Nodes
Introduction
Nodes Editor
Node Controls
Nodes usage
Nodes Groups
Composite Node types
Composite Node types
Input Nodes
Output Nodes
Color Nodes
Vector Nodes
Filter Nodes
Convertor Nodes
Matte Nodes
Distortion Nodes
Editing Sequences
Introduction
Introduction
The sequencer
Usage
Sequencer Modes
Sequence Screen Layout
Effects
Built-in Effects
Plugin Effects
Audio
Audio Sequences
Extending Blender
Introduction
Introduction
Python Scripting
Python Scripting in Blender
Setting up Python
The Text Editor
A working example
References
Python Scripts
Script Catalog
Bundled Scripts
Plugins
Blender's Plugins System
Texture plugins specifications
Sequence plugins specifications
Game Engine
Introduction
Introduction
The Logic Editor
Usage
Game Properties
Sensors
Introduction
Sensor Types
Controllers
Introduction
Expressions
Actuators
Introduction
Action
Camera
CD
Constraint
Edit Object
Ipo
2D Filters
Game
Message
Motion
Parent
Property
Random
Scene
Shape Action
Sound
State
Visibility
Cameras
Cameras
Dome Camera
Physics
Physics Engine
Material Physics
Object Types
- Static
- No Collision
- Dynamic
- Rigid Body
- Soft Body
- Occluder
- Sensor
Python API
Bullet physics
VideoTexture
Various resources
List of Features
External resources
Game Engine Basics (BSoD Tutorial)
FAQ