From BlenderWiki

Jump to: navigation, search


What is Blender?

Blender is an open source software package for 3D modeling, animation, rendering, post-production, and gaming. Initially developed by Ton Roosendaal's company NaN in the Netherlands, its popularity, and capabilites, have grown over the years. There is a large and active user base with ongoing development by dedicated hackers, making Blender a powerful and viable 3D software solution.

While not in its infancy, Blender is also not as fully-fleshed out as some other major software packages such as Lightwave, 3D-Studio Max, and XSI. Nevertheless, Blender is comparable in many arenas, and its unique user interface makes using it very efficient.

Blender's modeling capabilities, while excellent, are by some users supplemented by the Wings3D subdivision surface modeler.

The user interface looks strange. What's the idea behind it?

Blender's user interface is based on splittable and joinable windows. The main system is basically a grid with edges splitting the parts. The edges can be freely manipulated. Each window has a window type.

Actually even the main menu at the top of the screen is a window. It is a window that contains settings of Blender. The window can be dragged downwards to reveal these settings. The menu can be put anywhere you like on the screen or even disabled. This is a big difference compared to conventional software.

Each window contains a header. Header contains basic menus and commands. You can move the header by using middle mouse button for instance to find more commands. Menus contain the shortcuts to the commands and can hence be used as reference when needed.

One of the most important windows in Blender is the Buttons Window. Buttons Window consists of panels that can have subpanels. Panels have been categorized and their contents may vary depending on mode you are working in. You can find essential commands and tools such as rendering settings there.

You can have multiple workspaces on Blender to accommodate fast working. You can create new workspaces at whim and move between them fast. Creating and deleting workspaces is possible by using drop down menu next to main menu (just right to Help). You can move between them by using Ctrl or Ctrl arrow. Ctrl and Ctrl arrow can be used to maximize\minimize the window your mouse is in.

Note that windows are context sensitive based on mouse location. Shortcut keys work based on mouse location!

Adding/Removing windows

Blender separates its display into areas, or windows.

To add a window you'll need to split an existing window area.

  1. Move the cursor to the very edge of the window you wish to split. The cursor will change shape to a double-pointed arrow.
  2. RMB Template-RMB.png-click to get a pop-up menu.
  3. Choose Split Area.
  4. Position the new edge of the window and click to accept. Press Esc to abort.
  5. Click the little square button on the left end of the new window header (or menu bar) and choose a window type for the new window.

To remove a window you'll need to join it with (or swallow it by) an an adjacent window area.

  1. Move the cursor to the edge separating the window to remove and the window to take its area. If you are using Blender 2.37a or earlier: first place the cursor in the window you wish to keep then move it to the edge between the windows. For Blender 2.40+ it doesn't matter.
  2. RMB Template-RMB.png-click to get the pop-up menu.
  3. Choose Join Areas.
  4. If you are using Blender 2.40+ move the cursor to the window you wish to remove. A big arrow will appear to confirm that the other window will consume that area. Click the mouse to agree.

Headers

Every window (or area) has a header bar, more commonly called a menu bar. The header bar groups buttons and information for the most useful things you can do in that area along with the area's drop-down menus.

You can change the type of window displayed in the area by clicking on the little square button on the right end of the header bar.

You can position the header at the top or bottom of the window area, and you can hide or show the header. To do so, RMB Template-RMB.png-click on the header or the edge between areas. To show the header, you must first place the mouse cursor in the area to affect, then move it to the edge of the area and RMB Template-RMB.png-click.

I can't see the whole header!

Relax. Just place the mouse pointer anywhere in the header and drag it left or right with the middle mouse button.

You can also decrease the size of the header by hiding the menus. Click on the little arrow at the right end of the header bar. Click it again to get your menus back.

Window Types

Blender separates its display into areas, or windows. Each area can display a different information. When you first start Blender, you'll see three areas: the 3D View, the Buttons Window, and the main menu along the top of the screen which belongs to the User Preferences window. There are many more.

(Please note, updated documentation for all the window types is not yet available. Most of the links here are to documentation for a fairly old version of Blender, since it is not entirely irrelevent. As new documentation becomes available this list should be updated.)

As of Blender 2.42, the following areas are available:

Scripts Window   Provides access to all registered Blender Python scripts and a place for GUI scripts to draw in.
File Browser   You don't generally need to access this one directly.
Blender will use this window whenever it asks you to load and save.
Image Browser   Like the File Browser, but shows thumbnails of image files it finds on disk.
Node Editor   A newly introduced and very exciting way to handle materials borrowed from Softimage|XSI's powerful render tree editor.
Buttons Window   This is easily the most complex and the most used window type. It is worth your time to become very familiar with it. Many of Blender's powerful features are found inside.
Outliner   This window has its uses... particularly if you are searching for some small object in a complex .blend file.
User Preferences  

Provides the Blender main menu. Also allows you to manipulate things like:

  • mouse and widget display and user interaction
  • undo buffer size
  • defaults for object data linking
  • international languages
  • themes
  • autosave
  • OpenGL lighting, memory, etc.
  • system sound, video, etc.
  • file paths
Text Editor   A very simple plain-text editor with syntax highlighting and editing features for Python scripting
Audio Window   Used for audio sequencing. Also check out Manual/Audio Sequences.
Timeline   A new window to help with animation editing and playback.
Video Sequence Editor   Postproduction editing. See also this tutorial.
NLA Editor   The Non-Linear Animation editor is one of the most powerful features in Blender. With it you can blend actions and object IPOs (both forms of animation sequences) together.
Action Editor   This is another useful, and well-used, animation editor in Blender. Aligorith is currently refactoring its design and code to improve it [1].
IPO Curve Editor   IPO is short for interpolated. All animation is interpolation between keys, or values at a specific time. Values include: position, rotation, color, action, etc. Learning about IPOs is very important for animation.
3D View   This is where you will spend much of your time creating, editing, positioning, and animating objects.

How do I save?

Press F2.

You can also save the current file by pressing CtrlW or CtrlS.

In either case, if you try to save over an existing file Blender will give you a pop-up asking if you really want to overwrite it. Press ↵ Enter or click the pop-up to accept. Press Esc or move the mouse away to abort.

How do I import objects or models from other blender files?

  1. Press ⇧ ShiftF1 or choose FileAppend... from the main menu.
  2. Click on the .blend file from which you wish to import something.
  3. You'll be given a list of choices. In general, you'll only want to click on Object, Material, or IPO. (Don't click on the other things unless you know what you are doing. You won't hurt anything, but you'll confuse yourself.) To import an object or model, click Object.
  4. Blender will give you a list of all the objects in the file. If you are only interested in one item, click on it. You can hold down ⇧ Shift and RMB Template-RMB.png click or drag the mouse to select multiple items.
  5. Click Load Library.

Can Blender be customized?

Yes, you can build directly from CVS or modify it to your own needs, as long as you comply with the GPL License. This requires C (and for the game engine, C++) programming knowledge. Visit the Blender Developer's Forums to get started.

Other forms of customization are Python scripting and Plug-In modules. Python scripting is very robust and provides capabilities from simplistic run and quit menu actions to complex graphical user interfaces. Plug-In modules come in two types: Sequence and Texture.

To get started with Python scripting, you'll need to know Python, of course. See http://www.python.org to get started. Once you are familiar with the language, you should visit this wiki's Main Page for Blender-specific information. Another excellent resource is at the Blender Artists Forums where there is a Python and Plugins forum.

Writing plug-in modules requires a bit more programming experience. Familiarize yourself with how they work by visiting the Blender's Plugins System chapter of the Blender User's Manual.

Can Blender copy to the system clipboard?

Short answer: Mostly no.

Long answer:

The system clipboard is primarily designed to exchange simple kinds of data used by a wide variety of application programs: text, images, etc. Blender is a specialized application that operates on large amounts of complex data that does not fit any commonly available clipboard data format. Other programs would simply not know what to do with the data that Blender copied to the clipboard.

To further complicate things, each windowing system (Windows, KDE, Gnome, CDE, OSX, etc.) has its own way of sending and receiving data to and from the system clipboard. Even on the same system different window managers manage the clipboard differently. For Blender to support even some systems would be difficult at best.

A better and more reliable way to transfer your 3D data between programs is to export your data (from the File menu at the top of the screen) to a file format that the other program you wish to use understands. For example, to edit Blender data using Autodesk's 3D-Studio, export to a 3DS file. You can then start 3D-Studio normally and simply load the exported file.

All that said, if you are using Microsoft Windows and you wish to use the clipboard to transfer plain text into or out of Blender's Text Editor, you have options.

Blender 2.37a

Cut: ⇧ ShiftAltX
Copy: ⇧ ShiftAltC
Paste: ⇧ ShiftAltP

Blender 2.40+

Cut: not available
Copy: ⇧ ShiftCtrlC
Paste: ⇧ ShiftCtrlP

It is not an advertized feature so you may have to play around with ⇧ Shift key combinations before you find something that works.

Can Blender add file extentions automatically?

In general, no. Only very recently has automatic file extension capabilities been added to Blender, but not consistently –it is supported in some locations and not in others. As of 2.40+, saving blend files (*.blend) and saving rendered images (by pressing F3) does automatically append the correct file extension. In general, however, it is best to make sure that you specify the full filename, including extension, in save dialogues.

Does Blender support multi-processor computers?

Blender supports multi-threading in rendering, so yes. (At least, it's supposed to)

How do I move the cursor in Blender?

As usual, Blender provides a variety of ways to do this, depending on your convenience.

You can simply LMB Template-LMB.png-click where you want it. Remember that you are working in three-dimensional space, so you will have to check from at least two different views to position it exactly (for example, Top and Side view).

You can open the ViewView Properties... panel, from which you can enter exact coordinates for the 3D Cursor.

You can press ⇧ ShiftS to pop-up the Snap menu, giving you the choice to position the cursor at the currently-selected object(s)/vertices or to the closest grid junction.

How do I print from Blender?

You cannot print from Blender.

Save your image to file, then use a dedicated image processing program like Adobe Photoshop or The Gimp.

What is a widget?

A widget is a visual tool used to move, rotate, or scale things interactively in Blender. In Softimage|XSI they are called manipulators, and they work the same way (basically).

Each widget gives you colored handles which you can click on and drag to manipulate an object. Each handle is color coded to identify with one of the three coordinate axes:

  • The x-axis is red
  • The y-axis is green
  • The z-axis is blue

Thus, dragging a red handle moves, rotates, or scales your object along the x-axis.


There are three widgets, shown here by themselves without any object data attached and with their keyboard shortcut:

FAQ-Transform widget icon-2.gifTransform CtrlAltG FAQ-Rotate widget icon-2.gifRotate CtrlAltR FAQ-Scale widget icon-2.gifScale CtrlAltS
FAQ-Transform widget-2.jpg FAQ-Rotate widget-2.jpg FAQ-Scale widget-2.jpg


The coordinate system used to manipulate the object is by default the global coordinate system, but you can choose others:

FAQ-Widget popup-2.jpg
  • Global - The all-encompassing static coordinate system. It is displayed by a grid in 3D View. Should be sufficient for most purposes.
  • Local - The object's coordinate system. If the object is rotated this will be rotated as well.
  • Normal - If you have a selection in Editmode this will align the manipulator along the normal of the selected geoemtry.
  • View - The coordinate system relative to your current 3D View (i.e. how you look at it)


You'll also want to keep an eye on the pivot point when using the manipulator widgets. Objects scale and rotate relative to the location indicated by the current pivot point.

FAQ-Pivot point-2.jpg
  • Active Object uses only the last-selected object's center, no matter how many objects are actually selected. No shortcut key.
  • Individual Centers All selected objects rotate about their own center. Shortcut key: Ctrl. (Ctrl-Period, not on the numeric keypad)
  • 3D Cursor All selected objects rotate about the 3D Cursor. Shortcut key: . (Period, not on the numeric keypad)
  • Median Point The point that lies between all currently selected objects/vertices/etc. Shortcut key: ⇧ Shift, (Shift+Comma).
  • Bounding Box Center Shortcut key: , (Comma).


That last button on the 3D View header bar, between the pivot point and the widget manipulator controls, is the move object centers only button. Use it if you want to rotate or scale one or more object's position(s) without changing the orientation or scale of the object itself.

See Blender3d.org for more information on manipulator widgets.

How do I undo in Blender?

Press CtrlZ to undo. If you are in edit mode, press the U key.

Is there a redo button?

Er, well there's no button, but like undo you can redo using keyboard shortcuts.

Press CtrlY to redo. If you are in edit mode, press ⇧ ShiftU to redo.

How do I change the number of undos?

This is easily done, but you must be careful.

  1. If Blender is running, exit.
  2. Start Blender.
  3. Move the mouse cursor up so that it is above the line between the main menu and the 3D View window at the top of the screen. The cursor should change shape to an up/down arrow.
  4. Click and drag the menu down. This will reveal the User Preferences window (the main menu is really just the header to the User Preferences window).
  5. Click the button labeled Edit Methods.
  6. Use the slider labeled "Editmode undo:" to change the number of steps Blender can undo.
  7. Drag the menu back up to the top of the screen.
  8. Press CtrlU. This saves the default state Blender uses when it is started –including your undo/redo cache size. If you omit this last step, Blender will forget your changes to the undo/redo cache size the next time it starts.

How do I import objects\etc. from other .blend file to other?

Use Append\Link found in File menu. Browse to the .blend from which you want to import and select for instance Object if you want to import object.

How do I set background image to a 3D viewport?

Go to View menu found in the header of a 3D viewport and select Background Image... . Click "Use Background Image" on the new window that just appeared. Then browse suitable image and alter the settings as you like.

Alternative way is to use a mesh plane, unwrap it, add image to it as a texture and scale it the aspect ratio of the image (AltV).

How do I restore default settings of Blender?

Delete .b.blend found in <blender directory>\.blender\ and restart Blender.